Entrar com a conta da Microsoft
Entre ou crie uma conta.
Olá,
Selecione uma conta diferente.
Você tem várias contas
Escolha a conta com a qual você deseja entrar.
Usar um leitor de tela para criar um gráfico em um formulário nos bancos de dados da área de trabalho do Access

Este artigo destina-se a pessoas com deficiências visuais ou cognitivas que usam um programa de leitor de tela, como o Narrador do Microsoft, JAWS ou NVDA com produtos Microsoft 365. Este artigo faz parte do conjunto de conteúdo de suporte do leitor de tela do Microsoft 365 onde você pode encontrar mais informações de acessibilidade em nossos aplicativos. Para ajuda geral, visite a página Inicial do Suporte da Microsoft.

Use Access teclado e um leitor de tela para criar um gráfico de pizza, coluna ou linha em um formulário. Nós o testamos com o Narrator, o JAWS e o NVDA, mas pode funcionar com outros leitores de tela, desde que eles sigam os padrões e as técnicas comuns de acessibilidade. Você também aprenderá a formatar, ressarcar ou mover um gráfico.

Você pode adicionar um gráfico a um formulário para visualizar seus dados. Você pode vincular o gráfico a uma tabela ou consulta e personalizar o gráfico com uma variedade de propriedades.

Para saber mais sobre gráficos e como decidir qual gráfico você deve criar, vá para a seção Escolher o melhor tipo de gráfico para suas necessidades em Criar um gráfico em um formulário ou relatório.

Observações: 

Neste tópico

Criar um gráfico

Para criar com êxito um gráfico em Access, ata o gráfico a uma fonte de dados, como uma tabela ou consulta, e mapeie campos às dimensões do gráfico.

  1. Navegue até o formulário no qual você deseja criar o gráfico e pressione Shift+F10. O menu de contexto é aberto. Pressione D para abrir o formulário no Design View.

  2. Para selecionar um tipo de gráfico, pressione Alt+J, D, H, 1. O menu gráfico é aberto. Siga um destes procedimentos:

    • Para criar um gráfico de pizza, pressione P.

    • Para criar um gráfico de colunas, pressione C.

    • Para criar um gráfico de linha, pressione L.

  3. Pressione Enter. Um gráfico de espaço reservado é inserido no formulário. O painel Gráfico Configurações abre.

  4. Para mover o foco para o painel Gráfico Configurações, pressione F6 até ouvir um item no painel. Talvez seja necessário pedir a um colega para ajudá-lo a identificar o painel.

  5. Se necessário, para mover o foco para a guia Dados, pressione Shift+Tab até ouvir a guia atual. Em seguida, pressione a tecla De seta direita até ouvir: "Guia Dados". As propriedades da guia são exibidas.

  6. Para selecionar ou alterar o tipo de fonte de dados do gráfico, pressione a tecla Tab até ouvir "Fonte de dados", seguido pelo tipo de fonte atual, por exemplo "Tabela". Para alterar o tipo de fonte de dados, pressione a tecla de seta Esquerda ou Direita até ouvir o tipo de origem que deseja.

  7. Pressione a tecla Tab uma vez. Você ouvir o nome da fonte de dados atual, seguido de "Caixa de combinação". Se não houver nenhuma fonte de dados selecionada, você ouvirá: "Caixa de combinação". Para selecionar ou alterar a fonte de dados, pressione a tecla de seta para baixo até ouvir a fonte que deseja e pressione Enter.

    Por padrão, o diagrama de amostra é substituído por um gráfico dinâmico que usa os dois primeiros campos na fonte de dados como as dimensões Eixo (Categoria) e Valores (Eixo Y). Geralmente, a primeira coluna de uma tabela é uma chave primária, talvez você não queira usá-la como uma dimensão em um gráfico.

  8. Para criar um gráfico, você precisa selecionar pelo menos dois campos nas opções Eixo (Categoria),Legenda (Série)e Valores (Eixo Y). Para mover para uma opção, pressione a tecla Tab até ouvir a opção que deseja, por exemplo "Axis, category". Pressione a tecla de seta para cima ou para baixo até ouvir o campo que deseja. Se o campo for apresentado como uma caixa de seleção, pressione Barra de Espaços para selecioná-lo. Se o campo for um botão de opção, ele será selecionado automaticamente conforme você o move. Para obter mais informações sobre cada opção e o que eles fazem com o gráfico, vá para a seção Configurações de dados, etapa 3, em Criar um gráfico em um formulário ou relatório.

Formatar seu gráfico

Você pode formatar o gráfico e seus vários elementos. Você também pode formatar séries de dados individuais, que são um conjunto de valores em uma coluna, linha ou fatia de pizza que correspondem à legenda do gráfico. As opções de formatação dependem do tipo de gráfico.

Para obter informações detalhadas sobre as propriedades da série de dados que você pode formatar, vá para a seção Format settings, etapa 3, em Criar um gráfico em um formulário ou relatório.

Formatar um gráfico de pizza

Você pode modificar as propriedades de um gráfico de pizza usando o painel Folha de Propriedades. Talvez seja necessário pedir a um colega para ajudá-lo a selecionar as propriedades que deseja modificar na etapa 8.

  1. Abra o formulário com o gráfico na exibição Design conforme instruído em Criar um gráfico.

  2. Pressione F6 até ouvir "Workspace", seguido pelo nome do formulário.

  3. Para mover o foco para o gráfico, pressione a tecla Tab até ouvir o número do gráfico, por exemplo "Gráfico 19, recolhido".

  4. Pressione F4 para abrir o painel Folha de Propriedades.

  5. Pressione F6 uma vez. O foco se move para uma linha de propriedade no painel Folha de Propriedades. Você ouvir o número da linha, seguido pelo conteúdo da célula de propriedade.

  6. No painel Folha de Propriedades, as configurações que afetam a aparência do gráfico geralmente estão na guia Formatar. Para navegar até e selecionar uma guia, pressione a tecla Tab até ouvir o item de guia selecionado no momento, por exemplo, "Item da guia Dados, selecionado". Pressione a tecla de seta Esquerda ou Direita até ouvir: "Item da guia Formatar". As propriedades da guia Formatar são exibidas.

    Dica: Se você quiser inspecionar todas as propriedades de gráfico disponíveis, selecione a guia Todos.

  7. Para mover o foco para a lista de propriedades na guia selecionada, pressione a tecla Tab uma vez.

  8. Para procurar as propriedades da guia selecionada, pressione a tecla de seta para cima ou para baixo. Para expandir submenus, pressione Tecla de seta Alt+Down. Para selecionar um item em um submenu, pressione a tecla de seta Para Cima ou Para Baixo até ouvir a opção que deseja e pressione Enter para selecioná-lo. Para modificar campos de texto, digite um novo valor no campo.

  9. Para fechar o painel Folha de Propriedades, pressione F4.

Formatar uma coluna ou gráfico de linha

  1. Abra o formulário com o gráfico na exibição Design conforme instruído em Criar um gráfico.

  2. Pressione F6 até ouvir "Workspace", seguido pelo nome do formulário.

  3. Para mover o foco para o gráfico, pressione a tecla Tab até ouvir o número do gráfico, por exemplo "Gráfico 19, recolhido".

  4. Para mover o foco para o painel Gráfico Configurações, pressione F6 até ouvir um item no painel. Talvez seja necessário pedir a um colega para ajudá-lo a identificar o painel.

  5. Para selecionar a guia Formatar, pressione Shift+Tab até ouvir a guia atual e pressione a tecla De seta direita até ouvir: "Guia Formatar".

  6. Para mover o foco para a lista de propriedades na guia Formatar, pressione a tecla Tab uma vez.

  7. Para mover na guia Formatar, pressione a tecla SR+Tecla direita ou tecla de seta à esquerda. Para expandir menus, pressione Tecla de seta Alt+Down. Para navegar em um menu, pressione a tecla de seta para cima ou para baixo. Para selecionar uma opção, pressione Barra de Espaços ou Enter. Para modificar campos de texto, digite um novo valor no campo.

Redimensionar um gráfico

  1. Abra o formulário com o gráfico na exibição Design conforme instruído em Criar um gráfico.

  2. Pressione F6 até ouvir "Workspace", seguido pelo nome do formulário.

  3. Para mover o foco para o gráfico, pressione a tecla Tab até ouvir o número do gráfico, por exemplo "Gráfico 19, recolhido".

  4. Pressione teclas Shift+Arrow para ressar o gráfico. Você pode precisar de um colega para ajudá-lo a identificar dimensões adequadas para o gráfico.

Mover um gráfico

  1. Abra o formulário com o gráfico na exibição Design conforme instruído em Criar um gráfico.

  2. Pressione F6 até ouvir "Workspace", seguido pelo nome do formulário.

  3. Para mover o foco para o gráfico, pressione a tecla Tab até ouvir o número do gráfico, por exemplo "Gráfico 19, recolhido".

  4. Use as teclas de seta para mover o gráfico. Talvez você precise de um colega para ajudá-lo a identificar uma posição adequada para o gráfico.

Vincular um gráfico aos dados em um formulário ou relatório

Para fazer um gráfico interagir com os dados em um formulário ou relatório, vincule o gráfico à mesma fonte de dados que o formulário ou relatório. Em seguida, você pode definir um valor de campo correspondente para as propriedades de dados Link Child Fields e Link Master Fields do gráfico.

  1. Crie um formulário ou relatório vinculado a uma fonte de dados. Para obter instruções detalhadas, vá para Usar um leitor de tela para criar um formulário em bancos de dados da área de trabalho do Access ou Use um leitor de tela para criar um relatório em bancos de dados da área de trabalho do Access.

  2. No formulário ou relatório, adicione um gráfico conforme instruído em Criar um gráfico. Ao selecionar a fonte de dados, selecione a mesma fonte que no formulário ou relatório.

  3. Abra o formulário ou relatório no Design View conforme instruído em Criar um gráfico.

  4. Para mover o foco para o gráfico, pressione a tecla Tab até ouvir o número do gráfico, por exemplo "Gráfico 19, recolhido".

  5. Pressione F4 para abrir o painel Folha de Propriedades.

  6. Pressione F6 uma vez. O foco se move para uma linha de propriedade no painel Folha de Propriedades. Você ouvir o número da linha, seguido pelo conteúdo da célula de propriedade.

  7. Para navegar até e selecionar a guia Dados, pressione a tecla Tab até ouvir o item de guia selecionado no momento, por exemplo, "Item da guia Formatar, selecionado". Pressione a tecla de seta Esquerda ou Direita até ouvir: "Item da guia Dados". As propriedades da guia Dados são exibidas.

  8. Peça a um colega para ajudá-lo a mover o foco para a caixa de propriedades Link Child Fields ou Link Master Fields.

  9. Na caixa propriedade selecionada, pressione Shift+F10 para abrir o menu de contexto. Para abrir a caixa de diálogo Vinculador de Campo de Subformuidade, pressione B.

  10. A caixa de diálogo Linker de Campo de Subformuidade contém menus separados para os campos mestre e filho. Para mover na caixa de diálogo, pressione a tecla SR+Tecla direita ou tecla de seta à esquerda. Para expandir a lista de campos mestre ou filho, pressione Tecla de seta Alt+Down. Para procurar uma lista, pressione a tecla de seta para baixo. Para selecionar um campo ao que você deseja vincular, pressione Enter. Talvez seja necessário pedir a um colega para ajudá-lo a navegar na caixa de diálogo.

    Dica: Se você não tiver certeza de qual campo usar, pressione a tecla SR+Tecla direita até alcançar o botão Sugerir e pressione Enter para selecioná-lo. Access insere o campo recomendado na caixa de propriedades selecionada.

  11. Salve o formulário ou relatório.

  12. Verifique se o gráfico funciona conforme esperado no formato ouno relatório. Por exemplo, filtre o formulário ou relatório por um campo de categoria para atualizar o gráfico. Talvez seja necessário pedir a um colega para ajudá-lo a verificar o gráfico.

Confira também

Usar um leitor de tela para criar tabelas nos bancos de dados da área de trabalho do Access

Usar um leitor de tela para criar uma consulta nos bancos de dados da área de trabalho do Access

Usar um leitor de tela para criar um formulário nos bancos de dados da área de trabalho do Access

Usar um leitor de tela para exportar uma tabela do Access para uma pasta de trabalho do Excel

Usar um leitor de tela para trazer dados do Excel para acessar os bancos de dados da área de trabalho

Atalhos de teclado do Access

Usar um leitor de tela para explorar e navegar no Access

Suporte técnico para clientes com deficiências

A Microsoft quer proporcionar a melhor experiência possível para todos os clientes. Se você tiver alguma deficiência ou dúvidas sobre acessibilidade, contate o Answer Desk de Acessibilidade da Microsoft para obter assistência técnica. A equipe de suporte do Answer Desk Acessibilidade é treinada no uso de várias tecnologias adaptativas populares e pode oferecer assistência em espanhol, francês, inglês e na língua de sinais dos EUA. Acesse o site do Microsoft Answer Desk Acessibilidade para descobrir os detalhes de contato para a sua região.

Se for um usuário empresarial, comercial ou governamental, fale com o Answer Desk de Acessibilidade corporativo.

Precisa de mais ajuda?

Participar da discussão
Pergunte à comunidade
Obter suporte
Fale Conosco

Essas informações foram úteis?

Qual é o seu grau de satisfação com a qualidade do idioma?
O que afetou sua experiência?

Obrigado pelos seus comentários!

×