KB2484392 - CORREÇÃO: a coluna "xact_seqno" na tabela "MSrepl_errors" não registra uma linha ignorada no SQL Server 2008 ou no SQL Server 2008 R2 se você usar o parâmetro "-SkipErrors" no Agente de Distribuição

Aplica-se a
SQL Server 2008 SQL Server 2008 R2 SQL Server 2008 R2 Service Pack 1 SQL Server 2008 R2 Service Pack 2

A Microsoft distribui correções do Microsoft SQL Server 2008 ou SQL 2008 R2 como um arquivo para download. Como as correções são cumulativas, cada nova versão contém todos os hotfixes e todas as correções de segurança incluídas na versão anterior da correção do SQL Server 2008 ou SQL Server 2008 R2.

Sintomas

Considere o seguinte cenário:

  • Você configura uma replicação transacional no Microsoft SQL Server 2008 ou no SQL Server 2008 R2.

  • Você usa o parâmetro -SkipErrorsno Agente de Distribuição.

    Observação O parâmetro -SkipErrors é usado para ignorar erros na replicação transacional.

  • A seguinte mensagem de erro é exibida:

    Observação

    A linha não foi encontrada no Assinante ao aplicar o comando replicado.

  • Você usa a tabela MSrepl_errors para tentar localizar uma linha ou comando que falhou.

Nesse cenário, as colunas xact_seqno e command_id na tabela MSrepl_errors não registram a linha ignorada. Além disso, a coluna xact_seqno contém o seguinte valor incorreto:

0x0000000000000000000000000000

Resolução

Informações sobre a atualização cumulativa

SQL Server 2008 R2 Service Pack 1

                
A correção para esse problema foi lançada pela primeira vez na Atualização Cumulativa 1 para o SQL Server 2008 R2 Service Pack 1. Para obter mais informações sobre como obter esse pacote de atualizações cumulativas, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:

2544793 Pacote de atualizações cumulativas 1 para o SQL Server 2008 R2 Service Pack 1Observação: como os builds são cumulativos, cada nova versão de correção contém todos os hotfixes e todas as correções de segurança incluídas na versão anterior de correção do SQL Server 2008 R2. Recomendamos que você considere aplicar a versão de correção mais recente que contém esse hotfix. Para obter mais informações, clique no número abaixo para ler o artigo da Base de Dados de Conhecimento Microsoft:

2567616 As compilações do SQL Server 2008 R2 lançadas após o SQL Server 2008 R2 Service Pack 1

SQL Server 2008 Service Pack 2

A correção para esse problema foi lançada pela primeira vez na Atualização Cumulativa 3 para o SQL Server 2008 Service Pack 2. Para obter mais informações sobre esse pacote de atualização cumulativa, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:

2498535 Pacote de atualização cumulativa 3 para o SQL Server 2008 Service Pack 2Observação: como os builds são cumulativos, cada nova versão de correção contém todos os hotfixes e todas as correções de segurança incluídas na versão anterior de correção do SQL Server 2008. A Microsoft recomenda que você considere aplicar a versão de correção mais recente que contém esse hotfix. Para obter mais informações, clique no número abaixo para ler o artigo da Base de Dados de Conhecimento Microsoft:

2402659 As compilações do SQL Server 2008 lançadas após o lançamento do SQL Server 2008 Service Pack 2 Os hotfixes do Microsoft SQL Server 2008 são criados para service packs SQL Server específicos. Você deve aplicar um hotfix do SQL Server 2008 Service Pack 2 a uma instalação do SQL Server 2008 Service Pack 2. Por padrão, qualquer hotfix fornecido em um service pack do SQL Server é incluído no próximo service pack do SQL Server.

SQL Server 2008 Service Pack 1

A correção para esse problema foi lançada pela primeira vez na Atualização Cumulativa 12 para o SQL Server 2008 Service Pack 1. Para obter mais informações sobre esse pacote de atualização cumulativa, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:

2467236 Pacote de atualizações cumulativas 12 para o SQL Server 2008 Service Pack 1Observação: como os builds são cumulativos, cada nova versão de correção contém todos os hotfixes e todas as correções de segurança incluídas na versão anterior de correção do SQL Server 2008. A Microsoft recomenda que você considere aplicar a versão de correção mais recente que contém esse hotfix. Para obter mais informações, clique no número abaixo para ler o artigo da Base de Dados de Conhecimento Microsoft:

970365 As compilações do SQL Server 2008 lançadas após o lançamento do SQL Server 2008 Service Pack 1 Os hotfixes do Microsoft SQL Server 2008 são criados para service packs SQL Server específicos. Você deve aplicar um hotfix do SQL Server 2008 Service Pack 1 a uma instalação do SQL Server 2008 Service Pack 1. Por padrão, qualquer hotfix fornecido em um service pack do SQL Server é incluído no próximo service pack do SQL Server.

SQL Server 2008 R2

                
A correção para esse problema foi lançada pela primeira vez na Atualização Cumulativa 7. Para obter mais informações sobre como obter esse pacote de atualizações cumulativas para o SQL Server 2008 R2, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:

2507770 Pacote de atualizações cumulativas 7 para o SQL Server 2008 R2 Observação Como os builds são cumulativos, cada nova versão de correção contém todos os hotfixes e todas as correções de segurança incluídas na versão anterior de correção do SQL Server 2008 R2. Recomendamos que você considere aplicar a versão de correção mais recente que contém esse hotfix. Para obter mais informações, clique no número abaixo para ler o artigo da Base de Dados de Conhecimento Microsoft:

981356 As compilações do SQL Server 2008 R2 lançadas após o SQL Server 2008 R2

Status

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Referências

Para obter mais informações sobre como ignorar erros na replicação transacional, visite o seguinte site do Microsoft Developer Network (MSDN):

Como ignorar erros na replicação transacional
        
Para obter mais informações sobre MSrepl_errors, visite o seguinte site do MSDN:

Informações gerais sobre a instrução MSrepl_errors Transact-SQL Para obter mais informações sobre o Incremental Servicing Model para o SQL Server, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:

935897 Um Modelo de Manutenção Incremental foi disponibilizado pela equipe de SQL Server para fornecer hotfixes para problemas relatados Para obter mais informações sobre o esquema de nomenclatura para atualizações de SQL Server, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft:

822499 Novo esquema de nomenclatura para pacotes de atualização de software do Microsoft SQL Server Para obter informações adicionais sobre a terminologia de atualização de segurança, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):

824684 Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft