KB2544793 - Pacote de atualizações cumulativas 1 para o SQL Server 2008 R2 Service Pack 1

Aplica-se a
SQL Server 2008 R2

INTRODUÇÃO

Os pacotes de atualização cumulativa contêm hotfixes para os problemas do Microsoft SQL Server 2008 R2 Service Pack 1 (SP1) que foram corrigidos desde o lançamento do SQL Server 2008 R2 SP1.

Observação A compilação deste pacote de atualização cumulativa é conhecida como compilação 10.50.2769.0.

Recomendamos que você teste os hotfixes antes de implantá-los em um ambiente de produção. Como os builds são cumulativos, cada nova versão de correção contém todos os hotfixes e todas as correções de segurança incluídas na versão anterior de correção do SQL Server 2008 R2. Recomendamos que você considere aplicar a versão de correção mais recente que contém esse hotfix.

  Para obter mais informações, clique no número abaixo para ler o artigo da Base de Dados de Conhecimento Microsoft:

2567616 As compilações do SQL Server 2008 R2 lançadas após o SQL Server 2008 R2 Service Pack 1

Observações importantes sobre o pacote de atualização cumulativa

  • Os hotfixes neste pacote de atualização cumulativa estão incluídos no SQL Server 2008 R2 Service Pack 2 (SP2).
  • Os hotfixes do SQL Server 2008 agora são multilíngues. Portanto, um pacote de atualizações cumulativas pode ser aplicado a qualquer idioma com suporte.
  • Um pacote de atualizações cumulativas inclui todos os pacotes de componentes. Entretanto, o pacote de atualizações cumulativas só atualiza os componentes instalados no sistema.

Mais informações

Como obter o pacote de atualizações cumulativas 1 para o SQL Server 2008 R2 SP1

Um pacote de atualizações cumulativas com suporte já está disponível na Microsoft. No entanto, ele destina-se a corrigir apenas os problemas descritos neste artigo. Aplique-o somente a sistemas que estejam enfrentando esses problemas específicos. Esse pacote de atualizações cumulativas pode receber testes adicionais. Portanto, se você não for gravemente afetado por nenhum desses problemas, recomendamos que aguarde o próximo service pack do SQL Server 2008 R2 que contém os hotfixes neste pacote de atualização cumulativa.

Se a atualização cumulativa estiver disponível para download, existirá uma seção "Download de hotfix disponível" na parte superior deste artigo da Base de Dados de Conhecimento. Se esta seção não aparecer, contate o Serviço de Suporte e Atendimento ao Cliente Microsoft para obter o pacote de atualizações cumulativas.

Observação Se outros problemas estiverem ocorrendo ou se qualquer solução de problemas for necessária, talvez seja necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a outras questões e problemas de suporte não qualificados para esse pacote de atualizações cumulativas específico. Para obter uma lista completa dos números de telefone do Atendimento ao Cliente da Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:

/contactus/?ws=support

Os hotfixes incluídos neste pacote de atualizações cumulativas

  Os artigos da Base de Dados de Conhecimento Microsoft que discutem esses hotfixes serão lançados assim que estiverem disponíveis.

  Para obter mais informações sobre os problemas do SQL Server, clique nos números abaixo para ler os artigos na Base de Dados de Conhecimento Microsoft:

Número do bug VSTS Número do artigo KB Descrição
746726 2563924 CORREÇÃO: Erro "O fluxo de protocolo TDS (fluxo de dados tabular de entrada) está incorreto" quando a função SQLPutData insere o valor de SQL_NULL_DATA em um TVP no SQL Server 2008 R2
746739 2563216 CORREÇÃO: A imagem dinâmica não funciona em um cabeçalho ou rodapé de página no SSRS 2008 R2 se a expressão de valor usar o atributo Global! Variável PageNumber
746741 2559662 CORRECÇÃO: Desempenho lento ao renderizar um relatório que retorna uma longa sequência de texto no SSRS 2008 R2 se o texto não contiver caracteres de retorno de carro
746736 2547017 CORREÇÃO: Instâncias de funções DAX que não têm nomes aparecem incorretamente quando você adiciona um membro calculado a um relatório que usa um banco de dados SSAS 2008 R2 como fonte de dados
746734 2545989 CORREÇÃO: Erro "Ocorreu um tempo limite enquanto aguardava a trava do buffer" quando muitas transações atualizam simultaneamente um banco de dados no SQL Server 2008 R2 se o banco de dados usa o nível de isolamento snapshot
746725 2539378 CORREÇÃO: Replmerg.exe trava ao enumerar alterações em uma instrução no SQL Server se o procedimento armazenado contiver mais de 4.000 caracteres
746732 2539098 CORREÇÃO: Erro de tempo de execução: a propriedade DBPROP_MSMD_UPDATE_ISOLATION_LEVEL não pode ser encontrada" quando um aplicativo tenta criar uma conexão com o SSAS 2008 R2
746729 2535660 CORREÇÃO: A associação de função é sincronizada mesmo se o elemento SynchronizeSecurity estiver definido como o valor SkipMembership no SSAS 2008 ou no SSAS 2008 R2
718922 2532079 CORREÇÃO: As instruções DML não são executadas em algumas colunas em uma tabela depois de habilitar o CDC em algumas outras colunas no SQL Server 2008 R2
718953 2531172 CORREÇÃO: Erro "Não é possível obter o membro atual" ao executar uma consulta MDX no SQL Server 2008 R2 Analysis Services
746724 2530913 CORREÇÃO: "Erro: 17066" ocorre quando você cria um índice não clusterizado particionado no SQL Server 2008 R2 se um plano de execução paralela for usado
718941 2526959 CORREÇÃO: Problema de desempenho do aplicativo quando uma consulta faz referência a tabelas temporárias que são criadas em uma sessão no SQL Server 2008 e no SQL Server 2008 R2
730659 2525665 CORREÇÃO: SQL Server 2008 BIDS para de responder quando você para de depurar um pacote SSIS 2008 ou SSIS 2008 R2
718924 2522708 CORREÇÃO: O desempenho diminui depois que você move um relatório que contém uma grande lista de parâmetros suspensos de seleção múltipla para o SQL Server 2008 R2 Reporting Services
718910 2521127 CORREÇÃO: A janela PowerPivot não abre quando você abre um arquivo .xla ou .xlam no Excel 2010 se o PowerPivot para Excel 2010 estiver instalado
718923 2520240 CORREÇÃO: Erro de permissão ao exibir uma pasta usando o parâmetro "ViewMode=WebpartList" na cadeia de caracteres de consulta do Gerenciador de Relatórios no SQL Server 2008 R2 Reporting Services
718931 2519358 CORREÇÃO: Erro "O valor inteiro está fora do intervalo" quando você passa um valor bigint como o argumento last_sync_version da função CHANGETABLE no SQL Server 2008 ou no SQL Server 2008 R2
718946 2518876 CORREÇÃO: A consulta MDX retorna incorretamente valores NULL ou 0 para algumas medidas se um membro calculado é usado no eixo da linha no SSAS 2008 R2
718921 2518808 CORREÇÃO: "Expressão: (pCopySrc - comando) <= (int) cmdLength" erro ao adicionar uma coluna a uma tabela publicada em uma publicação transacional no SQL Server 2008 R2
718918 2516439 CORREÇÃO: "O script '/MDM/ScriptResource.axd' contém várias chamadas para Sys.Application.notifyScriptLoaded(). Apenas um é permitido" em um site do SQL Server 2008 R2 MDS
718897 2516163 CORREÇÃO: O construtor de relatórios 3.0 para de responder depois que você executa uma consulta mais de duas vezes em relação a um modelo de relatório no SSRS 2008 R2
718916 2515489 CORRECÇÃO: "Exception 0xc0000005 EXCEPTION_ACCESS_VIOLATION" e SQL Server 2008 R2 falha quando inicia uma sessão de evento SQL Server Extended
718949 2515286 CORREÇÃO: Erro "Não há função '{urn:schemas-microsoft-com:xml-sql}:variable()" para uma consulta XQuery que atualiza o valor de uma coluna XML no SQL Server 2005, no SQL Server 2008 ou no SQL Server 2008 R2
718933 2511151 CORRECÇÃO: Coluna de uma fonte de arquivo simples não é importada se os dados da próxima coluna é um byte mais longo do que a largura da coluna de saída no SSIS 2005, SSIS 2008 ou no SSIS 2008 R2
718940 2510668 Agora pode utilizar o Assistente de Instalação de Pacotes (Dtsinstall.exe) para executar o ficheiro de manifesto de implementação de um pacote SSIS quando o SSIS 2008 ou SSIS 2008 R2 não estiver instalado
718939 2509659 CORRECÇÃO: O esquema dbo é pré-anexado quando você usa um procedimento armazenado personalizado no procedimento armazenado sp_addarticle
718937 2506795 CORREÇÃO: Erro "Dados insuficientes para uma imagem" quando você abre um arquivo .pdf que é exportado de um SQL Server 2008 Reporting Services ou SQL Server 2008 R2 Reporting Services ambiente
718904 2504090 CORRECÇÃO: Violação de acesso quando você insere dados em uma nova partição de uma tabela particionada depois de soltar uma coluna da tabela no SQL Server 2008 R2
718901 2498818 CORREÇÃO: Erro 7359 quando você executa uma consulta em uma função definida pelo usuário ou um modo de exibição que usa um sinônimo em um servidor vinculado no SQL Server 2005, SQL Server 2008 ou SQL Server 2008 R2
718898 2492931 CORRECÇÃO: SSRS 2008 R2 falha quando você usa o SSRS 2008 R2 para renderizar o formato de metarquivo avançado (.emf) ou imprimir muitos relatórios ao mesmo tempo
718926 2491510 CORREÇÃO:Uma consulta que tem um predicado CONTAINS em uma cláusula WHERE leva muito tempo para ser compilada no SQL Server 2008 ou SQL Server 2008 R2
718899 2484392 CORRECÇÃO: A coluna "xact_seqno" na tabela "MSrepl_errors" não grava uma linha ignorada no SQL Server 2008 ou no SQL Server 2008 R2 se você usar o parâmetro "-SkipErrors" no Agente de Distribuição
718914 2481274 CORREÇÃO: Uma consulta que usa a função DATEDIFF pode ser executada lentamente no SQL Server 2005 ou no SQL Server 2008 ou no SQL Server 2008 R2
718936 2478514 CORRECÇÃO: O erro "O processo de mesclagem não pôde acessar dados de linha" ocorre quando o Agente de Mesclagem pára e linhas são definidas como 4 na coluna genstatus na tabela do sistema msmerge_genhistory
718930 2476322 CORREÇÃO: Uma consulta comum baseada em expressão de tabela que usa a função CHANGETABLE é executada muito lentamente no SQL Server 2008 Service Pack 1 ou SQL Server 2008 R2
718894 2451688 CORRECÇÃO: Erro "CPerIndexMetaQS::ErrorAbort - corrupção de índice" ao tentar atualizar um modo de exibição particionado no SQL Server 2008 R2
718925 968215 CORRECÇÃO: Mensagem de erro quando tenta inserir dados em massa numa tabela que contém uma coluna de tipo de data que utiliza um formato de data dos EUA no SQL Server 2008 ou no SQL Server 2008 R2: "Erro de conversão de dados de carregamento em massa"
693058
2526552 CORREÇÃO: SQL Server serviço de navegador periodicamente não responde a solicitações de entrada
721415 2550552 CORRECÇÃO: SQL Server comando pára de responder quando usa um caminho de acesso sem buffer para acessar um arquivo FILESTREAM no SQL Server 2008 R2

            
          

Informações sobre o pacote de atualizações cumulativas

Informações sobre reinicialização

  Talvez seja necessário reiniciar o computador após aplicar essa atualização cumulativa.

Informações do Registro

  Para usar um dos hotfixes no pacote, não é necessário fazer nenhuma alteração no Registro.

Como desinstalar este pacote de atualizações cumulativas

Para desinstalar este pacote de actualização cumulativa, siga estes passos:

  1. No Painel de Controle, abra a aplicação
    Adicionar ou remover programas
      item.

  2. Clique em
    Alterar ou remover programas.

  3. Para revelar todas as atualizações para a instalação do SQL Server 2008 R2, selecione a caixa Mostrar Atualizações marcar.

  4. Localize e desinstale a entrada para este pacote de atualização cumulativa.

Referências

  Para obter mais informações sobre o modelo de manutenção incremental para SQL Server, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:

935897
  Um Modelo de Manutenção Incremental foi disponibilizado pela equipe do SQL Server a fim de fornecer hotfixes para problemas relatados

  Para obter mais informações sobre o esquema de nomenclatura para atualizações SQL Server, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:

822499
  Novo esquema de nomenclatura para pacotes de atualização de software do Microsoft SQL Server
   Para obter informações adicionais sobre a terminologia da atualização de segurança, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):

824684
  Descrição da terminologia padrão utilizada para descrever as atualizações de software da Microsoft