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Sintomas

Considere o seguinte cenário:

  • Você instala o Internet Information Services (IIS) 7.5 em um computador que esteja executando o Windows 7 ou Windows Server 2008 R2.

  • Você hospedar alguns documentos Portable Document Format (PDF) em um site do IIS neste computador.

  • Você tem um computador cliente que possui o Adobe PDF Reader plug-in ativado em um navegador da Web.

  • Você pode usar este navegador da Web para abrir um dos documentos PDF que está hospedado em um site do IIS.

Nesse cenário, você não pode abrir o documento PDF. Além disso, o navegador da Web pode parar de responder.



Observação:

  • Você ainda poderá abrir outros documentos PDF neste site do IIS quando esse problema ocorrer.

  • Esse problema não afeta todas as versões do Adobe PDF Reader plug-in.

Causa

Esse problema ocorre devido a uma alteração de design no IIS 7.5.

Quando você tenta abrir um documento PDF em um site do IIS, o plug-in do Adobe PDF Reader envia uma solicitação que inclui vários intervalos de bytes para o IIS 7.5. Se a união de vários intervalos de bytes é um intervalo de byte único, a resposta do IIS 7.5 contém os intervalos de bytes mesclados em um intervalo de byte único (também conhecido como uma solicitação de intervalo de bytes mescladas). A resposta a esse intervalo único byte não inclui o tipo de conteúdo multipart/byteranges . No entanto, o tipo de conteúdo multipart/byteranges deve ser incluído em uma resposta a uma solicitação de intervalo de bytes mesclado. Esse comportamento faz com que o leitor de PDF Adobe plug-in para tratar da resposta incorreta. Portanto, não é possível abrir o documento PDF.

Observação: O tipo de conteúdo multipart/byteranges é incluído em um regular vários resposta de intervalos de bytes.

Resolução

Para resolver esse problema, aplique esse hotfix no computador que está executando o IIS 7.5.

Informações sobre o hotfix

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique este hotfix somente nos sistemas que estiverem enfrentando o problema descrito neste artigo. Esta correção poderá ser submetida a testes adicionais. Portanto, se esse problema não o prejudicar, recomendamos que você aguarde a próxima atualização de software que contenha esse hotfix.

Se o hotfix estiver disponível para download, há uma seção "Download de Hotfix disponível" na parte superior deste artigo da Base de Conhecimento. Se essa seção não for exibida, entre em contato com o suporte e atendimento ao cliente Microsoft para obter o hotfix.

Observação: caso outros problemas estejam ocorrendo ou caso qualquer solução de problemas seja necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não sejam específicos deste hotfix. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e suporte ou para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:

Observação: o formulário "Baixar Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Caso você não veja seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos:

Para aplicar esse hotfix, você deve estar executando o Windows 7 ou Windows Server 2008 R2.

Requisitos de reinicialização:

Você deve reiniciar o computador após aplicar esse hotfix.

Informações de substituição do hotfix:

Esse hotfix não substitui um hotfix lançado anteriormente.

Informações sobre o arquivo:

A versão global deste hotfix instala arquivos que possuam os atributos listados nas tabelas a seguir. As datas e horas desses arquivos estão listadas no Tempo Universal Coordenado (UTC). As datas e horas desses arquivos em seu computador local são exibidas em sua hora local com a diferença de horário de verão (DST) atual. Além disso, as datas e as horas podem ser alteradas quando você realizar determinadas operações nos arquivos.

Informações sobre o arquivo do Windows 7 e do Windows Server 2008 R2


Importante: os hotfixes do Windows 7 e Windows Server 2008 R2 estão incluídos nos mesmos pacotes. No entanto, os hotfixes na página solicitação de Hotfix estão listados em ambos os sistemas operacionais. Para solicitar o pacote de hotfix que se aplica a um ou ambos os sistemas operacionais, selecione o hotfix listado em "Windows 7/Windows Server 2008 R2" na página. Sempre consulte a seção "Aplica-se a" nos artigos para determinar o sistema operacional real que cada hotfix se aplica.

  • Os arquivos MANIFEST (. manifest) e os arquivos MUM (. mum) instalados para cada ambiente são listados separadamente na seção "Informações adicionais sobre arquivos para Windows Server 2008 R2 e Windows 7". MUM e arquivos de manifesto e os arquivos de catálogo (. cat) de segurança associadas são extremamente importantes para manter o estado do componente atualizado. Os arquivos do catálogo de segurança, para os quais os atributos não estejam listados, são assinados com uma assinatura digital da Microsoft.

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