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Sintomas

Se você usa um computador cliente que esteja executando o Microsoft Windows 95, o Microsoft Windows 98 ou o Microsoft Windows 98 Second Edition para imprimir em uma impressora de rede instalada como parte de um Microsoft cluster ou servidor autônomo, você pode receber a seguinte mensagem de erro:

A página de teste falha ao imprimir. Gostaria de ver o solucionador problemas de impressão para obter assistência. Acesso negado.

Causa

Esse problema pode ocorrer se o software de monitoramento de antivírus da McAfee estiver definido para executar uma verificação em tempo real de arquivos no cliente que está executando o Windows 95, o Windows 98 ou o Windows 98 Second Edition ou no servidor que está executando o Windows NT Server 4,0. Antivírus da McAfee verifica os arquivos no spool enquanto o trabalho de impressão está sendo processado. O Windows não pode fechar os arquivos porque o antivírus da McAfee tem os arquivos abertos. Esses arquivos são deixados na pasta systemroot\System32\Spool\Printers. Os arquivos. SHD e. SPL no spool permanecem na pasta após o trabalho de impressão ser exibido como concluído.

Resolução

Para solucionar esse problema, use um dos métodos descritos nesta seção.

Você recebe a mensagem de erro no servidor de impressão

Se você receber a mensagem de erro no servidor de impressão que está executando o Windows NT Server 4,0:

  1. Exclua os arquivos corrompidos na pasta spool:

    1. Clique em Iniciar, aponte para Configurações e clique em Painel de Controle.

    2. Clique duas vezes em Serviços, clique em spoolere, em seguida, clique em parar.

    3. Quando a seguinte mensagem for exibida, clique em Sim:

      Tem certeza de que deseja interromper o serviço de spooler?

    4. Clique em Iniciar, aponte para programase, em seguida, clique em Windows NT Explorer.

    5. Expanda a pasta WinNT , expanda a pasta System32 e, em seguida, expanda a pasta spool .

    6. Clique na pasta impressoras , clique em todos os arquivos listados no painel à direita e, em seguida, clique em excluir.

    7. Quando a seguinte mensagem for exibida, clique em Sim:

      Tem certeza de que deseja enviar estes x itens para a lixeira?

    8. Repita as etapas A e B para reiniciar o serviço de spooler e, em seguida, clique em Iniciar.

  2. Configure a impressora que está com o problema para começar a imprimir após a última página ser colocada em spool:

    1. Clique em Iniciar, aponte para configuraçõese, em seguida, clique em impressoras.

    2. Clique com o botão direito do mouse na impressora que está com o problema e clique em Propriedades.

    3. Clique na guia agendamento e, em seguida, clique em spool imprimir documentos para que o programa termine de imprimir mais rapidamente.

    4. Clique em Iniciar impressão após a última página ser colocada em spoole, em seguida, clique em OK.

  3. Configure a impressora que está com o problema para imprimir diretamente na impressora:

    1. Clique em Iniciar, aponte para configuraçõese, em seguida, clique em impressoras.

    2. Clique com o botão direito do mouse na impressora que está com o problema e clique em Propriedades.

    3. Clique na guia agendamento , clique em imprimir diretamente em impressorae, em seguida, clique em OK.

  4. Atualize o programa antivírus da McAfee para a versão 4,5 ou posterior.

  5. Verifique se a pasta de spool tem as permissões corretas.Para obter informações adicionais sobre as permissões corretas para a pasta spool, clique no número abaixo para ler o artigo na base de dados de conhecimento da Microsoft:

    137503 Diretório e permissões padrão de spool do Windows

Você recebe a mensagem de erro no cliente

Se você receber a mensagem de erro no cliente que está executando o Windows 95, o Windows 98 ou o Windows 98 segunda edição:

  1. Exclua os arquivos corrompidos na pasta spool:

    1. Clique em Iniciar, aponte para Programas e clique em Windows Explorer.

    2. Expanda a pasta Windows , expanda a pasta spool e, em seguida, clique na pasta impressoras .

    3. Clique em todos os arquivos listados no painel à direita e, em seguida, clique em excluir.

    4. Quando a seguinte mensagem for exibida, clique em Sim:

      Tem certeza de que deseja enviar estes x itens para a lixeira?

  2. Configure a impressora que está com o problema para começar a imprimir após a última página ser colocada em spool:

    1. Clique em Iniciar, aponte para configuraçõese, em seguida, clique em impressoras.

    2. Clique com o botão direito do mouse na impressora que está com o problema e clique em Propriedades.

    3. Clique na guia detalhes , clique em configurações de spoole, em seguida, clique em spool imprimir documentos para que o programa termine de imprimir mais rapidamente.

    4. Clique em Iniciar impressão após a última página ser colocada em spoole, em seguida, clique em OK.

  3. Configure a impressora que está com o problema para imprimir diretamente na impressora:

    1. Clique em Iniciar, aponte para configuraçõese, em seguida, clique em impressoras.

    2. Clique com o botão direito do mouse na impressora que está com o problema e clique em Propriedades.

    3. Clique na guia detalhes , clique em configurações de spool, clique em imprimir diretamente em impressorae, em seguida, clique em OK.

  4. Atualize o programa antivírus da McAfee para a versão 4,5 ou posterior.

Informações adicionais

Se você estiver usando um programa de depuração para depurar o serviço de spooler, os seguintes dados podem ser registrados no log de depuração:

LSPL: SplGetPrinter falha com ERROR_INSUFFICIENT_BUFFER cbBuf é 0 e pcbNeeded é 78.

Referências

Para obter informações adicionais sobre problemas de impressão relacionados, clique no número abaixo para ler o artigo na base de dados de conhecimento da Microsoft:

180892 Mensagem de erro: erro ao gravar em LPT1: acesso negado

142370 Imprimir nos resultados da impressora HP LaserJet no evento 2004

179156 Opções de impressão TCP/IP atualizadas para Windows NT 4,0 SP3 e posterior

188878 Imprimir em porta local pode falhar com erro de acesso negadoOs produtos de terceiros descritos neste artigo são fabricados por empresas que são independentes da Microsoft. A Microsoft não oferece garantias, implícitas ou de outra forma, em relação ao desempenho ou à confiabilidade desses produtos.

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