Um diagrama de sequência UML mostra como um conjunto de objetos interage em um processo ao longo do tempo. Ele mostra as mensagens que passam entre participantes e objetos no sistema e a ordem em que ocorrem.
Para criar um diagrama de sequência, use um modelo de Sequência UML ou um diagrama inicial, que inclui o estêncil Sequência UML . Arraste as formas do estêncil para a tela de desenho para criar o diagrama.
Iniciar um diagrama de sequência
- Inicie o Visio. Ou, se já tiver um arquivo aberto, selecione Arquivo>Novo.
- Na caixa Pesquisar, digite
UML sequence. - Selecione o diagrama de sequência UML .
- Na caixa de diálogo, selecione o modelo em branco ou um dos três diagramas iniciais. (Uma descrição de cada um deles é mostrada à direita quando você o seleciona.) Em seguida, selecione Unidades Métricas ou Unidades dos EUA.
- Selecione Criar.
- O diagrama é aberto. Você deve ver a janela Formas ao lado do diagrama. Se você não o vir, vá para Exibir>Painéis de Tarefas e verifique se a opção Formas está selecionada. Se você ainda não o vir, selecione o botão da janela Expandir as Formas à esquerda.
- Na guia Exibir, verifique se a caixa de marcação ao lado de Pontos de Conexão está selecionada. Esta opção faz com que os pontos de conexão apareçam quando você inicia a conectar formas.
- Agora, arraste as formas que deseja incluir no diagrama da janela Formas para a página. Para renomear rótulos de texto, clique duas vezes nos rótulos.
Linhas de vida para atores e objetos
Use uma forma Linha de Vida de Ator para cada participante e uma forma de Linha de Vida de Objeto para cada componente do sistema em seu processo.
Dica
À medida que você arrasta as linhas de vida para o lugar, guias de alinhamento verdes aparecem na tela para ajudá-lo a alinhar e espaçar as linhas de vida em relação às outras formas de linha de vida.
- Clique duas vezes na caixa de cabeçalho de cada linha da vida para inserir um nome ou título.
- Para alongar ou encurtar uma linha do tempo, selecione a linha da vida e arraste o ponto de controle amarelo na parte inferior da linha da vida.
Mensagens
Use formas de mensagem para representar informações enviadas entre linhas da vida.
Dica
O Visio ajuda você a associar os pontos de extremidade da mensagem a cada linha da vida. Um círculo verde aparece no ponto final quando ele se associa a um ponto de conexão. Os pontos de conexão desaparecem quando você termina de arrastar.
Anexe o ponto de extremidade inicial à linha de vida que envia a mensagem e arraste o ponto de extremidade principal para a linha de vida que está recebendo a mensagem.
Clique duas vezes na forma da mensagem para criar uma caixa de texto e digite um nome para a mensagem.
Use uma forma de mensagem (uma linha sólida) para representar uma solicitação ou a transmissão de informações.
Use uma forma de Mensagem de Retorno (uma linha tracejada) para representar uma resposta a uma mensagem anterior.
Use uma Self Message para representar uma chamada recursiva de uma operação ou um método chamando outro método pertencente ao mesmo objeto.
Use a forma Mensagem Assíncrona para mostrar quando uma ação pode não acontecer imediatamente.
Para alterar a forma de uma mensagem do conector:
- Clique com o botão direito do mouse no conector.
- Na parte inferior do menu pop-up, selecione uma das três opções (Ângulo Reto, Reto, Curvo).
- Selecione e arraste o conector para alterar sua forma.
Fragmentos
Se uma ou mais interações formarem um loop ou exigirem que uma condição seja atendida para encerrar a interação, coloque essas interações em uma forma de fragmento :
- Use o fragmento do Loop para uma interação básica de repetição
- Use o fragmento opcional para etapas que são executadas somente se uma determinada condição for atendida.
- Use a forma de fragmento alternativa para um processo ou interação se-então ou se-então-mais. O fragmento vem com duas seções, que permitem mostrar a interação alternativa. Para adicionar outra condição, arraste um operando de Interação para a forma.
- Arraste a forma do fragmento para as interações com as quais ela se relaciona. Use as alças de dimensionamento na forma do fragmento para garantir que ela inclua todas as interações relacionadas.
- Clique duas vezes no canto do título da forma de fragmento para adicionar um título ou uma breve descrição do processo delimitado pelo fragmento. Abaixo do canto do título, selecione o prompt [parâmetros] se quiser inserir as condições que encerrariam esse processo.
Ativação
Coloque uma forma Barra de ativação em uma linha da vida para mostrar quando e por quanto tempo esse objeto ou participante está ativo no processo. Normalmente, haverá setas indo e voltando de uma caixa de ativação para demonstrar o fluxo de informações.
Arraste os pontos finais da barra de ativação para cima ou para baixo para torná-la do tamanho desejado.
Destruição
A destruição indica quando um objeto ou ator termina de participar de um sistema. Um X grande aparece no final de sua linha de vida. Para mostrar a destruição de um objeto em um diagrama:
- Clique com o botão direito do mouse no objeto e selecione Mostrar destruição.
Veja Também
Criar um diagrama de componente UML