Criar um diagrama de componente UML

Aplica-se a
Visio Plano 1 Visio Professional 2024 Visio Professional 2021 Visio Professional 2019

Você pode criar um diagrama de componente UML para mostrar componentes, portas, interfaces e as relações entre eles.

Um componente em UML representa uma parte modular de um sistema. O comportamento é definido em termos de interfaces necessárias e fornecidas. Um componente tem uma exibição externa com propriedades e operações públicas e tem uma exibição interna com propriedades privadas e classificadores de realização. A visão interna mostra como o comportamento externo é percebido internamente.

Um diagrama de componente UML de exemplo.

Primeiro, você abre o modelo de componente UML e escolhe uma das quatro opções. Em seguida, o estêncil do componente UML é exibido, juntamente com as formas que estão em conformidade com o padrão UML 2.5.

Observação

O estêncil de componente UML só estará disponível se você for assinante do Visio Plano 2. Se você tem uma assinatura, verifique se sua versão do Visio é a mais recente.

Iniciar um diagrama de componente

  1. Inicie o Visio. Ou, se já tiver um arquivo aberto, clique em Arquivo>Novo.
  2. Vá para as categorias>Software e banco de dados>Componente UML.
  3. Selecione o modelo em branco ou um dos três diagramas iniciais. Depois de escolher o modelo desejado, clique em Criar.
  4. Você deve ver a janela Formas ao lado do diagrama. Se você não o vir, vá para Exibir>Painéis de Tarefas e verifique se a opção Formas está selecionada. Se você ainda não vê-lo, clique no botão Expandir a janela Formasbotão Expandir Janela de Formas à esquerda.
  5. Na guia Exibir, verifique se a caixa de marcação ao lado de Pontos de Conexão está selecionada. Isto fará com que os pontos de conexão apareçam quando você iniciar a conexão de formas.
  6. Agora, arraste as formas que deseja incluir no diagrama da janela Formas para a página. Para renomear rótulos de texto, clique duas vezes nos rótulos.

Formas de componentes

Quando usar

Use formas de componentes para cada unidade funcional em seu sistema ou aplicativo.

Forma de componente da loja

Mostrar ou ocultar estereótipo

Clique com o botão direito do mouse na forma para mostrar ou ocultar o rótulo de estereótipo.

Menu do botão direito do mouse, comando Mostrar estereótipo, <<rótulo de texto do componente>>

Subsistemas

Você pode usar a forma do componente como uma forma de subsistema que contém outros componentes. Basta redimensioná-lo para ser maior e soltar outros componentes em cima dele. Quando você vir o destaque verde, solte. Desse ponto em diante, a forma maior atuará como um contêiner e a forma menor se moverá com ela.

Dica

Se um componente desaparecer depois de arrastá-lo para cima de outro componente, traga-o para a frente pressionando CTRL+SHIFT+F.

Armazene a forma de subsistema com o componente Pedido arrastado para cima dela

Formas de interface

Quando usar

  1. Use a forma Interface Fornecida quando quiser especificar a realização de uma classe/interface.
  2. Use a Interface Necessária quando quiser especificar uma dependência em uma classe/interface.

Duas interfaces conectadas, 1: forma de interface fornecida terminando com círculo, 2: forma de interface necessária terminando com soquete

Etapa 1

Arraste uma forma Interface Fornecida para a página e alinhe o quadrado da porta com um ponto de conexão. Você saberá que ela estará conectada quando vir o realce verde ao redor do ponto de conexão.

Forma de interface fornecida associada à forma de componente

Passo 2

Arraste uma forma Interface Necessária para a página e alinhe o quadrado da porta com um ponto de conexão também. Você saberá que ela estará conectada quando vir o realce verde ao redor do ponto de conexão.

Forma de interface necessária associada à forma de componente

Passo 3

Para conectar uma interface fornecida e uma interface necessária, primeiro selecione a forma de interface necessária. Em seguida, procure a alça amarela.

Alça amarela na forma de Interface Necessária

Passo 4

Arraste a alça amarela para conectar-se à Interface Fornecida.

Forma de interface necessária conectada à interface fornecida

Dicas para conectores

Endireitar conectores

Se um conector estiver dando muitas voltas, clique com o botão direito do mouse nele e clique em Conector Reto.

Mostrar multiplicidade

Se necessário, clique com o botão direito do mouse no conector e selecione Mostrar Multiplicidade. Quando terminar, quatro caixas de texto são exibidas onde você pode adicionar detalhes. Se você não precisar de todas as caixas de texto, exclua as que você não precisa.

Alterar o tipo de conector

Você pode alterar um tipo de conector. Por exemplo, você pode alterar de uma Associação para uma Associação Direcionada. Clique com o botão direito do mouse no conector e clique em Definir Tipo de Conector.

Faça conexões dinâmicas em vez de conexões pontuais

Se você antecipar muito o movimento de formas, considere fazer uma conexão dinâmica em vez de uma conexão de ponto.

Mover ou girar texto em conectores

Provavelmente, você precisará girar ou mover o texto nas linhas de conexão. Veja como fazer isso:

  1. Clique em uma área vazia da página para desmarcar qualquer coisa que possa ser selecionada.
  2. Na guia Página Inicial , no grupo Ferramentas , clique no botão Bloco de Texto da ferramentaBloco de Texto
  3. Clique no conector com o texto que você deseja girar ou mover.
  4. Arraste o bloco de texto para movê-lo ou gire-o usando a Alça de RotaçãoAlça de rotação
  5. Quando terminar, clique no botão Ferramenta PonteiroBotão Ponteiro
    Depois de voltar para o botão da Ferramenta PonteiroBotão Ponteiro , o texto mantém a mesma posição em relação à forma. Se você usar o botão Ponteiro da Ferramenta Ponteiro para arrastar o texto, a forma também se moverá. Para mover o texto independentemente da forma, volte para o botão Bloco de Texto da Ferramenta Bloco de Texto .

Veja Também

Diagramas UML no Visio

Criar um diagrama de comunicação UML

Criar um diagrama de implantação UML

Criar um diagrama de sequência UML