Você pode criar um diagrama de comunicação UML para mostrar as interações entre linhas da vida que usam mensagens sequenciadas em uma organização de forma livre. Primeiro, você abre o modelo de comunicação UML e escolhe uma das quatro opções de modelo. Em seguida, o estêncil de Comunicação UML é exibido, juntamente com as formas que estão em conformidade com o padrão UML 2.5.
Observação
O estêncil de Comunicação UML só estará disponível se você for assinante do Visio Plano 2. Se você tem uma assinatura, verifique se sua versão do Visio é a mais recente.
Iniciar um diagrama de comunicação
- Inicie o Visio. Ou, se já tiver um arquivo aberto, clique em Arquivo>Novo.
- Vá para as categorias>Software e Banco de Dados>Comunicação UML.
- Selecione o modelo em branco ou um dos três diagramas iniciais. Se você quiser representar a colaboração de linhas de vida mostrando interações entre linhas de vida, escolha o diagrama inicial no canto inferior esquerdo.
- Clique em Criar.
- Você deve ver a janela Formas ao lado do diagrama. Se você não o vir, vá para Exibir>Painéis de Tarefas e verifique se a opção Formas está selecionada. Se você ainda não vê-lo, clique no botão Expandir a janela Formas
à esquerda. - Na guia Exibir, verifique se a caixa de marcação ao lado de Pontos de Conexão está selecionada. Isto fará com que os pontos de conexão apareçam quando você iniciar a conexão de formas.
- Agora, arraste as formas que deseja incluir no diagrama da janela Formas para a página. Para renomear rótulos de texto, clique duas vezes nos rótulos.
Formas de ator e linha de vida
Quando usar
- Arraste a forma Ator para a página para representar a função de um usuário ou de um sistema externo.
- Arraste a forma Lifeline para a página de cada elemento nomeado que representa um participante individual.
Interações entre linhas da vida como mensagens
Etapa 1
Arraste uma forma de mensagem para a página e associe uma extremidade a um ponto de conexão em outra forma. Você sabe que ele é colado quando há um quadrado verde ao redor do ponto de conexão.
Passo 2
Faça o mesmo com a outra extremidade da mensagem, de modo que ela também seja associada a um ponto de conexão. Você sabe que ele está colado quando há um realce verde ao redor do ponto.
Passo 3
Se você quiser que a mensagem seja assíncrona, clique com o botão direito do mouse e escolha Assíncrono. Fazer isso mudará a ponta da seta fechada para uma aberta.
Colaboração de linhas de vida, mostrando interações entre linhas de vida
Visão Geral
- Primeiro, conecte as linhas de vida com a Ferramenta Conector .
- Em seguida, use as formas Mensagem e Mensagem de Retorno para mostrar as interações entre linhas da vida.
Etapa 1
Na guia Início , clique na Ferramenta Conector (1). Passe o mouse sobre um dos pontos de conexão de uma forma linha de vida até ver um realce verde (2).
Passo 2
Clique e arraste do realce verde para um ponto de conexão em outra forma de linha de vida até ver um realce como este.
Passo 3
Clique na Ferramenta Ponteiro quando terminar de conectar as formas da linha de vida.
Passo 4
Arraste outra forma de mensagem para que ela fique paralela à outra linha.
Dicas para conectores
Endireitar conectores
Se um conector estiver dando muitas voltas, clique com o botão direito do mouse nele e clique em Conector Retor.
Alterar o tipo de conector
Você pode alterar um tipo de conector. Por exemplo, você pode alterar de uma Associação para uma Associação Direcionada. Clique com o botão direito do mouse no conector e clique em Definir Tipo de Conector.
Faça conexões dinâmicas em vez de conexões pontuais
Se você antecipar muito o movimento de formas, considere fazer uma conexão dinâmica em vez de uma conexão de ponto.
Mover ou girar texto em conectores
Provavelmente, você precisará girar ou mover o texto nas linhas de conexão. Veja como fazer isso:
- Clique em uma área vazia da página para desmarcar qualquer coisa que possa ser selecionada.
- Na guia Página Inicial , no grupo Ferramentas , clique no botão Bloco de Texto da ferramenta
- Clique no conector com o texto que você deseja girar ou mover.
- Arraste o bloco de texto para movê-lo ou gire-o usando a Alça de Rotação
- Quando terminar, clique no botão Ferramenta Ponteiro
Depois de voltar para o botão da Ferramenta Ponteiro
, o texto mantém a mesma posição em relação à forma. Se você usar o
da Ferramenta Ponteiro para arrastar o texto, a forma também se moverá. Para mover o texto independentemente da forma, volte para o
da Ferramenta Bloco de Texto .
Veja Também
Criar um diagrama de componente UML