Criar um diagrama de comunicação UML

Aplica-se A
Visio (Plano 1) Visio Professional 2024 Visio Professional 2021 Visio Professional 2019

Pode criar um diagrama de Comunicação UML para mostrar as interações entre as linhas da duração que utilizam mensagens sequenciadas numa disposição livre. Primeiro, abra o modelo Comunicação UML e escolha uma das quatro opções de modelo. Em seguida, é apresentado o stencil Comunicação UML , juntamente com as formas em conformidade com a norma UML 2.5.

Um exemplo de um diagrama de comunicação UML.

Nota

O stencil Comunicação UML só está disponível se for um subscritor Visio (Plano 2). Se tiver uma subscrição, certifique-se de que tem a versão mais recente do Visio.

Iniciar um diagrama de comunicação

  1. Inicie o Visio. Em alternativa, se já tiver um ficheiro aberto, clique em Ficheiro>Novo.
  2. Vá para Categorias>Software e Banco de Dados>UML Comunicação.
  3. Selecione o modelo em branco ou um dos três diagramas iniciais. Se quiser representar a colaboração de linhas da duração ao mostrar as interações entre as linhas da vida, certifique-se de que escolhe o diagrama de introdução no canto inferior esquerdo.
  4. Clique em Criar.
  5. Deverá ver a janela Formas junto ao diagrama. Se não a vir, aceda a Ver>Painéis de Tarefas e certifique-se de que Formas está selecionada. Se continuar a não vê-lo, clique no botão Expandir a janela FormasExpandir a janela Formas à esquerda.
  6. No separador Ver , certifique-se de que a caixa de verificação junto a Pontos de Ligação está selecionada. Isto fará com que os pontos de ligação apareçam quando começar a ligar formas.
  7. Agora, arraste as formas que pretende incluir no seu diagrama a partir da janela Formas para a página. Para mudar o nome das etiquetas de texto, faça duplo clique nas etiquetas.

Formas de atores e linhas de vida

Quando utilizar

  1. Arraste a forma Ator para a página para representar a função de um utilizador ou sistema externo.
  2. Arraste a forma Linha de Vida para a página de cada elemento com nome que represente um participante individual.

1: Forma de ator com texto de Alguém 2: Forma de linha de vida com:Texto do cupão

Interações entre linhas da vida como mensagens

Passo 1

Arraste uma forma de mensagem para a página e cole uma extremidade a um ponto de ligação noutra forma. Sabe que está colado quando existe um quadrado verde à volta do ponto de ligação.

Forma de mensagem com uma extremidade realçada a verde e ligada à forma de linha de vida

Passo 2

Faça o mesmo para a outra extremidade da mensagem, para que também esteja colada a um ponto de ligação. Sabe que está colado quando existe um realce verde à volta do ponto.

Forma de mensagem com fim realçado a verde e ligada a outra forma de linha de vida

Passo 3

Se quiser que a mensagem seja assíncrona, clique com o botão direito do rato e selecione Assíncrona. Esta ação irá alterar a ponta da seta fechada para uma aberta.

Forma da mensagem, menu de contexto, comando Assíncrono selecionado

Colaboração de linhas da duração ao mostrar as interações entre as linhas da vida

Descrição geral

  1. Primeiro, ligue as linhas de vida com a Connector Tool.
  2. Em seguida, utilize as formas Mensagem e Mensagem de Retorno para mostrar as interações entre as linhas da vida.

1 apontando para a linha do conector cinza, 2 apontando para a linha da mensagem com texto, 4: Execute()

Passo 1

No separador Base , clique na Ferramenta de Conexão (1). Paire o cursor sobre um dos pontos de ligação de uma forma da linha da vida até ver um realce verde (2).

1 a apontar para a ferramenta Conexão, 2 a apontar para o cursor a pairar sobre o ponto de ligação destacado a verde na forma da linha de vida

Passo 2

Clique e arraste do realce verde para um ponto de ligação noutra forma da linha da vida até ver um realce como este.

End of connector line dragged to another lifeline shape, with green highlight around connection point

Passo 3

Clique na Ferramenta de Ponteiro quando terminar de ligar as formas da linha da vida.

Clique aqui quando terminar de apontar para o comando Ferramenta de Ponteiro

Passo 4

Arraste outra forma de mensagem para que fique paralela à outra linha.

Posicionamento do cursor da forma da mensagem no local junto à linha de conexão

Sugestões para conectores

Endireitar conectores

Se uma conexão estiver a demorar demasiadas voltas, clique com o botão direito do rato na conexão e, em seguida, clique em Straight Connector.

Alterar tipo de conexão

Pode alterar um tipo de conexão. Por exemplo, pode mudar de uma Associação para uma Associação Dirigida. Clique com o botão direito do rato na conexão e, em seguida, clique em Definir Tipo de Conexão.

Estabelecer ligações dinâmicas em vez de ligações pontuais

Se prevê mover muito formas, considere fazer uma ligação dinâmica em vez de uma ligação por pontos.

Mover ou rodar texto em conexões

Irá provavelmente precisar de rodar ou mover texto nas linhas de conexão. Eis como fazê-lo:

  1. Clique numa área vazia da página para anular a seleção de tudo o que possa estar selecionado.
  2. No separador Base , no grupo Ferramentas , clique na ferramenta Bloco de TextoBotão Bloco de Texto
  3. Clique na conexão que tem o texto que pretende rodar ou mover.
  4. Arraste o bloco de texto para movê-lo ou rode-o utilizando a Alça de Rotação da Alça de Rotação
  5. Quando terminar, clique no botão Ferramenta de PonteiroBotão Ponteiro
    Depois de voltar ao botão Ferramenta de Ponteiro , botão Ponteiro , o texto mantém a mesma posição em relação à forma. Se utilizar o botão Ponteiropara arrastar o texto, a forma também será movida. Para mover o texto independentemente da forma, volte ao botão Bloco de Texto da Ferramenta de Texto.

Consulte Também

Diagramas UML no Visio

Criar um diagrama de componente UML

Criar um diagrama de implementação UML

Criar um diagrama de sequência UML