Criar um diagrama de componente UML

Aplica-se A
Visio (Plano 1) Visio Professional 2024 Visio Professional 2021 Visio Professional 2019

Você pode criar um diagrama de componente UML para mostrar componentes, portas, interfaces e as relações entre eles.

Um componente em UML representa uma parte modular de um sistema. O comportamento é definido em termos de interfaces necessárias e fornecidas. Um componente tem uma visão externa com propriedades e operações públicas, e tem uma visão interna com propriedades privadas e classificadores realizadores. A visão interna mostra como o comportamento externo é realizado internamente.

Um diagrama de componente UML de exemplo.

Primeiro, abra o modelo Componente UML e escolha uma das quatro opções. Em seguida, é apresentado o stencil Componente UML , juntamente com as formas em conformidade com a norma UML 2.5.

Nota

O stencil Componente UML só estará disponível se for um subscritor Visio (Plano 2). Se tiver uma subscrição, certifique-se de que tem a versão mais recente do Visio.

Iniciar um diagrama de componente

  1. Inicie o Visio. Em alternativa, se já tiver um ficheiro aberto, clique em Ficheiro>Novo.
  2. Vá para Categorias>Software e Banco de Dados>UML componente.
  3. Selecione o modelo em branco ou um dos três diagramas iniciais. Depois de escolher o modelo pretendido, clique em Criar.
  4. Deverá ver a janela Formas junto ao diagrama. Se não a vir, aceda a Ver>Painéis de Tarefas e certifique-se de que Formas está selecionada. Se continuar a não vê-lo, clique no botão Expandir a janela FormasExpandir a janela Formas à esquerda.
  5. No separador Ver , certifique-se de que a caixa de verificação junto a Pontos de Ligação está selecionada. Isto fará com que os pontos de ligação apareçam quando começar a ligar formas.
  6. Agora, arraste as formas que pretende incluir no seu diagrama a partir da janela Formas para a página. Para mudar o nome das etiquetas de texto, faça duplo clique nas etiquetas.

Formas de componente

Quando utilizar

Utilize formas de componentes para cada unidade funcional no seu sistema ou aplicação.

Forma Componente da Loja

Mostrar ou esconder estereótipos

Clique com o botão direito do rato na forma para mostrar ou ocultar a etiqueta de estereótipo.

Menu de clique com o botão direito do rato, comando Mostrar Estereotipo, <<etiqueta de texto do componente>>

Subsistemas

Pode utilizar a forma de componente como uma forma de subsistema que contém outros componentes. Basta redimensioná-lo para que fique maior e soltar outros componentes em cima dele. Assim que vir o realce verde, solte o botão de lado. A partir desse ponto, a forma maior irá agir como um contentor e a forma mais pequena irá mover-se com ela.

Sugestão

Se um componente desaparecer depois de arrastá-lo para cima de outro componente, traga-o para a frente pressionando CTRL+SHIFT+F.

Forma do subsistema Store com o componente Encomenda arrastado sobre a mesma

Formas de interface

Quando utilizar

  1. Use a forma Interface fornecida quando quiser especificar a realização de uma classe/interface.
  2. Use a Interface Necessária quando desejar especificar uma dependência em uma classe/interface.

Duas interfaces ligadas, 1: Fornecido Forma de interface que termina com círculo, 2: Necessário Interface forma que termina com socket

Passo 1

Arraste uma forma Interface Fornecida para a página e alinhe o quadrado da porta com um ponto de ligação. Saberá que está ligado quando vir o realce verde à volta do ponto de ligação.

Fornecido Forma Interface colada à forma Componente

Passo 2

Arraste uma forma Interface necessária para a página e alinhe o quadrado da porta com um ponto de ligação também. Saberá que está ligado quando vir o realce verde à volta do ponto de ligação.

Forma Interface necessária colada à forma Componente

Passo 3

Para conectar uma interface Fornecida e Necessária juntas, primeiro selecione a forma Interface necessária. Em seguida, procure a alça amarela.

Alça amarela na forma Interface Necessária

Passo 4

Arraste a alça amarela para se conectar à interface fornecida.

Forma de Interface necessária ligada à Interface Fornecida

Sugestões para conectores

Endireitar conectores

Se uma conexão estiver a dar demasiadas voltas, clique com o botão direito do rato na conexão e, em seguida, clique em Conexão Reta.

Mostrar multiplicidade

Se necessário, clique com o botão direito do rato no conector e selecione Mostrar Multiplicidade. Quando terminar, serão apresentadas quatro caixas de texto onde pode adicionar detalhes. Se não precisar de todas as caixas de texto, elimine as de que não precisa.

Alterar tipo de conexão

Pode alterar um tipo de conexão. Por exemplo, pode mudar de uma Associação para uma Associação Dirigida. Clique com o botão direito do rato na conexão e, em seguida, clique em Definir Tipo de Conexão.

Estabelecer ligações dinâmicas em vez de ligações pontuais

Se prevê mover muito formas, considere fazer uma ligação dinâmica em vez de uma ligação por pontos.

Mover ou rodar texto em conexões

Irá provavelmente precisar de rodar ou mover texto nas linhas de conexão. Eis como fazê-lo:

  1. Clique numa área vazia da página para anular a seleção de tudo o que possa estar selecionado.
  2. No separador Base , no grupo Ferramentas , clique na ferramenta Bloco de TextoBotão Bloco de Texto
  3. Clique na conexão que tem o texto que pretende rodar ou mover.
  4. Arraste o bloco de texto para movê-lo ou rode-o utilizando a Alça de Rotação da Alça de Rotação
  5. Quando terminar, clique no botão Ferramenta de PonteiroBotão Ponteiro
    Depois de voltar ao botão Ferramenta de Ponteiro , botão Ponteiro , o texto mantém a mesma posição em relação à forma. Se utilizar o botão Ponteiropara arrastar o texto, a forma também será movida. Para mover o texto independentemente da forma, volte ao botão Bloco de Texto da Ferramenta de Texto.

Consulte Também

Diagramas UML no Visio

Criar um diagrama de comunicação UML

Criar um diagrama de implementação UML

Criar um diagrama de sequência UML