В этом разделе перечислены распространенные причины ошибки #ЗНАЧ! в функциях СУММЕСЛИ и СУММЕСЛИМН и способы их устранения.

Проблема: формула ссылается на ячейки в закрытой книге

Функции СУММЕ ЕСЛИ и СУММЕСС, которые ссылаются на ячейку или диапазон в закрытой книге, приведут к #VALUE! ошибку "#ВЫЧИС!".

Примечание. Это известная проблема с несколькими другими функциями Excel, такими как СЧЁТЕ ЕСЛИ, СЧЁТЕФМН и СЧИТАТЬBLANK. См. функции СУММЕ ЕСЛИ, СЧЁТЕФ и СЧИТАТЬ #VALUE. Ошибка дополнительные сведения.

Решение: Откройте книгу, указанную в формуле, и нажмите клавишу F9, чтобы обновить формулу.

Эту проблему также можно обойти, используя функции СУММ и ЕСЛИ вместе в формуле массива. См. сообщение об ошибке функций СУММЕФ, СЧЁТЕ ЕСЛИ и СЧИТАТЬ СЧИТАТЬ #VALUE! дополнительные сведения.

Проблема: длина строки условия превышает 255 символов

Функции СУММЕСЛИ и СУММЕСЛИМН возвращают неправильные результаты, если они используются для сопоставления строк длиннее 255 символов.

Решение: Сократите строку, если это возможно. Если сократить строку нельзя, используйте функцию СЦЕПИТЬ или оператор-амперсанд (&), чтобы разделить значение на несколько строк. Например:

=СУММЕСЛИ(B2:B12;"длинная строка"&"еще одна длинная строка")

Проблема: в функции СУММЕСЛИМН аргумент диапазон_условия не совпадает с аргументом диапазон_суммирования.

Аргументы диапазонов в функции СУММЕСЛИМН должны совпадать. Это означает, что в аргументах диапазон_условия и диапазон_суммирования должно указываться одинаковое количество строк и столбцов.

В следующем примере формула должна возвращать сумму ежедневных продаж apples в Bellevue. Однако sum_range (C2:C10) не соответствует количеству строк и столбцов в аргументах criteria_range (A2:A12 & B2:B12). Использование синтаксиса =СУММЕ ЕСЛИМН(C2:C10,A2:A12,A14,B2:B12,B14) приведет к #VALUE! ошибку "#ВЫЧИС!".

Неправильная формула: =СУММЕСЛИМН(C2:C10;A2:A12;A14;B2:B12;B14), где C2:C10 необходимо изменить на C2:C12

Решение: В приведенном примере измените диапазон_суммирования на C2:C12 и выполните формулу повторно.

Примечание:  В функции СУММЕСЛИ можно использовать диапазоны разного размера.

У вас есть вопрос об определенной функции?

Задать вопрос на форуме сообщества, посвященном Excel

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community или попросить помощи в сообществе Answers community.

См. также

Исправление ошибки #ЗНАЧ! #BUSY!

Функция СУММЕСЛИ

Функция СУММЕСЛИМН

Видео о расширенных функциях ЕСЛИ

Полные сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Обнаружение ошибок в формулах

Все функции Excel (по алфавиту)

Функции Excel (по категориям)

Нужна дополнительная помощь?

Совершенствование навыков
Перейти к обучению

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?

Спасибо за ваш отзыв!

×