Исправление ошибки #ЗНАЧ! в функциях СЧЁТЕСЛИ и СЧЁТЕСЛИМН

В этом разделе перечислены распространенные причины ошибки #ЗНАЧ! в функциях СЧЁТЕСЛИ и СЧЁТЕСЛИМН.

Проблема: формула ссылается на ячейки в закрытой книге

Если функции СЧЁТЕФ и СЧЁТЕФС ссылаются на ячейку или диапазон в закрытой книге, это приведет к #VALUE! ошибка "#ЗНАЧ!".

Примечание. Это известная проблема с несколькими другими функциями Excel, такими как СУММЕФ, СУММЕСС, СЧИТАТЬBLANK. См. функции СУММЕФ, СЧЁТЕФ и СЧИТАТЬBLANK, возвращая #VALUE! .

Решение: Откройте связанную книгу, указанную в формуле, и нажмите клавишу F9, чтобы обновить формулу.

Эту проблему также можно обойти, используя функции СУММ и ЕСЛИ вместе в формуле массива. См. функции СУММЕФ, СЧЁТЕФ и СЧИТАТЬBLANK, возвращая #VALUE! .

Проблема: длина строки превышает 255 символов

Решение: Сократите строку, если это возможно. Если сократить строку нельзя, используйте функцию СЦЕПИТЬ или оператор-амперсанд (&), чтобы разделить значение на несколько строк. Пример:

  • =СЧЁТЕСЛИ(B2:B12;"длинная строка"&"еще одна длинная строка")

У вас есть вопрос об определенной функции?

Задать вопрос на форуме сообщества, посвященном Excel

Помогите нам улучшить Excel

У вас есть предложения по улучшению следующей версии Excel? Если да, ознакомьтесь с темами на портале пользовательских предложений для Excel.

См. также

Исправление ошибки #ЗНАЧ! #BUSY!

Функция СЧЁТЕСЛИ

Функция СЧЁТЕСЛИМН

Функция ЕСЛИ — вложенные формулы и типовые ошибки

См. видео о расширенных функциях ЕСЛИ

Общие сведения о формулах в Excel

Рекомендации, позволяющие избежать появления неработающих формул

Обнаружение ошибок в формулах

Все функции Excel (по алфавиту)

Функции Excel (по категориям)

Нужна дополнительная помощь?

Совершенствование навыков работы с Office
Перейти к обучению
Первоочередный доступ к новым возможностям
Присоединиться к программе предварительной оценки Office

Были ли сведения полезными?

Спасибо за ваш отзыв!

Благодарим за отзыв! Возможно, будет полезно связать вас с одним из наших специалистов службы поддержки Office.

×