Проблема
Невозможно подключиться к серверу, работающему под управлением Microsoft SQL Server 2014 или SQL Server 2012 с помощью протокола TLS версии 1.2. Кроме того, в журнале ошибок SQL Server регистрируется следующее сообщение об ошибке:
Примечание
Сбой инициализации TDSSNIClient с ошибкой 0x80090331, код состояния 0x80. Причина: не удается инициализировать поддержку SSL. Клиент и сервер не могут взаимодействовать, так как не обладают общим алгоритмом.
Решение
Эта проблема была впервые устранена в следующем накопительном пакете обновления SQL Server.
Накопительный пакет обновления 12 для SQL Server 2014
Накопительный пакет обновления 5 для SQL Server 2014 с пакетом обновления 1 (SP1)
Накопительный пакет обновления 10 для SQL Server 2012 с пакетом обновления 2 (SP2)
Накопительный пакет обновления 1 для SQL Server 2012 с пакетом обновления 3 (SP3) Примечание. Это обновление добавляет поддержку протокола TLS версии 1.2 в SQL Server 2014 и в драйвер Microsoft ODBC для SQL Server.
Сведения о накопительных обновлениях для SQL Server
Каждый новый накопительный пакет обновления для SQL Server содержит все исправления и исправления безопасности, которые входили в состав предыдущего накопительного пакета обновления. Ознакомьтесь с последними накопительными пакетами обновления для SQL Server:
- Последний накопительный пакет обновления для SQL Server 2014 с пакетом обновления 1 (SP1)
- Последний накопительный пакет обновления для SQL Server 2012 с пакетом обновления 2 (SP2)
- Последний накопительный пакет обновления для SQL Server 2012 с пакетом обновления 3 (SP3)
Примечание Сведения о последних сборках SQL Server см. в разделе: Где найти информацию о последних сборках SQL Server.
Состояние
Корпорация Майкрософт подтвердила, что это проблема продуктов Microsoft, перечисленных в разделе «Относится к».
Ссылки
Узнайте о терминологии , используемой корпорацией Майкрософт для описания обновлений программного обеспечения.