Проблема
Предположим, что у вас есть база данных, содержащая большие индексы columnstore в Microsoft SQL Server 2014. При выполнении команды DBCC CHECKDB для базы данных в журнале ошибок SQL Server появляется следующее сообщение об ошибке:
Примечание
Операционная система возвратила ошибку 665(не удалось выполнить запрошенную операцию из-за ограничения файловой системы) SQL Server во время записи со смещением 0x00004a21310000 в файл "<Имя> диска:\Program Files\Microsoft SQL Server\MSSQL12. MSSQLSERVER\MSSQL\Data\XXXX.mdf'. Дополнительные сообщения в журнале ошибок SQL Server и журнале системных событий могут содержать более подробную информацию. Это серьезная ошибка на уровне системы, которая угрожает целостности базы данных и должна быть немедленно устранена. Выполните полную проверку согласованности базы данных (DBCC CHECKDB). Эта ошибка может быть вызвана многими факторами. Для получения дополнительной информации см. книги по SQL Server в Интернете.
При выполнении команды DBCC CHECKTABLE для таблицы с индексом columnstore появляется следующее сообщение об ошибке:
Примечание
MSG 0, уровень 11, состояние 0, строка 0
Возникла серьезная ошибка текущей команды. Результаты, если таковые имеются, должны быть отброшены.
В то же время в журнале ошибок появляется следующее сообщение об ошибке:
Примечание
DBCC CHECKTABLE (<Table_Name>), выполненная DomainName\UserName, аварийно завершена из-за состояния ошибки 6. Истекшего времени: 0 часов 3 минуты 36 секунд.
Причина
Эта проблема возникает из-за дефекта в механизме предварительной выборки функции индекса columnstore SQL Server. Из-за этого дефекта страницы данных заполняют базу данных snapshot без необходимости, что может привести к преждевременной ошибке операционной системы 665.
NoteDBCC Команда CHECKDB автоматически создает базу данных snapshot внутренне. Та же проблема может возникнуть при создании snapshot базы данных вручную и выполнении нескольких запросов, использующих индекс columnstore.
Решение
Сведения о пакете обновления
Чтобы устранить эту проблему, приобретите пакет обновления 1 для SQL Server 2014.
Дополнительные сведения о SQL Server 2014 с пакетом обновления 1 (SP1) см. в статье об ошибках, исправленных в SQL Server 2014 с пакетом обновления 1.
Сведения о накопительном пакете обновления
Эта проблема была впервые исправлена в следующем накопительном пакете обновления SQL Server.
Рекомендация. Установите последний накопительный пакет обновления для SQL Server
Каждый новый накопительный пакет обновления для SQL Server содержит все исправления и исправления безопасности, которые входили в состав предыдущего накопительного пакета обновления. Рекомендуется скачать и установить последние накопительные пакеты обновления для SQL Server:
Состояние
Корпорация Майкрософт подтвердила, что это проблема продуктов Microsoft, перечисленных в разделе «Относится к».