KB3135748 - ИСПРАВЛЕНО: ошибка при использовании функции репликации в SQL Server 2014 или SQL Server 2012

Применяется к
SQL Server 2014 Developer - duplicate (do not use) SQL Server 2014 Enterprise - duplicate (do not use) SQL Server 2014 Standard - duplicate (do not use) SQL Server 2014 Express - duplicate (do not use) SQL Server 2014 Web - duplicate (do not use) SQL Server 2012 Service Pack 3 SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Enterprise Core SQL Server 2012 Express SQL Server 2012 for Embedded Systems SQL Server 2012 Standard

Проблема

При использовании функции репликации в Microsoft SQL Server 2012 или SQL Server 2014 агент средства чтения журналов может периодически давать сбой. Кроме того, в журнале ошибок SQL Server отображается одно из следующих сообщений об ошибке:

Ошибка 1

Примечание

< Дата><Время><SPID> Дамп стека, отправляемый в <DiskLocation>
< Дата><Время><SPID> * *******************************************************************************
< Дата><Время><SPID> *
< Дата><Время><SPID> * НАЧАЛО ДАМПА СТЕКА:
< Дата><Время><SPID><* Дата><и время><SPID>
< Дата><Время><SPID> *
< Дата><Время><SPID> * Местоположение: replicat.cpp:2746
< Дата><Время><SPID> * Выражение: pRowset
< Дата><Время><SPID> * SPID: <SPID>
< Дата><Время><SPID> * Идентификатор процесса: <ProcessID>
< Дата><Время><SPID> *
< Дата><Время><SPID> * Входной буфер 109 байт -
< Дата><Время><SPID> * 16 00 00 00 12 00 00 00 02 00 00 00 00 00 00 00 00 00
< Дата><Время><SPID> * s p _ r e p 01 00 00 00 0b 00 73 00 70 00 5f 00 72 00 65 00 70 00
< Дата><Время><SPID> * l c m d s & ô 6c 00 63 00 6d 00 64 00 73 00 00 00 00 00 26 04 04 F4
< Дата><Время><SPID> * & & ÿ 01 00 00 00 00 26 04 04 00 00 00 00 00 00 26 04 04 ff
< Дата><Время><SPID> * ÿÿ ¥ & ff ff ff 00 00 A5 0a 00 00 00 00 00 26 04 04 00 00 00 00
< Дата><Время><SPID> * & & ¡ 00 00 00 26 04 04 00 00 00 00 00 00 26 04 04 20 A1 07
< Дата><Время><SPID> * 00

Ошибка 2

Примечание

<Дата><и время><Ошибка SID> : 5243, серьезность: 22, состояние: 7.
<SPID><> даты и времени><. Во время выполнения внутренней операции было обнаружено несоответствие. Обратитесь в службу технической поддержки.
<Дата><и время><SPID> ex_raise2: Исключение возникло, основной = 52, незначительный = 43, состояние = 7, серьезность = 22, попытка создать дамп симптомов
<Дата><и время><SPID> **Поток дампа - spid = 0, EC = 0x000000297EC97DE0
<Дата><и время><SPID> ***Дамп стека, отправляемый в <DiskLocation>
<Дата><и время><SPID> * *******************************************************************************
<SPID даты><и времени><> *
<Дата><и время><SPID> * НАЧАЛО ДАМПА СТЕКА:
<Date<>Time><SPID> * <Date><Time><SPID>
<SPID даты><и времени><> *
<Дата><и время><SPID> * ex_raise2: Возникло исключение, основной=52, незначительный=43, состояние=7, серьезность=22
<SPID даты><и времени><> *
<Дата><и время><SPID> * Входной буфер: 109 байт -
<Дата><и время><SPID> * 16 00 00 00 12 00 00 00 02 00 00 00 00 00 00 00 00 00 00 00
<Дата><и время><SPID> * s p _ r e p 01 00 00 00 0b 00 73 00 70 00 5f 00 72 00 65 00 70 00
<Дата><и время><SPID> * l c m d s & ô 6c 00 63 00 6d 00 64 00 73 00 00 00 00 00 26 04 04 f4
<Дата><и время><SPID> * & & ÿ 01 00 00 00 00 26 04 04 00 00 00 00 00 00 26 04 04 ff
<Дата><и время><SPID> * ÿÿ ¥ & ff ff ff 00 00 a5 0a 00 00 00 00 00 00 26 04 04 00 00 00
<Дата><и время><SPID> * & & ¡ 00 00 00 26 04 04 00 00 00 00 00 00 26 04 04 20 a1 07
<Дата><и время><SPID> * 00

Причина

Эта проблема возникает, когда одна и та же статья опубликована в нескольких транзакционных изданиях или одна и та же статья является частью CDC и транзакционной публикации.

Решение

Сведения о накопительном пакете обновления

Эта проблема была впервые исправлена в следующем накопительном пакете обновления SQL Server:
 

Рекомендация. Установите последний накопительный пакет обновления для SQL Server

Каждый новый накопительный пакет обновления для SQL Server содержит все исправления и исправления безопасности, которые входили в состав предыдущего накопительного пакета обновления. Рекомендуется скачать и установить последние накопительные пакеты обновления для SQL Server:

Состояние

Корпорация Майкрософт подтвердила, что это проблема продуктов Microsoft, перечисленных в разделе «Относится к».