KB4038634 — накопительный пакет обновления 1 для SQL Server 2017 г.

Дата выхода: 24 октября 2017 г.
Версия: 14.0.3006.16

Сводка

В этой статье описывается накопительный пакет обновления 1 (CU1) для Microsoft SQL Server 2017. Это обновление содержит 71 исправление, которое было выпущено после выпуска SQL Server 2017 RTM, и обновляет компоненты в следующих сборках:

  • SQL Server — версия продукта: 14.0.3006.16, версия файла: 2017.140.3006.16
  • Analysis Services — версия продукта: 14.0.1.439, версия файла: 2017.140.1.439

Известные проблемы, связанные с этим обновлением

В этом накопительном пакете обновления нет известных проблем.

Улучшения и исправления, включенные в это обновление

Доступна скачиваемая книга Excel, содержащая сводный список сборок вместе с текущим жизненным циклом поддержки. Файл Excel также содержит подробные списки исправлений для SQL Server 2019 и SQL Server 2017. Выберите, чтобы скачать этот файл Excel.

Примечание

На отдельные записи в следующей таблице можно напрямую ссылаться с помощью закладки. Если выбрать любой идентификатор записи ошибки в таблице, к URL-адресу будет добавлен тег закладки с использованием формата "#NNNNNNNN". Затем этим URL-адресом можно поделиться с другими пользователями, чтобы они могли напрямую перейти к нужному исправлению в таблице.

Дополнительные сведения об исправленных ошибках и улучшениях, включенных в этот накопительный пакет обновления, см. в следующих статьях базы знаний Майкрософт.

Ссылка на ошибку Описание Область исправления Компонент Платформа
10682349 ИСПРАВЛЕНО: SSAS аварийно завершает работу при доступе к файлам .vmp в SQL Server 2017 и SQL Server 2016 (KB4024023) Analysis Services Analysis Services Все
10682367 ИСПРАВЛЕНИЕ: сбой SSAS при выполнении запроса DAX или MDX в SSAS в табличном режиме (KB4032543) Analysis Services Analysis Services Все
10687745 ИСПРАВЛЕНО: безопасность размеров игнорируется Power BI Desktop в SQL Server Analysis Services (многомерная модель) (KB4018908) Analysis Services Analysis Services Все
10687757 ИСПРАВЛЕНО: сбой SSAS при выполнении запроса многомерных выражений, ссылающегося на вычисляемый элемент, который является дочерним элементом другой иерархии (KB4022753) Analysis Services Analysis Services Все
10687784 ИСПРАВЛЕНИЕ: бюллетень по безопасности MS16-136 breaks the SSRS data source type in PowerPivot in SQL Server 2017 and SQL Server 2016 (KB4025402) Analysis Services Analysis Services Все
10868739 FIX: SSAS crashes when you processing an SSAS database or cube in SQL Server 2014 or 2017 (KB4039509) Analysis Services Analysis Services Windows
10868754 ИСПРАВЛЕНО: при выполнении операций обновления процесса в SSAS (KB4033789) может возникать утечка памяти Analysis Services Analysis Services Windows
10868777 ИСПРАВЛЕНО: SQL Server 2016 или 2017 Analysis Services могут давать сбой в определенной ситуации (KB3208545) Analysis Services Analysis Services Windows
10965958 ИСПРАВЛЕНО: непредвиденная ошибка исключения возникает, когда мера XIRR обрабатывает слишком много записей в SSAS 2016 или 2017 (KB4034789) Analysis Services Analysis Services Windows
10965991 ИСПРАВЛЕНО: ошибка "Неоднозначные пути" при развертывании базы данных табличной модели в Analysis Services в SQL Server 2016 или 2017 (KB4040085) Analysis Services Analysis Services Windows
10682338 ИСПРАВЛЕНИЕ. Неверные результаты запроса многомерных выражений при выполнении перекрестного соединения таблицы элемента иерархии таблицы в SSAS (KB4022594) Analysis Services Analysis Services Все
10682343 ИСПРАВЛЕНО: сбой SSAS при добавлении меры, ссылающейся на пустые значения в Power BI (KB4021994) Analysis Services Analysis Services Все
10682356 ИСПРАВЛЕНО: SSAS аварийно завершает работу, когда числовой вычисляемый столбец должен изменить свою схему кодировки во время фазы ProcessRecalc (KB3212541) Analysis Services Analysis Services Все
10868755 ИСПРАВЛЕНО: При экспорте отчета Reporting Services в формат PDF в SQL Server 2017 (KB4040512) возникает ошибка Analysis Services Reporting Services Все
10965982 ИСПРАВЛЕНО: Всплеск памяти в LSASS.EXE при включении режима базовой проверки подлинности в SSRS 2016 или 2017 (KB4039124) Analysis Services Reporting Services Windows
10965994 ИСПРАВЛЕНО: ошибка при экспорте отчета SSRS на устройство iOS в SQL Server 2016 или 2017 (KB4043478) Analysis Services Reporting Services Windows
10965998 FIX: Отсутствует горизонтальная полоса прокрутки на странице подписки на веб-портале SSRS 2016 или 2017 (KB4039126) Analysis Services Reporting Services Windows
10965999 FIX: «Папка... Не существует" при удалении папки на веб-портале службы отчетов SQL Server 2017 (KB4039125) Analysis Services Reporting Services Windows
10966008 ИСПРАВЛЕНИЕ: веб-часть средства просмотра отчетов не допускает полную вертикальную полосу прокрутки после установки определенной высоты веб-части (KB4039058) Analysis Services Reporting Services Windows
10729322 ИСПРАВЛЕНО: Reporting Services "SortExpression" возникаетrsComparisonError, когда в столбце есть NULL значение "DataTimeOffset" (KB4017827) Analysis Services Reporting Services Windows
10868736 ИСПРАВЛЕНО. Ошибка при экспорте база знаний DQS, содержащего домены в клиенте DQS в SQL Server 2014 или 2017 (KB4022483) Data Quality Services Import-Export Windows
10966015 ИСПРАВЛЕНИЕ: пакет SSIS, содержащий символы немецких умляутов, завершается ошибкой при выполнении после добавочного развертывания пакета в SQL Server 2016 или 2017 (KB4038590) Integration Services Средства Windows
10867556 ИСПРАВЛЕНО: Excel аварийно завершает работу при сохранении книги в формате PDF с помощью надстройки Adobe Acrobat PDFMaker, если надстройка MDS для Excel в SQL Server также установлена (KB4022895) Master Data Services Клиент Windows
10687776 ИСПРАВЛЕНИЕ: развертывание папки "Сущности" на странице "Управление группами" занимает много времени в SQL Server 2017 MDS и SQL Server 2016 MDS (KB4023865) Master Data Services Сервер Все
10682313 ИСПРАВЛЕНИЕ: загрузка данных из промежуточных таблиц занимает гораздо больше времени при использовании рекурсивной иерархии в Master Data Services (KB4043103) Master Data Services Сервер Все
10986691 ИСПРАВЛЕНИЕ: Непредвиденная ошибка возникает при использовании функции DReplay для воспроизведения перехваченной трассировки в SQL Server 2017 (KB4045678) Клиентские средства SQL Server Средства оценки производительности баз данных Windows
10270905 FIX: Backup of availability database via VSS-based application may fail in SQL Server (KB4040108) Подсистема SQL Server Восстановление резервной копии Все
10868723 ИСПРАВЛЕНИЕ: SQL Server управляемое резервное копирование не удаляет старые резервные копии, срок хранения которых истек в SQL Server 2014 или 2017 (KB4038882) Подсистема SQL Server Восстановление резервной копии Windows
10868726 ИСПРАВЛЕНО: управляемое резервное копирование периодически завершается сбоем из-за ошибки SQLVDI в SQL Server 2014 или 2017 (KB4039511) Подсистема SQL Server Восстановление резервной копии Windows
10868733 ИСПРАВЛЕНО: управляемое резервное копирование в Microsoft Azure прекращается после резервного копирования больших баз данных в SQL Server 2014 или 2017 (KB4040376) Подсистема SQL Server Восстановление резервной копии Windows
10966001 ИСПРАВЛЕНО. Ошибка нарушения ограничения, возвращаемая функцией managed_backup.fn_available_backups после установки накопительного пакета обновления 2 для SQL Server 2016 SP1 (KB4040531) Подсистема SQL Server Восстановление резервной копии Windows
10966019 ИСПРАВЛЕНИЕ: SQL Server Управляемые резервные копии не запускают запланированное резервное копирование журналов в SQL Server 2016 и 2017 (KB4040535) Подсистема SQL Server Восстановление резервной копии Windows
10965952 Обновление для повышения производительности динамических административных представлений columnstore "column_store_row_groups" и "dm_db_column_store_row_group_physical_stats" в SQL Server 2016 или 2017 (KB4024860) Подсистема SQL Server Хранилища столбцов Все
10936099 Обновление, позволяющее SQL Server 2017 Express Edition выступать в качестве следящего сервера в сеансе зеркального отображения базы данных (KB4045687) Подсистема SQL Server Высокая доступность и аварийное восстановление Windows
10921835 ИСПРАВЛЕНО: Повреждение памяти происходит при отработке отказа группы доступности для транзакций DTC в SQL Server 2017 (KB4046065) Подсистема SQL Server Высокая доступность и аварийное восстановление Windows
10936097 ИСПРАВЛЕНО: SQL Server 2017 сообщает, что все транзакции завершены, даже если некоторые транзакции сталкиваются с ошибками при попытке фиксации (KB4046066) Подсистема SQL Server Высокая доступность и аварийное восстановление Windows
10965980 ИСПРАВЛЕНИЕ: отказ зеркального отображения базы данных завершается ошибкой 3456 в SQL Server 2016 или 2017 (KB4042251) Подсистема SQL Server Высокая доступность и аварийное восстановление Windows
10965988 ИСПРАВЛЕНИЕ: автоматическое заполнение в группах доступности случайным образом вызывает ошибку 41169 в SQL Server 2016 или 2017 (KB4040519) Подсистема SQL Server Высокая доступность и аварийное восстановление Все
10936183 ИСПРАВЛЕНИЕ: снижение производительности при использовании In-Memory OLTP с группами доступности Always On в SQL Server 2016 или 2017 (KB4039868) Подсистема SQL Server Выполняющаяся в памяти OLTP Windows
10936185 ИСПРАВЛЕНО: некорректное поведение при использовании оптимизированных для памяти таблиц с оператором where exists в SQL Server 2016 или 2017 (KB4039776) Подсистема SQL Server Выполняющаяся в памяти OLTP Windows
10985578 ИСПРАВЛЕНИЕ: Возникает ошибка при передаче оптимизированной для памяти таблицы во встроенную функцию с табличным значением при вызове из хранимой процедуры в SQL Server 2017 (KB4045329) Подсистема SQL Server Выполняющаяся в памяти OLTP Windows
11000432 ИСПРАВЛЕНО: в течение нескольких минут или часов после создания резервной копии snapshot для базы данных, содержащей оптимизированные для памяти таблицы, в SQL Server 2017 (KB4046099) возникает ошибка утверждения Подсистема SQL Server Выполняющаяся в памяти OLTP Windows
10749795 ИСПРАВЛЕНИЕ: переносимость и производительность различаются между сопоставлениями планировщика Windows и Linux в SQL Server 2017 (KB4043455) Подсистема SQL Server Linux Linux
11080104 ИСПРАВЛЕНО: переход на летнее время в часовом поясе Сан-Паулу не определяется SQL Server 2017 на Linux (KB4052938) Подсистема SQL Server Linux Linux
10966010 ИСПРАВЛЕНО: разрыв цепочки журналов в таблице "managed_backup.fn_available_backups" в SQL Server 2016 или 2017 (KB4040530) Подсистема SQL Server Службы управления Windows
10936563 ИСПРАВЛЕНО: EXCEPTION_ACCESS_VIOLATION ошибка при выполнении хранимой процедуры sys.sp_MScdc_capture_job в SQL Server (KB4039089) Подсистема SQL Server Метаданные Все
10938809 ИСПРАВЛЕНО: при создании базы данных в SQL Server 2017 (KB4044009 возникает состояние взаимоблокировки) Подсистема SQL Server Метаданные Windows
10070694 ИСПРАВЛЕНО: запросы к внешним таблицам PolyBase возвращают повторяющиеся строки в SQL Server 2017 и SQL Server 2016 (KB4019840) Подсистема SQL Server PolyBase Все
10965984 ИСПРАВЛЕНО: нарушение прав доступа возникает при вызове триггера DDL командой CREATE EXTERNAL TABLE в SQL Server 2016 или 2017 (KB4039966) Подсистема SQL Server PolyBase Windows
10965968 ИСПРАВЛЕНИЕ: Возвращает неправильные результаты при запросе вычисляемого столбца после установки исправления, описанного в статье KB 3213683, и включения TF 176 в SQL Server 2016 или 2017 (KB4040533) Подсистема SQL Server Программирование Все
10966016 ИСПРАВЛЕНО: пакет SSIS не запускается, если он выполняется хранимой процедурой CLR, у пользователя которой нет разрешений SYSADMIN (KB4039736) Подсистема SQL Server Программирование Windows
10867554 ИСПРАВЛЕНО. Удаленный экземпляр SQL Server аварийно завершает работу при выполнении хранимой процедуры, которая массово загружает неполный файл данных во временную таблицу (KB4043459) Подсистема SQL Server Программирование Windows
10966009 ИСПРАВЛЕНО: EXCEPTION_ACCESS_VIOLATION для запросов с использованием инструкции sys.dm_os_memory_objects в SQL Server 2016 или 2017 (KB4038113) Подсистема SQL Server Выполнение запроса Windows
9704947 Улучшение: в операторы CREATE и UPDATE STATISTICS добавлена новая ключевое слово для сохранения частоты выборки для будущих обновлений статистики в SQL Server (KB4039284) Подсистема SQL Server Оптимизатор запросов Все
10889338 ИСПРАВЛЕНО: ошибка деления на ноль возникает, когда параллельный запрос принудительно выполняется в последовательном режиме в SQL Server 2017 (KB4042885) Подсистема SQL Server Оптимизатор запросов Windows
11003299 ИСПРАВЛЕНО: FORCE_LAST_GOOD_PLAN рекомендация зависает в состоянии "Проверка" при первой проверке в SQL Server 2017 г. (KB4046055) Подсистема SQL Server Хранилище запросов Windows
11003402 FIX: Automatic tuning settings can't be configure on ModelDB in SQL Server 2017 (KB4046022) Подсистема SQL Server Хранилище запросов Windows
10691456 ИСПРАВЛЕНО: не удается удалить статью о выполнении хранимой процедуры из публикации P2P в SQL Server (KB4023926) Подсистема SQL Server Репликация Windows
10691460 ИСПРАВЛЕНО: невозможно отключить "сбор данных изменения", если какой-либо столбец зашифрован с помощью функции "Always Encrypted" в SQL Server (KB4034376) Подсистема SQL Server Репликация Все
10978904 ИСПРАВЛЕНО: Отслеживание изменений ошибка ручной очистки с ошибкой несуществования таблицы в SQL Server 2014 и 2017 (KB4043624) Подсистема SQL Server Репликация Все
10687780 ИСПРАВЛЕНО: маска данных в столбце с плавающей запятой не применяется в SQL Server 2017 и SQL Server 2016 (KB4023995) Подсистема SQL Server Инфраструктура безопасности Все
10867553 ИСПРАВЛЕНИЕ: функция SUSER_SNAME возвращает разные результаты в период с SQL Server 2014 по SQL Server 2016 или 2017 (KB4025020) Подсистема SQL Server Инфраструктура безопасности Windows
10982548 ИСПРАВЛЕНО: сбой выполнения, когда функция SQL CLR вызывает операторы Transact-SQL посредством вызовов олицетворения в SQL Server 2017 (KB4046918) Подсистема SQL Server Инфраструктура безопасности Все
10868749 FIX: Access violation for spatial data types query via linked server in SQL Server 2014 or 2017 (KB4040401) Подсистема SQL Server ОС SQL Windows
11008122 Обновление для включения новых динамических представлений и функций управления в SQL Server 2017 (KB4046638) Подсистема SQL Server Управление хранилищем Windows
10870647 ИСПРАВЛЕНО: не удалось обрезать раздел секционированной таблицы, если она содержит расширенный индекс или индекс XML в SQL Server 2016 или 2017 (KB4024622) Подсистема SQL Server Раздел индекса таблицы Windows
10998915 ИСПРАВЛЕНО: инструкции DML, использующие каскадные операции, завершаются ошибкой в SQL Server 2017 (KB4046744) Подсистема SQL Server Темпоральная Windows
10865727 ИСПРАВЛЕНО. Ошибка утверждения возникает на дополнительном реплика при возобновлении приостановленной базы данных доступности в SQL Server 2016 или 2017 (KB4024393) Подсистема SQL Server Транзакционные услуги Windows
10936411 ИСПРАВЛЕНО: Косвенные контрольные точки в базе данных tempdb приводят к ошибке "Non-yielding Scheduler" в SQL Server 2016 или 2017 (KB4040276) Подсистема SQL Server Транзакционные услуги Windows
10868768 ИСПРАВЛЕНО: Нарушение прав доступа возникает при использовании sp_xml_preparedocument для открытия XML-документов в SQL Server 2014 или 2017 (KB4039510) Подсистема SQL Server XML Windows
10998673 ИСПРАВЛЕНИЕ: невозможно установить SQL Server 2017, если имя/идентификатор/путь к экземпляру содержит многобайтовые символы (KB4046044) Настройка SQL Платформа развертывания Windows

Получение или скачивание этого или последнего накопительного пакета

Получение или скачивание последнего накопительного пакета обновления для Windows (рекомендуется)

Следующее обновление доступно в Центре загрузки Майкрософт:

Скачайте последний накопительный пакет обновления для SQL Server 2017 прямо сейчас

Если страница скачивания не отображается, обратитесь в службу поддержки пользователей Майкрософт, чтобы получить накопительный пакет обновления.

Получение или скачивание этого накопительного пакета обновления для Windows из каталога Центра обновления Майкрософт

Примечание

После выпуска будущих накопительных пакетов обновления для SQL Server 2017 этот и все предыдущие накопительные обновления можно будет скачать из каталога Центра обновления Майкрософт. Однако рекомендуется всегда устанавливать последний доступный накопительный пакет обновления.

Следующее обновление доступно в каталоге Центра обновления Майкрософт:

Скачайте накопительный пакет обновления для SQL Server 2017 CU1 прямо сейчас

Получение или скачивание последнего накопительного пакета обновления для Linux

Чтобы обновить SQL Server 2017 в Linux до последней версии CU, сначала необходимо настроить репозиторий накопительного пакета обновления. Затем обновите пакеты SQL Server с помощью соответствующей команды обновления для конкретной платформы.

Инструкции по установке и прямые ссылки на загрузку пакетов CU см. в заметках о выпуске SQL Server 2017.

Сведения о файлах

Сведения о файловом хэше

Вы можете проверить загрузку, вычислив хэш файлаSQLServer2017-KB4038634-x64.exe с помощью следующей команды:

certutil -hashfile SQLServer2017-KB4038634-x64.exe SHA256

Имя файла Хэш SHA256
SQLServer2017-KB4038634-x64.exe C1187BF68AC07294D8242C4126F021D3BEEF561F86931A8229B3D4AE86993A73
Сведения о файле накопительного пакета обновления

Английская версия пакета содержит файлы с атрибутами, указанными в следующей таблице, или более поздние. Значения даты и времени для этих файлов указаны в формате UTC. При просмотре сведений о файлах выполняется перевод их в местное время. Чтобы узнать разницу между временем UTC и местным временем, откройте вкладку "Часовой пояс" элемента "Дата и время" на панели управления.

Версии на базе x64

SQL Server 2017 Analysis Services

Имя файла Версия файла Размер файла Дата Время Платформа
Microsoft.analysisservices.server.core.dll 14.0.1.439 1380512 1 октября 2017 г. 22:06 x86
Microsoft.data.mashup.dll 2.49.4831.201 174816 1 октября 2017 г. 20:52 x86
Microsoft.data.mashup.oledb.dll 2.49.4831.201 36576 1 октября 2017 г. 20:52 x86
Microsoft.data.mashup.preview.dll 2.49.4831.201 48864 1 октября 2017 г. 20:52 x86
Microsoft.data.mashup.providercommon.dll 2.49.4831.201 105184 1 октября 2017 г. 20:52 x86
Microsoft.hostintegration.connectors.dll 2.49.4831.201 5167328 1 октября 2017 г. 20:52 x86
Microsoft.mashup.container.exe 2.49.4831.201 26336 1 октября 2017 г. 20:52 x64
Microsoft.mashup.container.netfx40.exe 2.49.4831.201 26848 1 октября 2017 г. 20:52 x64
Microsoft.mashup.container.netfx45.exe 2.49.4831.201 26848 19 октября 2017 г. 12:13 x64
Microsoft.mashup.eventsource.dll 2.49.4831.201 159456 1 октября 2017 г. 20:52 x86
Microsoft.mashup.oauth.dll 2.49.4831.201 82656 1 октября 2017 г. 20:52 x86
Microsoft.mashup.oledbprovider.dll 2.49.4831.201 67296 19 октября 2017 г. 12:13 x86
Microsoft.mashup.shims.dll 2.49.4831.201 25824 1 октября 2017 г. 20:52 x86
Microsoft.mashup.storage.xmlserializers.dll 1.0.0.0 151264 1 октября 2017 г. 20:52 x86
Microsoft.mashupengine.dll 2.49.4831.201 13032160 1 октября 2017 г. 20:52 x86
Microsoft.powerbi.adomdclient.dll 14.0.1.484 1044672 1 октября 2017 г. 20:52 x86
Msmdlocal.dll 2017.140.1.439 40357024 1 октября 2017 г. 22:06 x86
Msmdlocal.dll 2017.140.1.439 59898528 19 октября 2017 г. 12:22 x64
Msmdpump.dll 2017.140.1.439 8544416 19 октября 2017 г. 12:22 x64
Msmdsrv.exe 2017.140.1.439 60589352 1 октября 2017 г. 22:07 x64
Msmgdsrv.dll 2017.140.1.439 8208544 1 октября 2017 г. 22:07 x64
Msmgdsrv.dll 2017.140.1.439 7310496 19 октября 2017 г. 12:15 x86
Powerbiextensions.dll 2.49.4831.201 5316832 1 октября 2017 г. 20:52 x64
Sql_as_keyfile.dll 2017.140.3006.16 100512 19 октября 2017 г. 12:19 x64
Sqlboot.dll 2017.140.3006.16 194720 19 октября 2017 г. 11:08 x64
Sqlceip.exe 14.0.3006.16 249504 19 октября 2017 г. 12:18 x86

Службы баз данных SQL Server 2017 Common Core

Имя файла Версия файла Размер файла Дата Время Платформа
Microsoft.analysisservices.adomdclient.dll 14.0.1.439 1088672 1 октября 2017 г. 22:04 x86
Microsoft.analysisservices.adomdclient.dll 14.0.1.439 1088672 1 октября 2017 г. 22:06 x86
Microsoft.analysisservices.core.dll 14.0.1.439 1380648 1 октября 2017 г. 22:04 x86
Microsoft.analysisservices.xmla.dll 14.0.1.439 741536 1 октября 2017 г. 22:04 x86
Microsoft.analysisservices.xmla.dll 14.0.1.439 741536 1 октября 2017 г. 22:06 x86
Pbsvcacctsync.dll 2017.140.3006.16 66720 19 октября 2017 г. 12:19 x86
Pbsvcacctsync.dll 2017.140.3006.16 80544 19 октября 2017 г. 12:22 x64
Sql_common_core_keyfile.dll 2017.140.3006.16 100512 19 октября 2017 г. 12:19 x64
Sqlftacct.dll 2017.140.3006.16 53920 19 октября 2017 г. 11:09 x86
Sqlftacct.dll 2017.140.3006.16 61088 19 октября 2017 г. 12:22 x64
Sqlmgmprovider.dll 2017.140.3006.16 371864 19 октября 2017 г. 12:15 x86
Sqlmgmprovider.dll 2017.140.3006.16 414880 19 октября 2017 г. 12:21 x64

Базовый экземпляр служб баз данных SQL Server 2017

Имя файла Версия файла Размер файла Дата Время Платформа
Datacollectorcontroller.dll 2017.140.3006.16 224928 19 октября 2017 г. 11:08 x64
Fssres.dll 2017.140.3006.16 88224 19 октября 2017 г. 12:21 x64
Hadrres.dll 2017.140.3006.16 186528 19 октября 2017 г. 12:21 x64
Hkcompile.dll 2017.140.3006.16 1421472 19 октября 2017 г. 11:08 x64
Hkengine.dll 2017.140.3006.16 5858464 19 октября 2017 г. 11:08 x64
Hkruntime.dll 2017.140.3006.16 161952 19 октября 2017 г. 12:21 x64
Microsoft.analysisservices.applocal.xmla.dll 14.0.1.439 740136 19 октября 2017 г. 12:20 x86
Microsoft.sqlautoadmin.autobackupagent.dll 14.0.3006.16 237216 19 октября 2017 г. 12:20 x86
Microsoft.sqlautoadmin.sqlautoadmin.dll 14.0.3006.16 79520 19 октября 2017 г. 12:09 x86
Microsoft.sqlserver.xevent.linq.dll 2017.140.3006.16 303776 19 октября 2017 г. 11:02 x64
Qds.dll 2017.140.3006.16 1164448 19 октября 2017 г. 14:38 x64
Sqagtres.dll 2017.140.3006.16 72864 19 октября 2017 г. 12:22 x64
Sql_engine_core_inst_keyfile.dll 2017.140.3006.16 100512 19 октября 2017 г. 12:19 x64
Sqlaccess.dll 2017.140.3006.16 474784 19 октября 2017 г. 11:08 x64
Sqlagent.exe 2017.140.3006.16 578720 19 октября 2017 г. 12:21 x64
Sqlagentctr140.dll 2017.140.3006.16 60576 19 октября 2017 г. 11:08 x64
Sqlagentctr140.dll 2017.140.3006.16 51872 19 октября 2017 г. 12:15 x86
Sqlboot.dll 2017.140.3006.16 194720 19 октября 2017 г. 11:08 x64
Sqlceip.exe 14.0.3006.16 249504 19 октября 2017 г. 12:18 x86
Sqlcmdss.dll 2017.140.3006.16 71840 19 октября 2017 г. 12:21 x64
Sqldk.dll 2017.140.3006.16 2789024 19 октября 2017 г. 14:38 x64
Sqlevn70.rll 2017.140.3006.16 3288224 19 октября 2017 г. 11:00 x64
Sqlevn70.rll 2017.140.3006.16 3587232 19 октября 2017 г. 11:00 x64
Sqlevn70.rll 2017.140.3006.16 1441440 19 октября 2017 г. 11:00 x64
Sqlevn70.rll 2017.140.3006.16 2084512 19 октября 2017 г. 11:00 x64
Sqlevn70.rll 2017.140.3006.16 3205792 19 октября 2017 г. 11:01 x64
Sqlevn70.rll 2017.140.3006.16 3329696 19 октября 2017 г. 11:01 x64
Sqlevn70.rll 2017.140.3006.16 3769504 19 октября 2017 г. 11:01 x64
Sqlevn70.rll 2017.140.3006.16 3907232 19 октября 2017 г. 11:01 x64
Sqlevn70.rll 2017.140.3006.16 3904160 19 октября 2017 г. 11:02 x64
Sqlevn70.rll 2017.140.3006.16 2031264 19 октября 2017 г. 11:02 x64
Sqlevn70.rll 2017.140.3006.16 4015264 19 октября 2017 г. 11:02 x64
Sqlevn70.rll 2017.140.3006.16 3472032 19 октября 2017 г. 11:03 x64
Sqlevn70.rll 2017.140.3006.16 3776672 19 октября 2017 г. 11:03 x64
Sqlevn70.rll 2017.140.3006.16 3358368 19 октября 2017 г. 11:03 x64
Sqlevn70.rll 2017.140.3006.16 3282592 19 октября 2017 г. 11:04 x64
Sqlevn70.rll 2017.140.3006.16 3625632 19 октября 2017 г. 11:04 x64
Sqlevn70.rll 2017.140.3006.16 3393184 19 октября 2017 г. 11:04 x64
Sqlevn70.rll 2017.140.3006.16 3579032 19 октября 2017 г. 11:04 x64
Sqlevn70.rll 2017.140.3006.16 3666592 19 октября 2017 г. 11:05 x64
Sqlevn70.rll 2017.140.3006.16 1494176 19 октября 2017 г. 11:05 x64
Sqlevn70.rll 2017.140.3006.16 3810976 19 октября 2017 г. 11:06 x64
Sqlevn70.rll 2017.140.3006.16 3775136 19 октября 2017 г. 11:07 x64
Sqllang.dll 2017.140.3006.16 41170080 19 октября 2017 г. 14:57 x64
Sqlmin.dll 2017.140.3006.16 40221344 19 октября 2017 г. 14:50 x64
Sqlolapss.dll 2017.140.3006.16 106656 19 октября 2017 г. 11:08 x64
Sqlos.dll 2017.140.3006.16 26272 19 октября 2017 г. 11:03 x64
Sqlpowershellss.dll 2017.140.3006.16 66720 19 октября 2017 г. 12:21 x64
Sqlrepss.dll 2017.140.3006.16 63136 19 октября 2017 г. 12:21 x64
Sqlscm.dll 2017.140.3006.16 69280 19 октября 2017 г. 11:08 x64
Sqlscriptdowngrade.dll 2017.140.3006.16 27800 19 октября 2017 г. 11:08 x64
Sqlscriptupgrade.dll 2017.140.3006.16 5871264 19 октября 2017 г. 09:52 x64
Sqlservr.exe 2017.140.3006.16 485024 19 октября 2017 г. 14:38 x64
Sqlsvc.dll 2017.140.3006.16 160416 19 октября 2017 г. 12:21 x64
Sqltses.dll 2017.140.3006.16 9536160 19 октября 2017 г. 14:38 x64
Sqsrvres.dll 2017.140.3006.16 259744 19 октября 2017 г. 12:22 x64
Svl.dll 2017.140.3006.16 153760 19 октября 2017 г. 12:22 x64
Xpadsi.exe 2017.140.3006.16 88224 19 октября 2017 г. 12:21 x64
Xplog70.dll 2017.140.3006.16 74400 19 октября 2017 г. 12:22 x64
Xpsqlbot.dll 2017.140.3006.16 32416 19 октября 2017 г. 12:22 x64
Xpstar.dll 2017.140.3006.16 436384 19 октября 2017 г. 12:21 x64

SQL Server 2017 Database Services Core Shared

Имя файла Версия файла Размер файла Дата Время Платформа
Dts.dll 2017.140.3006.16 2996896 19 октября 2017 г. 12:19 x64
Dtsconn.dll 2017.140.3006.16 495264 19 октября 2017 г. 12:19 x64
Dtshost.exe 2017.140.3006.16 103072 19 октября 2017 г. 12:21 x64
Dtspipeline.dll 2017.140.3006.16 1264288 19 октября 2017 г. 12:19 x64
Dtutil.exe 2017.140.3006.16 145568 19 октября 2017 г. 12:19 x64
Microsoft.analysisservices.applocal.core.dll 14.0.1.439 1381536 1 октября 2017 г. 22:06 x86
Msxmlsql.dll 2017.140.3006.16 1450656 19 октября 2017 г. 11:08 x64
Sql_engine_core_shared_keyfile.dll 2017.140.3006.16 100512 19 октября 2017 г. 12:19 x64
Sqlscm.dll 2017.140.3006.16 59544 19 октября 2017 г. 11:01 x86
Sqlscm.dll 2017.140.3006.16 69280 19 октября 2017 г. 11:08 x64
Sqlsvc.dll 2017.140.3006.16 133280 19 октября 2017 г. 11:01 x86
Sqlsvc.dll 2017.140.3006.16 160416 19 октября 2017 г. 12:21 x64

SQL Server 2017 sql_extensibility

Имя файла Версия файла Размер файла Дата Время Платформа
Launchpad.exe 2017.140.3006.16 1121440 19 октября 2017 г. 12:21 x64
Sql_extensibility_keyfile.dll 2017.140.3006.16 100512 19 октября 2017 г. 12:19 x64
Sqlsatellite.dll 2017.140.3006.16 918688 19 октября 2017 г. 12:22 x64

SQL Server 2017 Full-Text Engine

Имя файла Версия файла Размер файла Дата Время Платформа
Fd.dll 2017.140.3006.16 665760 19 октября 2017 г. 11:08 x64
Fdhost.exe 2017.140.3006.16 113312 19 октября 2017 г. 12:21 x64
Fdlauncher.exe 2017.140.3006.16 61600 19 октября 2017 г. 11:08 x64
Sql_fulltext_keyfile.dll 2017.140.3006.16 100512 19 октября 2017 г. 12:19 x64
Sqlft140ph.dll 2017.140.3006.16 66208 19 октября 2017 г. 11:08 x64

SQL Server 2017 sql_inst_mr

Имя файла Версия файла Размер файла Дата Время Платформа
Imrdll.dll 14.0.3006.16 23712 19 октября 2017 г. 11:08 x86
Sql_inst_mr_keyfile.dll 2017.140.3006.16 100512 19 октября 2017 г. 12:19 x64

Службы интеграции SQL Server 2017

Имя файла Версия файла Размер файла Дата Время Платформа
Attunity.sqlserver.cdccontroltask.dll 5.0.0.70 75248 15 сентября 2017 г. 06:38 x86
Attunity.sqlserver.cdcsplit.dll 5.0.0.70 36336 15 сентября 2017 г. 06:38 x86
Attunity.sqlserver.cdcsrc.dll 5.0.0.70 76272 19 октября 2017 г. 12:10 x86
Dts.dll 2017.140.3006.16 2548384 19 октября 2017 г. 11:01 x86
Dts.dll 2017.140.3006.16 2996896 19 октября 2017 г. 12:19 x64
Dtsconn.dll 2017.140.3006.16 397984 19 октября 2017 г. 11:01 x86
Dtsconn.dll 2017.140.3006.16 495264 19 октября 2017 г. 12:19 x64
Dtshost.exe 2017.140.3006.16 88224 19 октября 2017 г. 12:15 x86
Dtshost.exe 2017.140.3006.16 103072 19 октября 2017 г. 12:21 x64
Dtspipeline.dll 2017.140.3006.16 1057440 19 октября 2017 г. 12:10 x86
Dtspipeline.dll 2017.140.3006.16 1264288 19 октября 2017 г. 12:19 x64
Dtutil.exe 2017.140.3006.16 125088 19 октября 2017 г. 11:01 x86
Dtutil.exe 2017.140.3006.16 145568 19 октября 2017 г. 12:19 x64
Isdeploymentwizard.exe 14.0.3006.16 477344 19 октября 2017 г. 12:58 x86
Isdeploymentwizard.exe 14.0.3006.16 476832 19 октября 2017 г. 13:08 x64
Microsoft.analysisservices.applocal.core.dll 14.0.1.439 1381536 1 октября 2017 г. 22:04 x86
Microsoft.analysisservices.applocal.core.dll 14.0.1.439 1381536 1 октября 2017 г. 22:06 x86
Microsoft.sqlserver.integrationservices.isserverdbupgrade.dll 14.0.3006.16 493728 19 октября 2017 г. 09:51 x86
Microsoft.sqlserver.integrationservices.isserverdbupgrade.dll 14.0.3006.16 493728 19 октября 2017 г. 11:08 x86
Microsoft.sqlserver.integrationservices.server.dll 14.0.3006.16 83616 19 октября 2017 г. 12:15 x86
Microsoft.sqlserver.integrationservices.server.dll 14.0.3006.16 83616 19 октября 2017 г. 12:20 x86
Microsoft.sqlserver.integrationservices.wizard.common.dll 14.0.3006.16 415392 19 октября 2017 г. 12:42 x86
Microsoft.sqlserver.integrationservices.wizard.common.dll 14.0.3006.16 415392 19 октября 2017 г. 12:59 x86
Msdtssrvr.exe 14.0.3006.16 219808 19 октября 2017 г. 12:21 x64
Sql_is_keyfile.dll 2017.140.3006.16 100512 19 октября 2017 г. 12:19 x64
Sqlceip.exe 14.0.3006.16 249504 19 октября 2017 г. 12:18 x86

SQL Server 2017 sql_polybase_core_inst

Имя файла Версия файла Размер файла Дата Время Платформа
Sqlevn70.rll 2017.140.3006.16 1494176 19 октября 2017 г. 11:05 x64
Sqlevn70.rll 2017.140.3006.16 3904160 19 октября 2017 г. 11:02 x64
Sqlevn70.rll 2017.140.3006.16 3205792 19 октября 2017 г. 11:01 x64
Sqlevn70.rll 2017.140.3006.16 3907232 19 октября 2017 г. 11:01 x64
Sqlevn70.rll 2017.140.3006.16 3810976 19 октября 2017 г. 11:06 x64
Sqlevn70.rll 2017.140.3006.16 2084512 19 октября 2017 г. 11:00 x64
Sqlevn70.rll 2017.140.3006.16 2031264 19 октября 2017 г. 11:02 x64
Sqlevn70.rll 2017.140.3006.16 3579032 19 октября 2017 г. 11:04 x64
Sqlevn70.rll 2017.140.3006.16 3587232 19 октября 2017 г. 11:00 x64
Sqlevn70.rll 2017.140.3006.16 1441440 19 октября 2017 г. 11:00 x64
Sqlevn70.rll 2017.140.3006.16 3775136 19 октября 2017 г. 11:07 x64

SQL Server 2017 sql_shared_mr

Имя файла Версия файла Размер файла Дата Время Платформа
Smrdll.dll 14.0.3006.16 23712 19 октября 2017 г. 11:08 x86
Sql_engine_core_shared_keyfile.dll 2017.140.3006.16 100512 19 октября 2017 г. 12:19 x64

SQL Server 2017 sql_tools_extensions

Имя файла Версия файла Размер файла Дата Время Платформа
Dts.dll 2017.140.3006.16 2548384 19 октября 2017 г. 11:01 x86
Dts.dll 2017.140.3006.16 2996896 19 октября 2017 г. 12:19 x64
Dtsconn.dll 2017.140.3006.16 397984 19 октября 2017 г. 11:01 x86
Dtsconn.dll 2017.140.3006.16 495264 19 октября 2017 г. 12:19 x64
Dtshost.exe 2017.140.3006.16 88224 19 октября 2017 г. 12:15 x86
Dtshost.exe 2017.140.3006.16 103072 19 октября 2017 г. 12:21 x64
Dtspipeline.dll 2017.140.3006.16 1057440 19 октября 2017 г. 12:10 x86
Dtspipeline.dll 2017.140.3006.16 1264288 19 октября 2017 г. 12:19 x64
Dtutil.exe 2017.140.3006.16 125088 19 октября 2017 г. 11:01 x86
Dtutil.exe 2017.140.3006.16 145568 19 октября 2017 г. 12:19 x64
Microsoft.sqlserver.astasksui.dll 14.0.3006.16 184480 19 октября 2017 г. 13:08 x86
Microsoft.sqlserver.chainer.infrastructure.dll 14.0.3006.16 406688 19 октября 2017 г. 11:01 x86
Microsoft.sqlserver.chainer.infrastructure.dll 14.0.3006.16 406688 19 октября 2017 г. 12:20 x86
Microsoft.sqlserver.configuration.sco.dll 14.0.3006.16 2093216 19 октября 2017 г. 12:15 x86
Microsoft.sqlserver.configuration.sco.dll 14.0.3006.16 2093216 19 октября 2017 г. 12:20 x86
Msmgdsrv.dll 2017.140.1.439 7310496 19 октября 2017 г. 12:15 x86
Sql_tools_extensions_keyfile.dll 2017.140.3006.16 100512 19 октября 2017 г. 12:19 x64
Sqlscm.dll 2017.140.3006.16 59544 19 октября 2017 г. 11:01 x86
Sqlscm.dll 2017.140.3006.16 69280 19 октября 2017 г. 11:08 x64
Sqlsvc.dll 2017.140.3006.16 133280 19 октября 2017 г. 11:01 x86
Sqlsvc.dll 2017.140.3006.16 160416 19 октября 2017 г. 12:21 x64

Заметки для этого обновления

Необходимые условия

Чтобы применить этот накопительный пакет обновления, необходимо использовать SQL Server 2017.

Сведения о перезапуске

После применения этого накопительного пакета обновления может потребоваться перезапуск компьютера.

Сведения реестра

Для использования одного из исправлений в этом пакете не требуется вносить изменения в реестр.

Важные уведомления

В этой статье также содержатся важные сведения о следующих ситуациях:

  • Кардиостимулятор: изменение поведения производится в дистрибутивах, использующих последнюю доступную версию кардиостимулятора. Предусмотрены методы смягчения последствий.

  • Хранилище запросов: Этот сценарий необходимо выполнить, если вы используете хранилище запросов и ранее установили Microsoft SQL Server 2017 с накопительным пакетом обновления 2 (CU2).

Версия сборки CU служб Analysis Services

Начиная с Microsoft SQL Server 2017 номера версий сборок служб Analysis Services и ядра СУБД SQL Server не совпадают. Дополнительные сведения см. в статье Проверка версии сборки накопительного пакета обновления Analysis Services.

Накопительные пакеты обновления (CU)

Накопительные пакеты обновления теперь доступны в Центре загрузки Майкрософт.

В Центре загрузки доступен только последний CU, выпущенный для SQL Server 2017.

Пакеты CU для Linux доступны по адресу https://packages.microsoft.com.

  • Каждый новый накопительный пакет обновления содержит все исправления, включенные в предыдущий накопительный пакет обновления для установленной версии SQL Server.
  • Накопительные пакеты обновления SQL Server сертифицированы на том же уровне, что и пакеты службы, поэтому их следует устанавливать с такой же степенью уверенности.
  • Рекомендуется выполнять постоянную упреждающую установку накопительных пакетов обновления по мере их доступности в соответствии со следующими рекомендациями:
    • Согласно историческим данным, значительное число обращений в службу поддержки связано с проблемами, которые уже были устранены в выпущенном накопительном пакете обновления.
    • Накопительные пакеты обновления могут содержать дополнительные улучшения помимо исправлений. К ним относятся обновления, повышающие удобство поддержки, управляемость и надежность.
  • Рекомендуется протестировать накопительные пакеты обновления SQL Server перед развертыванием в рабочих средах.
Уведомление кардиостимулятора

ВАЖНО

Во всех дистрибутивах (включая RHEL 7.3 и 7.4), использующих последний доступный пакет Pacemaker 1.1.18-11.el7 , вносится изменение поведения параметра кластера, start-failure-is-fatal если его значение равно false. Это изменение влияет на рабочий процесс отработки отказа. Если в первичной реплике происходит сбой, ожидается, что кластер выполнит отработку отказа на одну из доступных вторичных реплик. Вместо этого пользователи заметят, что кластер продолжает попытки запустить отказавшую основную реплику. Если эта первичная реплика никогда не подключается к сети (из-за постоянного сбоя), кластер никогда не переключается на другую доступную вторичную реплику.

Эта проблема затрагивает все версии SQL Server, независимо от того, какую версию накопительного обновления они используют.

Чтобы устранить проблему, используйте один из следующих методов.

Способ 1

Сделайте следующее:

  1. Удалите start-failure-is-fatal переопределение из существующего кластера.

    # RHEL, Ubuntu pcs property unset start-failure-is-fatal # or pcs property set start-failure-is-fatal=true # SLES crm configure property start-failure-is-fatal=true

  2. Уменьшите cluster-recheck-interval значение.

    # RHEL, Ubuntu pcs property set cluster-recheck-interval=<Xmin> # SLES crm configure property cluster-recheck-interval=<Xmin>

  3. failure-timeout Добавьте метасвойство к каждому ресурсу AG.

    # RHEL, обновление ресурсов компьютеров с Ubuntu ag1 meta failure-timeout=60s # SLES crm configure edit ag1 # В текстовом редакторе добавьте "meta failure-timeout=60s" после всех параметров и перед любыми операциями

    Примечание

    В этом коде подставьте значение для <Xmin> соответствующим образом. Если реплика выходит из строя, кластер пытается перезапустить реплику с интервалом, который ограничен failure-timeout значением и cluster-recheck-interval значением. Например, если failure-timeout задано значение 60 секунд и cluster-recheck-interval 120 секунд, перезапуск выполняется с интервалом, который больше 60 секунд, но меньше 120 секунд. Рекомендуется установить failure-timeout значение 60scluster-recheck-interval больше 60 секунд. Рекомендуется не устанавливать cluster-recheck-interval значение в маленький размер. Для получения дополнительных сведений обратитесь к документации по кардиостимулятору или к поставщику системы.

Способ 2

Вернитесь к Pacemaker версии 1.1.16.

Уведомление о хранилище запросов

ВАЖНО

Этот сценарий необходимо запустить, если вы используете хранилище запросов и выполняете обновление с накопительного пакета обновления 2 (CU2) SQL Server 2017 непосредственно до накопительного пакета обновления 3 (CU3) SQL Server 2017 или более позднего накопительного обновления. Этот сценарий не нужно запускать, если у вас уже установлен накопительный пакет обновления 3 (CU3) для SQL Server 2017 или более поздний накопительный пакет обновления SQL Server 2017.

SET NOCOUNT ON;
DROP TABLE IF EXISTS #tmpUserDBs;

SELECT [database_id], 0 AS [IsDone]
INTO #tmpUserDBs
FROM master.sys.databases
WHERE [database_id] > 4
 AND [state] = 0 -- must be ONLINE
 AND is_read_only = 0 -- cannot be READ_ONLY
 AND [database_id] NOT IN (SELECT dr.database_id FROM sys.dm_hadr_database_replica_states dr -- Except all local Always On secondary replicas
  INNER JOIN sys.dm_hadr_availability_replica_states rs ON dr.group_id = rs.group_id
  INNER JOIN sys.databases d ON dr.database_id = d.database_id
  WHERE rs.role = 2 -- Is Secondary
   AND dr.is_local = 1
   AND rs.is_local = 1)

DECLARE @userDB sysname;

WHILE (SELECT COUNT([database_id]) FROM #tmpUserDBs WHERE [IsDone] = 0) > 0
BEGIN
 SELECT TOP 1 @userDB = DB_NAME([database_id]) FROM #tmpUserDBs WHERE [IsDone] = 0

 -- PRINT 'Working on database ' + @userDB

 EXEC ('USE [' + @userDB + '];
DECLARE @clearPlan bigint, @clearQry bigint;
IF EXISTS (SELECT [actual_state] FROM sys.database_query_store_options WHERE [actual_state] IN (1,2))
BEGIN
 IF EXISTS (SELECT plan_id FROM sys.query_store_plan WHERE engine_version = ''14.0.3008.27'')
 BEGIN
  DROP TABLE IF EXISTS #tmpclearPlans;

  SELECT plan_id, query_id, 0 AS [IsDone]
  INTO #tmpclearPlans
  FROM sys.query_store_plan WHERE engine_version = ''14.0.3008.27''

  WHILE (SELECT COUNT(plan_id) FROM #tmpclearPlans WHERE [IsDone] = 0) > 0
  BEGIN
   SELECT TOP 1 @clearPlan = plan_id, @clearQry = query_id FROM #tmpclearPlans WHERE [IsDone] = 0
   EXECUTE sys.sp_query_store_unforce_plan @clearQry, @clearPlan;
   EXECUTE sys.sp_query_store_remove_plan @clearPlan;

   UPDATE #tmpclearPlans
   SET [IsDone] = 1
   WHERE plan_id = @clearPlan AND query_id = @clearQry
  END;

  PRINT ''- Cleared possibly affected plans in database [' + @userDB + ']''
 END
 ELSE
 BEGIN
  PRINT ''- No affected plans in database [' + @userDB + ']''
 END
END
ELSE
BEGIN
 PRINT ''- Query Store not enabled in database [' + @userDB + ']''
END')
  UPDATE #tmpUserDBs
  SET [IsDone] = 1
  WHERE [database_id] = DB_ID(@userDB)
END
Развертывание гибридной среды

При развертывании обновления в гибридной среде (например, при использовании Always On, репликации, кластеризации или зеркального отображения) перед установкой обновления рекомендуется ознакомиться со следующими статьями:

Языковая поддержка

В настоящее время накопительные пакеты обновления SQL Server поддерживают нескольких языков. Таким образом, этот накопительный пакет обновления не предназначен для какого-либо одного языка. Он применяется ко всем поддерживаемым языкам.

Обновленные компоненты (функции)

Один пакет CU включает все доступные обновления для всех компонентов (функций) SQL Server 2017. Однако накопительный пакет обновления обновляет только те компоненты, которые установлены на выбранном для обслуживания экземпляре SQL Server. Если после применения этого накопительного пакета обновления в экземпляр добавляется компонент SQL Server (например, службы Analysis Services), необходимо повторно применить накопительный пакет обновления, чтобы обновить новый компонент до его уровня.

Поддержка этого обновления

Если возникнут другие проблемы или понадобится устранение неполадок, может потребоваться создать запрос на обслуживание. За дополнительные вопросы о поддержке и проблемы, не соответствующие этому конкретному накопительному пакету обновления, взимается обычная плата за поддержку. Полный список телефонных номеров службы поддержки пользователей Майкрософт и возможность создать отдельный запрос на обслуживание доступны на веб-сайте службы поддержки Майкрософт.

Удаление этого обновления

Удаление этого обновления в Windows
  1. На панели управления откройте элемент Программы и компоненты, а затем выберите Просмотр установленных обновлений.
  2. Найдите запись, соответствующую этому накопительному пакету обновления, в разделе SQL Server 2017.
  3. Нажмите и удерживайте (или щелкните правой кнопкой мыши) запись, а затем выберите Удалить.
Удаление этого обновления в Linux

Чтобы удалить этот накопительный пакет обновления в Linux, необходимо выполнить откат пакета до предыдущей версии. Дополнительные сведения об откате установки см. в статье Откат SQL Server.

Заявление об отказе от ответственности за продукцию сторонних производителей

Продукты сторонних производителей, рассматриваемые в этой статье, изготовлены компаниями, которые не зависят от корпорации Майкрософт. Корпорация Майкрософт не дает никаких гарантий, в том числе подразумеваемых, относительно производительности и надежности этих продуктов.

Ссылки