Príznaky
Predpokladajme, že používate Microsoft BizTalk Server 2010 alebo 2013. Použijete vlastný kanál súčasť volanie služby Enterprise Service Bus (ESB) Transformácia transformácia správy ESB Toolkit 2.1 vlastnosť DocumentSpecName kontexte nesprávne nastaví výstupné správy a zobrazí nasledujúce chybové hlásenie:
Názov denníka: aplikácia
Zdroj: BizTalk Server
Identifikácia udalosti: 5720
Kategória úlohy: BizTalk Server
Úroveň: chyba
Popis: bola Odoslať kanál: "ESBTransform.SendPipeline1, ESBTransform, verzia = 1.0.0.0 Culture = neutral, PublicKeyToken = ca09cc62b15919a7" zdroj: "Plochý súboru assembleri" odosielajúci Port: "<SendPortName >" URI: "<SendPortURI>" dôvodu: typ dokladu "http://ESBTransform.FlatFileSchema1#TargetRoot" nezodpovedá na danej schémy.
Príčina
Tento problém sa vyskytuje, pretože ESB transformácia služby nenastaví vlastnosť DocumentSpecName kontexte výstup správu schémy typ cieľa po transformácie.
Riešenie
Informácie o rýchlej oprave
Od spoločnosti Microsoft je k dispozícii podporovaná rýchla oprava. Táto rýchla oprava je však určená iba opravu problému, ktorý je popísaný v tomto článku. Rýchlu opravu použite len v počítačoch s týmto konkrétnym problémom.
Ak je rýchla oprava k dispozícii na stiahnutie, na začiatku tohto článku databázy Knowledge Base sa nachádza časť „K díspozícii je rýchla oprava na stiahnutie“. Ak sa táto sekcia nezobrazuje, odošlite požiadavku na služby zákazníkom spoločnosti Microsoft a podporu získať rýchlu opravu.
Poznámka: Ak sa vyskytnú ďalšie problémy alebo ak je potrebné riešiť problémy, je možné, že budete musieť vytvoriť samostatnú servisnú požiadavku. Na ďalšie žiadosti o podporu a problémy, ktoré sa netýkajú tejto konkrétnej rýchlej opravy, sa vzťahujú zvyčajné poplatky za poskytnutie technickej podpory. Úplný zoznam telefónnych čísel služieb zákazníkom spoločnosti Microsoft a podpora alebo vytvoriť samostatnú servisnú požiadavku, nájdete na nasledujúcej webovej lokalite spoločnosti Microsoft:
http://support.microsoft.com/contactus/?ws=supportPoznámka: "Rýchla oprava k dispozícii na prevzatie" formulár sa zobrazujú jazyky, pre ktoré je rýchla oprava k dispozícii. Ak nemôžete nájsť požadovaný jazyk, znamená to, že rýchla oprava nie je pre tento jazyk k dispozícii.
Kumulatívna aktualizácia informácií
Tento problém bol najskôr odstránený v nasledujúcej kumulatívnej aktualizácie servera BizTalk Server 2013:
Požiadavky
Ak chcete použiť túto rýchlu opravu, musíte mať BizTalk ESB Toolkit 2.1 nainštalovaný.
Požiadavka na reštartovanie
Po použití tejto rýchlej opravy nie je potrebné reštartovať počítač.
Informácie o nahradení rýchlej opravy
Táto rýchla oprava nenahrádza žiadne iné rýchle opravy.
Informácie o súboroch
Anglická verzia tejto rýchlej opravy má atribúty súborov (alebo novšie atribúty) uvedené v nasledujúcej tabuľke. Dátumy a čas jednotlivých súborov sú uvedené vo formáte koordinovaného svetového času (UTC). Pri zobrazení informácií o súbore sa dátumy a čas prevedú na miestny čas. Ak chcete vyhľadať rozdiely medzi časom UTC a miestnym časom, použite kartu Časové pásmo v položke Dátum a čas v ovládacom paneli.
Názov súboru |
Verzia súboru |
Veľkosť súboru |
Dátum |
Čas |
Platforma |
---|---|---|---|---|---|
Microsoft.Practices.ESB.Itinerary.Services.dll |
2.1.1.0 |
24576 |
13-Oct-2014 |
13:11 |
x86 |
Ďalšie informácie
Ďalšie informácie o terminológii z oblasti aktualizácii softvéru získate v téme Popis štandardnej terminológie použitej na popis aktualizácií softvéru od spoločnosti Microsoft.
Stav
Spoločnosť Microsoft potvrdila, že ide o problém v produktoch spoločnosti Microsoft, ktoré sú uvedené v časti Vzťahuje sa na.