Prihláste sa s kontom Microsoft
Prihláste sa alebo si vytvorte konto.
Dobrý deň,
Vyberte iné konto.
Máte viacero kont
Vyberte konto, s ktorým sa chcete prihlásiť.

Príznaky

Na portáli Business Portal pre Microsoft Dynamics GP alebo Microsoft Dynamics SL sa pri kliknutí na položku Lokalita Nastavenia a potom na položku Spravovať používateľov môže zobraziť nasledujúce chybové hlásenie:

Chyba servera v aplikácii /.
--------------------------------------------------------------------------------


používateľa.


Popis: Počas vykonávania aktuálnej webovej žiadosti sa vyskytla nespracovaná výnimka. Ďalšie informácie o chybe a pôvode v kóde nájdete v stope zásobníka.



Podrobnosti o výnimke: Microsoft.BusinessFramework.Security.AuthenticationException: Neplatný používateľ.



Chyba zdroja: Počas vykonávania aktuálnej webovej požiadavky sa vygenerovala nespracovaná výnimka. Informácie týkajúce sa pôvodu a umiestnenia výnimky možno identifikovať pomocou sledovania zásobníka výnimiek nižšie.



Sledovanie zásobníka:


[AuthenticationException: Neplatný používateľ.] Microsoft.BusinessFramework.UserManager.VerifyUser() +695 Microsoft.BusinessFramework.EnterpriseSession.Initialize(String enterpriseUrl) +1061 Microsoft.BusinessFramework.Security.EnterpriseInitializationModule.OnAcquireRequestState(Object sender, EventArgs e) +150 System.Web.SyncEventExecutionStep.System. Web.HttpApplication+IExecutionStep.Execute() +60 System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +87


--------------------------------------------------------------------------------

Version Information:
Microsoft .NET Framework Version:1.1.4322.2032;
ASP.NET Verzia:1.1.4322.2032

Príčina

Tento problém sa vyskytuje, keď platí jedna alebo viacero z nasledujúcich podmienok:

  • Používateľské konto, ktoré sa použilo na inštaláciu portálu Business Portal, nemá správne povolenia na serveri so systémom Microsoft Internetové informačné služby (IIS). Používateľské konto nie je členom správnych rolí v počítači so systémom Microsoft SQL Server.

  • Používateľské konto je členom domény, ktorá sa líši od domény, v ktorej bol nainštalovaný Business Portal.

  • Používateľské konto neexistuje v tabuľkách portálu Business Portal v databáze Služby Dynamics ani v systémovej databáze.

  • Používateľské konto sa poškodí na portáli Business Portal.

  • Možnosť Rozšírené zabezpečenie internetu je povolená.

Riešenie

Ak chcete tento problém vyriešiť, postupujte podľa týchto krokov. Po dokončení každého kroku kliknite na položku Lokalita Nastaveniaa potom kliknite na položku Spravovať používateľov na podnikovom portáli. Keď sa vám nebude zobraziť chybové hlásenie, ktoré je uvedené v časti Príznaky, problém sa vyrieši. Ak je to tak, ostatné kroky v tejto časti nie je potrebné dokončiť. Vždy, keď sa zobrazí chybové hlásenie, prejdite na ďalší krok.

  1. Overte, či má používateľské konto, ktoré sa použilo na inštaláciu portálu Business Portal, aspoň povolenia lokálneho správcu na serveri so službou IIS. Skontrolujte tiež, či je k dispozícii používateľské Microsoft SQL Server prihlásenie. Skontrolujte, či prihlásenie je členom týchto rolí servera v SQL Server:

    • Správcovia zabezpečenia

    • Autori databáz

  2. Skontrolujte, či je používateľské konto členom domény a siete, v ktorej je nainštalovaný Business Portal. Overte tiež, či má doména nastavené dôveryhodné prostredie v sieti.

  3. Skontrolujte, či používateľské konto, pre ktoré sa zobrazuje chybové hlásenie, existuje v nasledujúcich tabuľkách:

    • MbfUserWindowsIdentity (MbfUserWindowsIdentity)

    • MbfUser


    Ak chcete overiť, či používateľské konto existuje, v analyzátore SQL alebo v programe SQL Server Management Studio. V prípade systému Microsoft Dynamics GP spustite príkaz v databáze Dynamics. V prípade služby Microsoft Dynamics SL spustite príkaz v systémovej databáze.

    SELECT WINDOWSCREDENTIALS FROM MbfUserWindowsIdentity
    SELECT ALIAS FROM MbfUser

    Ak v týchto tabuľkách neexistuje používateľské konto, používateľ, ktorý nainštaloval podnikový portál, musí odstrániť a potom pridať používateľské konto pomocou portálu Business Portal. Ďalšie informácie o odstránení alebo pridaní používateľského konta nájdete v časti Ďalšie informácie.

  4. Ak problém pretrváva, uistte sa, že používateľ, ktorý nainštaloval Business Portal, sa pokúsi vykonať úlohu. Ak sa používateľovi, ktorý nainštaloval Business Portal, chybové hlásenie neuchová, môže sa poškodiť používateľské konto používateľa, ktorý dostal chybové hlásenie. Používateľ, ktorý nainštaloval Business Portal, musí odstrániť a potom pridať používateľské konto pomocou portálu Business Portal. Ďalšie informácie o odstránení alebo pridaní používateľského konta nájdete v časti Ďalšie informácie.

  5. Na serveri IIS kliknite na tlačidlo Štart, kliknite na položku Ovládací panel, kliknite na položku Pridať alebo odstrániť programy a potom kliknite na položku Pridať alebo Windows súčasti. Zrušte začiarknutie políčka Rozšírené zabezpečenie na internete a potom pokračujte v sprievodcovi a program odstráňte.




    Poznámky

    • Ak chcete používať rozšírené zabezpečenie internetu, prihláste sa spolu so vhodným heslom pomocou mena používateľa domain\userID.

    • Kontrola internetového rozšíreného zabezpečenia nie je potrebná, pretože Portál Business Portal sa overuje voči doméne každého používateľa, ktorý sa pokúsi prihlásiť do programu.

Ďalšie informácie

Ak chcete odstrániť a potom pridať používateľské konto na portáli Business Portal, postupujte podľa týchto krokov.

Odstránenie používateľa

  1. Start Business Portal. Použite používateľské konto, ktoré sa použilo na inštaláciu portálu Business Portal.

  2. V Business Portal 3.0 kliknite na položku Lokalita Nastaveniaa potom kliknite na položku Spravovať používateľov podnikových portálov.

    V podnikovom portáli pre Dynamics GP 10 (a novšie verzie) kliknite na položku Akcie lokality ,kliknite na položku Nastaveniaa potom kliknite na položku Používatelia v časti Správa podnikových portálov.

  3. V zozname Zoznam používateľov vyberte používateľské konto.

  4. V oblasti Vybrať úlohu kliknite na položku Odstrániť používateľov.

  5. V okne Odstránenie používateľov portálu business portal kliknutím vyberte používateľské konto, ktoré chcete odstrániť.

  6. Kliknite na položku Odstrániť.

Pridanie používateľa

  1. Start Business Portal. Použite používateľské konto, ktoré sa použilo na inštaláciu portálu Business Portal.

  2. V Business Portal 3.0 kliknite na položku Lokalita Nastaveniaa potom kliknite na položku Spravovať používateľov podnikových portálov.

    V podnikovom portáli pre Dynamics GP 10 (a novšie verzie) kliknite na položku Akcie lokality ,kliknite na položku Nastaveniaa potom kliknite na položku Používatelia v časti Správa podnikových portálov.

  3. V oblasti Vybrať úlohu kliknite na položku Pridať nových používateľov. Ak chcete pridať používateľské konto na podnikový portál, postupujte podľa krokov v Sprievodcovi pridaním používateľov.

Potrebujete ďalšiu pomoc?

Chcete ďalšie možnosti?

Môžete preskúmať výhody predplatného, prehľadávať školiace kurzy, naučiť sa zabezpečiť svoje zariadenie a ešte oveľa viac.

Komunity pomôžu s kladením otázok a odpovedaním na ne, s poskytovaním pripomienok a so získavaním informácií od odborníkov s bohatými znalosťami.

Boli tieto informácie užitočné?

Aká je podľa vás jazyková kvalita textu?
Čo sa vám páčilo, prípadne čo nie?
Stlačením tlačidla Odoslať sa vaše pripomienky použijú na zlepšenie produktov a služieb spoločnosti Microsoft. Váš správca IT bude môcť tieto údaje zhromažďovať. Vyhlásenie o ochrane osobných údajov.

Ďakujeme za vaše pripomienky!

×