Prihláste sa s kontom Microsoft
Prihláste sa alebo si vytvorte konto.
Dobrý deň,
Vyberte iné konto.
Máte viacero kont
Vyberte konto, s ktorým sa chcete prihlásiť.

Príznaky

V špecializovanej alebo medzinárodnej dopravy v Arms nariadenia (ITAR) Microsoft Office 365 prostredie, používateľ sa zobrazí Upozornenie zabezpečenia dialógové okno, ktoré obsahuje nasledujúce chybové hlásenie:

Názov certifikátu zabezpečenia je neplatný alebo nezodpovedá názvu lokality.

Napríklad Upozornenie zabezpečenia dialógové okno podobné nasledujúcemu: Upozornenie zabezpečenia Tento problém sa môže vyskytnúť za nasledujúcich okolností:

  • Používateľ sa pokúsi vytvoriť nový profil v programe Microsoft Office Outlook.

  • Používateľ pokúsi spustiť klienta programu Outlook.

  • Problém sa vyskytuje prerušovane, keď je spustený klient programu Outlook.

Ak používateľ klikne na Áno, používateľ môže pokračovať v operácii. Avšak, ak používateľ klikne nie, Autodiscover vyhľadávania zlyhá. Zlyhanie vyhľadávania Autodiscover zabraňuje nasledujúce funkcie pracovať podľa očakávania:

  • Automatické vytvorenie profilu programu Outlook pomocou služby Autodiscover

  • Asistent mimo pracoviska (OOF)

  • Informácie o voľnom čase

Príčina

Všeobecne platí, že tento problém sa vyskytuje, keď URL, ktoré sa pokúšate získať prístup nie je uvedený v predmete alebo predmet Alternatívny názov (SAN) certifikátu Secure Sockets Layer (SSL) pre webovú lokalitu. Hoci rôzne organizácie konfigurácie sa môžu mierne líšiť, tento problém sa zvyčajne vyskytuje, pretože organizácie Autodiscover systému DNS (Domain Name) záznamy sú nesprávne nakonfigurované.

Riešenie

Ak chcete vyriešiť tento problém, budete musieť zmeniť Autodiscover DNS záznamy (interné, externé alebo oboje). Však tieto zmeny by sa nemali brať na ľahkú váhu, pretože funkcia Autodiscover nemusí fungovať, ak DNS záznamy sú nesprávne nakonfigurované. Pred zmenou záznamov služby Autodiscover DNS, mali by ste pochopiť, ako sa klient programu Outlook pokúsi vyhľadať službu Autodiscover. Klient Outlook sa pokúsi vyhľadať službu Autodiscover pomocou nasledujúceho základného poradia operácií. Však krok, v ktorom sa nachádza služba Autodiscover sa líši od nasadenia nasadenia. Toto umiestnenie závisí od toho, či existuje lokálne riešenie v koexistencii a aké konkrétne lokálne e-mailové prostredie je (napríklad lokálny server Microsoft Exchange, lokálne Lotus Notes alebo iné prostredie). Nasledujúca tabuľka zobrazuje základné poradie operácií, ako klient Outlook vyhľadá službu Autodiscover:

1

  1. Objekt pripojenia služby bod (SCP)-interné pripojenia.

  2. Klient programu Outlook sa pokúsi nájsť záznam pre adresu URL, ktorá vráti objekt SCP.

2

  1. Domény používateľa SMTP. (Napríklad https://proseware.com)

  2. Klient programu Outlook sa pokúsi nájsť záznam pre doménu SMTP používateľa.

3

  1. Doména SMTP používateľa je predponou s Autodiscover. (Napríklad https://autodiscover.proseware.com)

  2. Klient programu Outlook sa pokúsi nájsť záznam pre adresu URL, ktorá je pripojená pomocou služby Autodiscover.

4

  1. Klient programu Outlook sa pokúsi nájsť záznam DNS služby (SRV) pre službu Autodiscover v zóne DNS, ktorá zodpovedá používateľa domény SMTP. (Napríklad _autodiscover. _tcp. proseware. com)

  2. Záznam SRV vráti ďalšiu adresu URL, pre ktorú musí existovať nejaký riešiteľný záznam, napríklad záznam alebo záznam CNAME.

5

Výsledok Ak služba Autodiscover nie je nájdený niektorú z týchto metód, Autodiscover zlyhá.

Stručne povedané, Služba Autodiscover môže vyriešiť pomocou záznam, záznam CNAME alebo záznam SRV. Ak chcete určiť, ktoré záznamy sa používajú v súčasnosti, spustite nasledujúce príkazy v príkazovom riadku alebo v prostredí Windows PowerShell:

  1. Ak chcete vyhľadať záznam, spustite nasledujúce príkazy. Uistite sa, že ste nahradiť SMTPDomain.com nižšie s doménou s hodnotou v hornej časti vašej chyby certifikátu.

nslookup 
set type=A 
Autodiscover.SMTPDomain.com 
  1. Ak chcete vyhľadať záznam SRV, spustite nasledujúce príkazy:

nslookup 
set type=SRV 
_autodiscover._tcp.SMTPDomain.com 

V nasledujúcom príklade môže klient programu Outlook vyhľadať službu Autodiscover pomocou záznamu pre adresu URL služby Autodiscover, ako je popísané v kroku 3 v predchádzajúcej tabuľke:

autodiscover.proseware.comAvšak, ako sme sa zmienili v časti "príčina", táto adresa URL nie je uvedený v SAN SSL certifikátu, ktorý používa služba Autodiscover. Napríklad, nájdete na nasledujúcej snímke obrazovky: Služba Autodiscover Ak chcete vyriešiť tento problém, použite nasledujúcu metódu.

Nahradiť existujúci záznam pomocou záznamu SRV, ktorý odkazuje na priestor názvov, ktorý je už v SAN certifikátu SSL

Toto je preferovaný spôsob riešenia v aktuálnom dizajne služby, pretože existujúci certifikát SSL nemusí byť aktualizovaný a nasadený. Podľa základného poradia operácií, ktoré sú uvedené vyššie v tejto časti, organizácia môže implementovať nový záznam pomocou kontrolované a testované spôsob, ako zabrániť výpadky služby Autodiscover. Ak chcete vyriešiť tento problém, postupujte nasledovne:

  1. Vytvoriť nový záznam SRV. Záznam SRV by mali byť vytvorené v zóne DNS, ktorá zodpovedá používateľa domény SMTP. Záznam SRV by mali mať nasledujúce vlastnosti:

    • Služba: _autodiscover

    • Protokol: _tcp

    • Port: 443

    • Hostiteľ: adresa URL pre presmerovanie. Táto adresa URL môže byť adresa URL služby Outlook Web Access (OWA), pretože vyriešená IP by mala byť rovnaká ako služba Autodiscover. Okrem toho sa môže líšiť od nasadenia nasadenia.

  2. Skôr než odstránite existujúci záznam, nový záznam SRV by sa mali testovať zmenou hostiteľského súboru používateľa na presmerovanie aktuálneho záznamu na neplatnú adresu IP. Tento test môžete overiť, že nový záznam SRV pracuje podľa očakávania pred nasadením nové záznamy DNS do celej organizácie. Poznámka: Keď záznam SRV používa klient programu Outlook, používateľ môže zobraziť nasledujúce hlásenie, ktoré radí používateľovi presmerovanie, ktoré sa vyskytuje. Odporúčame, aby používateľ začiarknite políčko nepýtajte sa ma na túto stránku znova , aby sa správa nezobrazí znova. Otázku o tejto webovej stránke nezobrazovať

  3. Keď záznam SRV funguje podľa očakávania, môžete odstrániť existujúci záznam zo servera DNS.

Ďalšie informácie

Ďalšie informácie o službe Autodiscover, nájdete na nasledujúcej webovej lokalite Microsoft TechNet:

Informácie o službe Autodiscover

Potrebujete ďalšiu pomoc?

Chcete ďalšie možnosti?

Môžete preskúmať výhody predplatného, prehľadávať školiace kurzy, naučiť sa zabezpečiť svoje zariadenie a ešte oveľa viac.

Komunity pomôžu s kladením otázok a odpovedaním na ne, s poskytovaním pripomienok a so získavaním informácií od odborníkov s bohatými znalosťami.

Boli tieto informácie užitočné?

Aká je podľa vás jazyková kvalita textu?
Čo sa vám páčilo, prípadne čo nie?
Stlačením tlačidla Odoslať sa vaše pripomienky použijú na zlepšenie produktov a služieb spoločnosti Microsoft. Váš správca IT bude môcť tieto údaje zhromažďovať. Vyhlásenie o ochrane osobných údajov.

Ďakujeme za vaše pripomienky!

×