Príznaky
Pri nastavení možností žiadosti o dovolenku v programe Outlook 2003 alebo Outlook 2007 vo všetkých pracovných stanicech vrátane servera sa zobrazí toto chybové hlásenie:
Nepodarilo sa pripojiť k podnikovému portálu. Nemáte oprávnenie na pripojenie z dôvodu chyby protokolu, ktorá môže súvisieť s nastaveniami zabezpečenia adresára virtuálneho adresára portálu Business Portal. Tieto nastavenia by mali povoliť a Windows overenia. Obráťte sa na správcu portálu Business Portal.
Táto chyba sa zobrazí, keď sa pokúsite pripojiť nástroj Outlook o dovolenku Add-In v balíku Outlook HRM Self Service Suite pomocou portálu Business Portal s procesorom Microsoft Dynamics GP.
Príčina
Skontrolujte nastavenia prístupu na overenie. Bežne základné overovanie v Správcovi služieb Internetové informačné služby (IIS) je povolené a malo by byť vypnuté.
Riešenie
Metóda 1: Nastavenia v správcovi IIS 1. Udeľte povolenia skupine Používatelia domény pre vašu webovú lokalitu BP prostredníctvom služieb Microsoft Internetové informačné služby (IIS) týmito krokmi:
a. Prihláste sa na webový server Business Portal (BP) so serverom IIS. b. V ovládacom paneli otvortenástroje na správu apotom kliknite na položku Správca služieb IIS.
c. V okne správcu služieb IIS rozbaľte položku Webové lokality.
d. Kliknite pravým tlačidlom myši na webovú lokalitu BP a potom kliknite na položku Povolenia.
e. V okne zabezpečenia by ste mali mať skupinu Používatelia podobnú skupine (XXXXX\Používatelia)Poznámka XXXXX je zástupným objektom pre názov domény.Ak táto skupina neexistuje, pridajte skupinu domén. 2. Po udelení Windows integrované overovanie pre vašu webovú lokalitu BP prostredníctvom služieb IIS postupujte takto:
a. Prihláste sa na webový server BP so spustenými IIS. b. V ovládacom paneli otvortenástroje na správu apotom kliknite na položku Správca služieb IIS.
c. V okne správcu služieb IIS rozbaľte položku Webové lokality.
d. Kliknite pravým tlačidlom myši na webovú lokalitu BP a potom kliknite na položku Vlastnosti.
e. Kliknite na kartu Zabezpečenie adresára.
f. V oblasti Authentication and access control (Overovanie a riadenie prístupu) kliknite na položku Edit (Upraviť).
g. V oblasti Overený prístup kliknutím označte začiarkavacie políčko Windows overenie.
h. V oblasti Overený prístup sa uistite, že políčko Základné overenie nie je neoznačené. ---- chcete skontrolovať základné overovanie pre služby IIS 7.0, postupujte takto: a. V pracovnej stanice, v ktorej je nainštalovaný Business Portal (BP), prejdite na položku IIS Manager. Ak to chcete urobiť, kliknite na položky Štart, Ovládací panel, Nástroje na správu a potom dvakrát kliknite na Internetové informačné služby správcu (IIS). b. V časti Pripojenia na ľavom okraji kliknutím rozbaľte príslušnú lokalitu pripojenia.c. Kliknutím rozbaľte položku Lokality.d. Kliknite pravým tlačidlom myši na položku Podnikový portál (ktorý sa môže nachádzať pod sharepointou) a potom kliknite na položku Prepnúť na zobrazenie funkcií.e. V zobrazení Funkcie sa zobrazia časti označené ako ASP.NET a IIS. V časti IIS dvakrát kliknite na položku Overovanie. f. Kliknutím vyberte položku Základné overovanie.g. Na pravom okraji v časti Akcie kliknite na položku Vypnúť. (Poznámka: Ak je v zozname uvedené iba možnosť Povoliť, už je vypnutá.) h. Zavrite okná. ----- 3. Resetovanie služieb IIS. Ak to chcete urobiť, kliknite na položky Štart a Spustiť, do poľa Otvoriť zadajte IISRESET a potom proces vykonajte kliknutím na tlačidlo OK. 4. Vyskúšajte to znova. Ak stále máte rovnaký problém, požiadajte iného používateľa, aby sa pokúsil získať prístup do okna s možnosťami žiadosti o dovolenku zo svojho Outlook profilu a zistiť, či má prístup.POZNÁMKA: Skontrolujte, či je microsoft Outlook nainštalovaný ako e-mailový systém kompatibilný s rozhraniom MAPI. Ak táto metóda nefunguje, prejdite na metódu 2.Metóda 2: Nastavenia v Internet Exploreri 1. V Internet Exploreri kliknite na položku Nástroje, potom na položku Možnosti siete internet a kliknutím vyberte kartu Rozšírené. V časti Zabezpečenie skontrolujte, či je označená možnosť Windows integrované overovanie. 2. Pridajte URL adresu BP do dôveryhodných lokalít.Metóda 3: Overenie/testovanie, ktoré môžete vyhľadať na URL adresu zobrazenú v možnostiach žiadosti o dovolenku v Outlook 1. Po Add-In otvorte okno Outlook. Kliknite na položky Nástroje, Možnosti žiadosti o dovolenku a potom kliknite na kartu Pripojenie. Všimnite si URL adresu uvedenú v dolnej časti okna. Toto je cesta, ktorú budete musieť vyhľadať pomocou týchto krokov. Príklad URL adresy: Adresa http://localhost/BusinessPortal/Applications/HRM/VacationRequestWebService.asmx (Poznámka Ak ste zadali názov hostiteľa, potom nahradí názov localhost v tejto URL adrese.) 2. Prejdite na server, na ktorom je nainštalovaný BP. Kliknite na tlačidlo Štart, potom na položku Nástroje na správu Internetové informačné služby správcu SLUŽIEB (IIS).3. Kliknutím rozbaľte pripojenie databázy na ľavom okraji.4. Kliknutím rozbaľte položku Lokality, kliknutím rozbaľte podnikový portál, kliknutím znova rozbaľte podnikový portál, kliknite na položku Aplikácie a potom kliknite na priečinok ĽUDSKÉ ZDROJE. (V podstate prejdite na tú istú URL adresu, ktorá sa zobrazí v okne Možnosti žiadosti o dovolenku. Vaše kroky a umiestnenie na prehľadávanie sa môžu líšiť od toho, čo je uvedené v tomto príklade.) 5. Kliknutím na položku Zobrazenie obsahu v dolnej časti okna zobrazíte súbory v priečinku HRM.6. Posuňte sa nadol a vyhľadajte VacationRequestWebService.asmx. Kliknite naň pravým tlačidlom myši a potom kliknite na položku Prehľadávať. Malo by sa otvoriť okno VacationRequestWebService. Je dôležité, aby sa tu otvorilo okno webovej služby. 7. Ak sa otvorí okno webovej služby, všimnite si URL adresu v hornej časti stránky. URL adresa uvedená v okne Možnosti žiadosti o dovolenku by sa mala presne zhodovať s touto URL adresou.