Príznaky
Keď sa prihlásite do služby Microsoft Dynamics NAV, zobrazí sa nasledujúca chyba: Vaša programová licencia
nepovoľuje väčším používateľom pracovať súčasne. Počkajte, kým iný používateľ program nezastaví používať. Ak chcete povoliť väčší počet súčasne používateľov vo svojom systéme, obráťte sa na správcu systému.
Príčina
Táto chyba sa zobrazí, keď celkový počet používateľov, ktorí pristupujú k databáze Microsoft Dynamics NAV v rovnakom čase, prekročil celkový počet relácií používateľov, ku ktorému licencia poskytuje prístup. Ak máte licenciu pre 5 používateľov a ste 6. používateľom, ktorý sa pokúšate prihlásiť do databázy služby Microsoft Dynamics NAV, zobrazí sa táto chyba.
Táto chyba sa môže vyskytnúť aj v prípade, že skutočný počet aktívnych používateľov prihlásených do databázy služby Microsoft Dynamics NAV je menší ako počet relácií používateľov, ku ktorých licencia poskytuje prístup. Tu sú uvedené situácie, v ktorých sa môže vyskytnúť:
-
Ak používate N/ODBC alebo C/Front, každá inštancia spustených programov použije reláciu používateľa.
-
K databáze služby Microsoft Dynamics NAV môžu byť stále pripojené nečinné relácie. Môže sa to stať, ak používateľ nezatvoriť službu Microsoft Dynamics NAV správne pri ukončení alebo po výpadku napájania.
-
Pri spustení databázovej služby Microsoft Dynamics NAV je možné špecifikovať len maximálny počet relácií, ktoré môžu byť súčasne prihlásení na
databázový server služby Microsoft Dynamics NAV. Ak bol nastavený maximálny počet relácií pri spustení databázovej služby Microsoft Dynamics NAV, do servera databázy navigácie v rovnakom čase sa môže prihlásiť viac používateľov bez ohľadu na počet relácií v licencii.
Riešenie
1. Ako zistiť, ako môžu používatelia byť prihlásení do databázy služby Microsoft Dynamics NAV: V okne Relácie databázy môžete v ľubovoľnom čase zistiť počet používateľov prihlásených do databázy
služby Microsoft Dynamics NAV. Ak chcete získať prístup do okna Relácie databázy v službe Microsoft Dynamics NAV, postupujte takto:
-
Prechod na kartu Súbor, Databáza, Informácie, Relácie
-
Prechod na detaily poľa Aktuálne relácie
V okne Relácie databázy sa zobrazí zoznam všetkých relácií pripojených k databáze Microsoft Dynamics NAV vrátane používateľov, relácií N/ODBC atď.
Filtrovaním podľa databázy služby Microsoft Dynamics NAV v poli Názov databázy môžete obmedziť záznamy tak, aby sa v nich mohli zobrazovať iba relácie pripojené k tejto databáze.
2. Relácie neaktívnych alebo nečinných Používateľov Môžete odstrániť nečinné relácie používateľov z okna Relácie databázy výberom záznamu pre reláciu, ktorú chcete odstrániť, kliknutím pravým tlačidlom myši a výberom položky Odstrániť alebo stlačením klávesu
Delete.
Poznámka: Platnosť relácie neaktívnych alebo nečinných osôb automaticky uplynie po určitom čase, zvyčajne po 2 hodinách.
3. Databázový server Microsoft Dynamics NAV len vtedy, keď je nainštalovaný databázový server Microsoft Dynamics NAV, parameter Relácie sa automaticky nastaví tak, aby sa rovná počtu relácií používateľov v licencii nainštalovanej
na serveri. Toto nastavenie však možno zmeniť manuálne, aby maximálny počet relácií bol nastavený na menej ako počet relácií používateľov na licencii nainštalovanej na serveri Maximálny počet relácií môžete skontrolovať tak, že prejdete do príkazového riadka, prejdete do adresára, v ktorom je nainštalovaný server databázy Microsoft Dynamics NAV, a napíšete názov SERVER, alebo prejdite z Prieskumníka do adresára, v ktorom je nainštalovaný databázový server, Windows a dvakrát kliknite na súbor
Server.exe.
Ak je hodnota maximálnych relácií nastavená na hodnotu menšiu ako počet relácií používateľov vo vašej licencii, parameter Maximálny počet relácií je možné zmeniť v doplnku Microsoft Database Server Manager Prichytenie-in pre konzolu Microsoft Management Console alebo môžete zmeniť parameter maximálnych relácií z príkazového riadka pri spustení servera zadaním relácie = XX, kde XX je počet relácií.
Ďalšie informácie
Ďalšie informácie nájdete v článkoch Ako zistiť počet relácií s licenciami v
službe Microsoft Dynamics NAV.
Postup: Aktivácia súboru licencie– pri zakúpení ďalších relácií používateľov skontrolujte, či je nový súbor s licenciou správne nainštalovaný. V opačnom prípade nebudete môcť používať ďalšie zakúpené relácie používateľov.