Príznaky
Pri pokuse o tlač zostavy v systéme Microsoft Dynamics CRM 4,0 sa zobrazí nasledujúce chybové hlásenie:
Nie je možné načítať ovládací prvok na tlač klienta.
Tento problém sa vyskytuje, ak nainštalujete aktualizáciu pre SQL Server 2005 Service Pack 2 General Distribution Release (NDR). Ďalšie informácie o aktualizácii pre SQL Server 2005 Service Pack 2 NDR nájdete v článku databázy Microsoft Knowledge Base, ktorý sa zobrazí po kliknutí na nasledovné číslo článku:
954606 MS08-052: Popis aktualizácie zabezpečenia pre GDI + pre SQL Server 2005 Service Pack 2 NDR: 9. septembra 2008
Príčina
Tento problém sa vyskytuje, pretože aktualizácia pre SQL Server 2005 Service Pack 2 NDR aktualizuje číslo verzie RSClientPrint triedy. Preto sa musí aktualizovať aj ovládací prvok ReportViewer.
Riešenie
Ak chcete tento problém vyriešiť, použite jeden z nasledujúcich postupov:
- 
              Inštalácia zobrazovača zostáv s redistribuovateľnými balíkmi 2005 Service Pack 1. Ak chcete získať Zobrazovač zostáv s redistribuovateľnými 2005 Service Pack 1, navštívte nasledujúcu webovú lokalitu spoločnosti Microsoft: 
- 
              Nainštalujte balík kumulatívnej aktualizácie 9 pre SQL Server 2005 Service Pack 2. Ďalšie informácie o kumulatívnej aktualizácii balíka 9 pre SQL Server 2005 Service Pack 2 nájdete v článku databázy Microsoft Knowledge Base, ktorý sa zobrazí po kliknutí na nasledovné číslo článku: 953752 Kumulatívna aktualizácia balíka 9 pre SQL Server 2005 Service Pack 2 Ak sa chybové hlásenie, ktoré je spomenuté v časti príznaky, zobrazuje aj po inštalácii kumulatívnej aktualizácie balíka 9, odstráňte triedu RSClientPrint . Postupujte podľa nasledujúcich krokov: - 
                  Spustite program Windows Internet Explorer. 
- 
                  V ponuke Nástroje kliknite na položku Možnosti siete Internet. 
- 
                  Postupujte podľa príslušných krokov: - 
                      V programe Windows Internet Explorer 7 kliknite na položku Nastavenie v oblasti histórie prehľadávania a potom kliknite na položku Zobraziť objekty. 
- 
                      V programe Microsoft Internet Explorer 6 kliknite na položku nastavenia v oblasti Temporary Internet Files (dočasné internetové súbory ) a potom kliknite na položku Zobraziť objekty. 
 
- 
                      
- 
                  Kliknite pravým tlačidlom myši na RSClientPrint triedaa potom kliknite na položku odstrániť. 
 
- 
                  
Odkazy
Ďalšie informácie sú k dispozícii na nasledujúcej webovej lokalite spoločnosti Microsoft:
 
                         
				 
				