Príznaky
Predstavte si nasledujúcu situáciu:
-
Nasledujúci softvér nainštalujete na počítač:
-
Eclipse 3.5, 3.6 mesiaca alebo produkt, ktorý je založený na jednej z týchto verzií.
-
Microsoft Visual Studio Team Explorer všade 2010 Service Pack 1 (SP1) pre mesiaca
-
Windows Internet Explorer 9
-
-
Team Explorer všade 2010 používa na pripojenie k serveru Microsoft Team Foundation Server (TFS).
-
Pokúšate sa uložiť alebo Zobraziť pracovnú položku, ktorá obsahuje niektoré ovládacie prvky HTML.
V takomto prípade uložiť alebo operácia zlyhá. Zobrazí sa tiež nasledujúce chybové hlásenie:
Uloženie FailedJava.lang.reflect.InvocationTargetException
Príčina
Tento problém sa vyskytuje z dôvodu zmeny JavaScript nástroj, ktorý je predstavený v programe Internet Explorer 9. Zmena konflikty, ktorí použijú kód príslušného mesiaca verzie. Tento konflikt spôsobuje failaure funkcia pre pracovnú položku, ktorá obsahuje RTF súbor kontroly Team Explorer všade 2010 SP1. Zobrazí sa chybové hlásenie.
Riešenie
Informácie o rýchlej oprave
Rýchla oprava je k dispozícii na nasledujúcej webovej lokalite Microsoft Download Center: prevziať balík rýchlej opravy. Ďalšie informácie o preberaní súborov technickej podpory spoločnosti Microsoft, kliknite na nasledovné číslo článku publikovaného v databáze Microsoft Knowledge Base:
119591 Získanie podporných súborov spoločnosti Microsoft zo služieb online Spoločnosť Microsoft preverila, či tento súbor neobsahuje vírusy. Spoločnosť Microsoft použila aktuálny antivírusový softvér, dostupný v deň zverejnenia tohto súboru. Súbor je uložený na zabezpečených serveroch, ktoré neumožňujú neoprávnené zmeny súborov. Poznámka: Ak chcete nainštalovať túto rýchlu opravu, postupujte nasledovne:
-
Uložte súbor Tfseclipseplugin-updatesitearchive-10.1.0-qfe1.zip balíka rýchlej opravy do lokálneho priečinka.
-
Spustite mesiaca.
-
V ponuke Pomocník kliknite na Inštaláciu softvéru.
-
Kliknite na tlačidlo Pridať.
-
Zadajte menolokálneho Team Explorer plug-in Archív a kliknite na tlačidlo Archív.
-
Vyberte súbor Tfseclipseplugin-updatesitearchive-10.1.0-qfe1.zip, ktorá sa uloží do lokálneho priečinka a potom kliknite na tlačidlo OK.
-
V dialógovom okne Inštalácia kliknutím začiarknite políčka zodpovedajúce Team Explorer všade v zozname súčastí systému.
-
Dvakrát kliknite na tlačidlo ďalej .
-
Prijmite licenčné podmienky pre softvér spoločnosti Microsoft a kliknite na tlačidlo ďalej.
-
Kliknite na tlačidlo Dokončiť.
Ďalšie informácie o inštalácii Team Foundation Server doplnok a príkazového riadka klienta, prevezmite a potom sa zobrazí na nasledujúcej webovej stránke spoločnosti Microsoft:
Inštalácia Team Foundation Server doplnok a príkazového riadka klienta
Požiadavky
Ak chcete nainštalovať túto rýchlu opravu, musíte mať Microsoft Visual Studio Team Explorer všade 2010 Service Pack 1 (SP1) nainštalované v počítači.
Informácie o reštartovaní
Po použití tejto rýchlej opravy je nutné reštartovať mesiaca.
Informácie o nahradení rýchlej opravy
Táto rýchla oprava nenahrádza predchádzajúcu rýchlu opravu.
Informácie o súboroch
Globálna verzia tejto rýchlej opravy má atribúty súborov (alebo novšie atribúty) uvedené v nasledujúcej tabuľke. Dátumy a čas jednotlivých súborov sú uvedené vo formáte koordinovaného svetového času (UTC). Pri zobrazení informácií o súbore sa dátumy a čas prevedú na miestny čas. Ak chcete vyhľadať rozdiely medzi časom UTC a miestnym časom, použite kartu Časové pásmo v položke Dátum a čas v ovládacom paneli.
Názov súboru |
Verzia súboru |
Veľkosť súboru |
Dátum |
Čas |
---|---|---|---|---|
Tfseclipseplugin-updatesitearchive-10.1.0-qfe1.zip |
Nevzťahuje sa |
12,854,618 |
24-May-2011 |
07:17 |
Alternatívne riešenie
Ak chcete vyriešiť tento problém, postupujte nasledovne:
-
Otvorte priečinok programu mesiaca.
-
Vyhľadajte a otvorte Eclipse.ini v textovom editore. Napríklad pomocou programu Poznámkový blok otvorte súbor.
-
Pridajte nasledujúci riadok na konci súboru:
-Dcom.microsoft.tfs.client.common.ui.controls.generic.html.htmleditor.disable=
-
Uložte súbor Eclipse.ini a potom reštartujte mesiaca.
Stav
Spoločnosť Microsoft potvrdzuje, že ide o problém v produktoch spoločnosti Microsoft, ktoré sú uvedené v tomto článku v časti Informácie v tomto článku sa týkajú nasledujúcich produktov.