FIX: Sys.fn_hadr_backup_is_preferred_replica systému funkcia nefunguje správne po CU7 pre SQL Server 2012 SP1 nainštalovaný

BUG #: 199892 (údržby) VSTS: 1822306

Príznaky

Predstavte si nasledujúcu situáciu:

  • Máte Kumulatívna aktualizácia 7 pre Microsoft SQL Server 2012 Service Pack 1 (SP1) nainštalované.

  • Zapnete funkciu skupiny dostupnosti AlwaysOn SQL Server 2012.

  • Funkciu dodanie denníka niektorých databáz, ktoré sú skupiny dostupnosti AlwaysOn.

  • Nastavíte zálohovanie preferencie pre dostupnosť skupiny Prednosťsekundárne.

  • Spustiť funkciu systému sys.fn_hadr_backup_is_preferred_replicana či aktuálne replika je preferovaným záložné replika oboch na primárne a sekundárne databázy.

V tomto scenári systému funkcia môže vrátiť 1 obojstranne nesprávne.

Príčina

Tento problém sa vyskytuje z dôvodu regresnej, ktorý sa vyskytuje po nainštalovaní rýchlej opravy v KB 2887115 .

Riešenie

Kumulatívna aktualizácia balíka 8 pre SQL Server 2012 SP1/en-us/help/2917531

Každý nový Kumulatívna aktualizácia pre SQL Server obsahuje všetky rýchle opravy a všetky opravy zabezpečenia, ktoré boli súčasťou predchádzajúcej kumulatívnej aktualizácie. Pozrite sa na najnovšie kumulatívnej aktualizácie pre server SQL Server:


Informácie o rýchlej opraveOd spoločnosti Microsoft je k dispozícii podporovaná rýchla oprava. Táto rýchla oprava je však určená iba opravu problému, ktorý je popísaný v tomto článku. Rýchlu opravu použite len v počítačoch s týmto konkrétnym problémom.

Ak je rýchla oprava k dispozícii na stiahnutie, na začiatku tohto článku databázy Knowledge Base sa nachádza časť „K díspozícii je rýchla oprava na stiahnutie“. Ak sa táto sekcia nezobrazuje, odošlite požiadavku na služby zákazníkom spoločnosti Microsoft a podporu získať rýchlu opravu.

Poznámka: Ak sa vyskytnú ďalšie problémy alebo ak je potrebné riešiť problémy, je možné, že budete musieť vytvoriť samostatnú servisnú požiadavku. Na ďalšie žiadosti o podporu a problémy, ktoré sa netýkajú tejto konkrétnej rýchlej opravy, sa vzťahujú zvyčajné poplatky za poskytnutie technickej podpory. Úplný zoznam telefónnych čísel služieb zákazníkom spoločnosti Microsoft a podpora alebo vytvoriť samostatnú servisnú požiadavku, nájdete na nasledujúcej webovej lokalite spoločnosti Microsoft:

http://support.microsoft.com/contactus/?ws=supportPoznámka: "Rýchla oprava k dispozícii na prevzatie" formulár sa zobrazujú jazyky, pre ktoré je rýchla oprava k dispozícii. Ak nemôžete nájsť požadovaný jazyk, znamená to, že rýchla oprava nie je pre tento jazyk k dispozícii.

Požiadavka na reštartovaniePo použití tejto rýchlej opravy nie je potrebné reštartovať počítač.

Informácie o nahradení rýchlej opravyTáto rýchla oprava nenahrádza predchádzajúcu rýchlu opravu.

Stav

Spoločnosť Microsoft potvrdila, že ide o problém v produktoch spoločnosti Microsoft, ktoré sú uvedené v časti Vzťahuje sa na.

Author: jannaw
Writer: v-shysun
Tech Reviewer: hanspo; fasedrak; jeanyd; jannaw; sqlprev
Editor: v-emy

Potrebujete ďalšiu pomoc?

Rozšírte svoje zručnosti
Preskúmať školenie
Buďte medzi prvými, ktorí získajú nové funkcie
Pripojiť k Microsoft insiderov chcú

Považujete poskytnuté informácie za užitočné?

Ďakujem za vaše pripomienky!

Ďakujeme vám za pripomienky. Pravdepodobne vám pomôže, ak vás spojíme s pracovníkom podpory pre Office.

×