Prihláste sa s kontom Microsoft
Prihláste sa alebo si vytvorte konto.
Dobrý deň,
Vyberte iné konto.
Máte viacero kont
Vyberte konto, s ktorým sa chcete prihlásiť.

Príznaky

Predstavte si nasledujúcu situáciu:

  • Môžete vytvoriť zobrazenie zdroja údajov v Microsoft SQL Server Analysis Services (BAL) ktorý obsahuje zdroj údajov SQL Server a IBM DB2 zdroja údajov.

  • Zdroj údajov SQL Server sa nachádza vo vzdialenom systéme 64-bitové SQL Server.

  • Poskytovateľ Microsoft OLE DB pre DB2 4.0 je nainštalovaný na diaľku inštancii programu SQL Server a v systéme kde zobrazenie zdroja údajov je vytvorený.


V tomto prípade dotaz vyhlásenie, že zobrazenie zdroja údajov používa môžu zlyhať s chybové hlásenie podobné nasledujúcemu:

Trieda nie je zaregistrovaná.

Príčina

Poskytovateľa OLE DB pre DB2 4.0 používa ProgID hodnotu DB2OLEDB.1 pri 32-bit proces načíta poskytovateľa a ProgID hodnotu DB2OLEDB pri 64-bit proces načíta poskytovateľa. V tomto scenári, návrhára SQL Server pracuje ako 32-bitové proces. Preto prechádza DB2OLEDB.1 do systému vzdialeného servera SQL Server. Proces 64-bitové SQL Server nemôže nájsť DB2OLEDB.1 triedy, pretože poskytovateľa OLE DB pre DB2 4.0 je zaregistrovaná ako DB2OLEDB. Táto situácia spôsobuje dotazu sa nepodarí, pretože poskytovateľa OLE DB pre DB2 4.0 sa nedá nájsť.

Riešenie

Informácie o rýchlej oprave

Od spoločnosti Microsoft je k dispozícii podporovaná rýchla oprava. Táto rýchla oprava je však určená iba opravu problému, ktorý je popísaný v tomto článku. Rýchlu opravu použite len v systémoch, v ktorých sa vyskytuje problém popísaný v tomto článku. Táto rýchla oprava môže byť ďalej testovaná. Ak nie ste výrazne ovplyvnení týmto problémom, odporúčame vám počkať na ďalšiu aktualizáciu softvéru, ktorá bude obsahovať túto rýchlu opravu.

Ak je rýchla oprava k dispozícii na stiahnutie, na začiatku tohto článku databázy Knowledge Base sa nachádza časť „K díspozícii je rýchla oprava na stiahnutie“. Ak sa táto časť nezobrazuje, obráťte sa na oddelenie služieb zákazníkom a technickej podpory spoločnosti Microsoft a požiadajte o poskytnutie tejto rýchlej opravy.

Poznámka:  Ak sa vyskytnú ďalšie problémy alebo ak je potrebné riešiť problémy, je možné, že budete musieť vytvoriť samostatnú servisnú požiadavku. Na ďalšie žiadosti o podporu a problémy, ktoré sa netýkajú tejto konkrétnej rýchlej opravy, sa vzťahujú zvyčajné poplatky za poskytnutie technickej podpory. Ak si chcete pozrieť úplný zoznam telefónnych čísel oddelení služieb a technickej podpory zákazníkov spoločnosti Microsoft alebo vytvoriť samostatnú servisnú požiadavku, prejdite na nasledujúcu webovú lokalitu spoločnosti Microsoft:

http://support.microsoft.com/contactus/?ws=supportPoznámka: Formulár "Prevzatie dostupnej rýchlej opravy" sa zobrazuje pre jazyky, pre ktoré je rýchla oprava k dispozícii. Ak nemôžete nájsť požadovaný jazyk, znamená to, že rýchla oprava nie je pre tento jazyk k dispozícii.

Požiadavky

Použiť túto rýchlu opravu, musíte najskôr odinštalovať existujúcu inštaláciu poskytovateľa Microsoft OLE DB pre DB2 4.0. Potom použite súbor .msi, ktorý je uvedený v časti "Informácie o súbore" nainštalovať túto rýchlu opravu.

Informácie o reštartovaní

Musíte reštartovať počítač po použití tejto rýchlej opravy.

Informácie o nahradení

Táto rýchla oprava nenahrádza predchádzajúcu rýchlu opravu.

Informácie o súboroch

Anglická verzia tejto rýchlej opravy má atribúty súborov (alebo novšie atribúty) uvedené v nasledujúcej tabuľke. Dátumy a čas jednotlivých súborov sú uvedené vo formáte koordinovaného svetového času (UTC). Pri zobrazení informácií o súbore sa dátumy a čas prevedú na miestny čas. Ak chcete vyhľadať rozdiely medzi časom UTC a miestnym časom, použite kartu Časové pásmo v položke Dátum a čas v ovládacom paneli.

Pre poskytovateľa Microsoft OLE DB pre DB2 4.0

Názov súboru

Verzia súboru

Veľkosť súboru

Dátum

Čas

Platforma

Db2oledbv4_x64.msi

Nevzťahuje sa

4,073,472

26-Nov-2013

14:42

Nevzťahuje sa

Db2oledbv4_x86.msi

Nevzťahuje sa

2,992,640

26-Nov-2013

14:42

Nevzťahuje sa


Stav

Spoločnosť Microsoft potvrdila, že ide o problém v produktoch spoločnosti Microsoft, ktoré sú uvedené v časti Vzťahuje sa na.

Vyhlásenie o produktoch iných výrobcov

Produkty tretích strán, ktorými sa zaoberá tento článok, vyrábajú spoločnosti, ktoré sú nezávislé od spoločnosti Microsoft. Spoločnosť Microsoft neposkytuje žiadnu záruku, implicitnej alebo inej, týkajúce sa výkonu alebo spoľahlivosti týchto produktov.

Potrebujete ďalšiu pomoc?

Chcete ďalšie možnosti?

Môžete preskúmať výhody predplatného, prehľadávať školiace kurzy, naučiť sa zabezpečiť svoje zariadenie a ešte oveľa viac.

Komunity pomôžu s kladením otázok a odpovedaním na ne, s poskytovaním pripomienok a so získavaním informácií od odborníkov s bohatými znalosťami.

Boli tieto informácie užitočné?

Aká je podľa vás jazyková kvalita textu?
Čo sa vám páčilo, prípadne čo nie?
Stlačením tlačidla Odoslať sa vaše pripomienky použijú na zlepšenie produktov a služieb spoločnosti Microsoft. Váš správca IT bude môcť tieto údaje zhromažďovať. Vyhlásenie o ochrane osobných údajov.

Ďakujeme za vaše pripomienky!

×