Ak tento článok nepopisuje váš problém s hardvérom, nájdete na webovej lokalite Microsoft ďalšie články o hardvéri:
http://support.microsoft.com/default.aspx/w98?sid=460Dôležité upozornenie: Tento článok obsahuje informácie o úprave databázy registry. Pred úpravou databázy registry, uistite sa, že zálohovať a uistite sa, že viete, ako obnoviť databázu registry, ak sa vyskytne problém. Informácie o tom, ako zálohovať, obnovení a úprave databázy registry získate po kliknutí na nasledovné číslo článku publikovaného v databáze Microsoft Knowledge Base:
256986 Popis databázy Registry systému Microsoft Windows
Príznaky
Môže sa vyskytnúť niektorý z nasledujúcich príznakov:
-
Keď sa pokúsite vytvoriť nové telefonické pripojenie alebo otvoriť v priečinku Telefonické pripojenie siete, nie je možné vybrať modem v Sprievodcovi inštalácia nového modemu.
-
Pri otvorení telefonické sa zobrazí výzva na inštaláciu modemu.
-
Ak sa v Správcovi zariadení, vidíte nainštalované modem so stavom nasledovné zariadenia vo vlastnostiach modemu:
Toto zariadenie pracuje správne.
Ak v ovládacom paneli otvorte nástroj modemu, a kliknite na tlačidlo Podrobnosti na karte Diagnostika , zobrazí chybové hlásenia.
Príčina
Toto správanie sa môže vyskytnúť, ak súčasti TAPI sú poškodené alebo chýbajú, alebo ak ovládač iného výrobcu telefónnej odkazuje v databáze registry a ovládač je poškodený alebo nekompatibilný so systémom Windows.
Riešenie
Ak chcete vyriešiť tento problém, postupujte podľa každého postupu. Na konci každého postupu test a zistite, či sa problém vyriešil.
Metóda 1: Vyhľadanie ovládačov iných výrobcov telefónne
Upozornenie: Ak Editor databázy Registry použijete nesprávne, môžete spôsobiť vážne problémy, ktoré môžu vyžadovať preinštalovanie operačného systému. Spoločnosť Microsoft nemôže zaručiť, že môžete vyriešiť problémy, ktoré vyplývajú z nesprávneho použitia editora databázy Registry. Použite Editor databázy Registry používate na vlastné riziko. Kontrola ProviderFilename0 hodnotu v nasledovnom kľúči databázy registry pomocou editora databázy Registry:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Telephony\ProvidersPoznámka: predvolený údaj pre hodnotu ProviderFilename0 je TSP3216L.TSP. Ak údaj nie je TSP3216L. TSP, export kľúča databázy registry poskytovateľov a zmeňte údaj hodnoty TSP3216L.TSP.
Metóda 2: Vyhľadanie poškodený súbor Telephon.ini
-
Kliknite na tlačidlo Štart, ukážte na nájsťa kliknite na tlačidlo súbory alebo priečinky.
-
Do poľa zadajte telephon.ini tapiini.exe, kliknite na primárny disk v zozname Vyhľadajte a kliknite na tlačidlo Hľadať.
-
Kliknite pravým tlačidlom myši na súbor Telephon.ini, a kliknite na tlačidlo odstrániť.
-
Dvakrát kliknite na súbor Tapiini.exe vytvoriť nový súbor Telephon.ini. Ďalšie informácie získate po kliknutí na nasledovné číslo článku publikovaného v databáze Microsoft Knowledge Base:
120221 ako obnoviť súbor Telephon.ini
Metóda 3: Skontrolujte súčasti poškodené TAPI
-
Kliknite na tlačidlo Štart, ukážte na nájsťa kliknite na tlačidlo súbory alebo priečinky.
-
Do poľa zadajte tapiini.exe tapi.dll tapiui.dll tapisrv.exe tapiupr.exe tapi16.exe remotesp.tsp tsp3216l.tsp tsp3216s.dll tlocmgr.exe príkaz telephon.cpl tcmsetup.exe tapi.inf, kliknite na položku Primárny disk do poľa Hľadať a potom kliknite na tlačidlo Hľadať.
-
Pre každý súbor nájsť, kliknite pravým tlačidlom myši na súbor a kliknite na položku premenovať. Zmeniť príponu súboru každého súboru .old. Poznámka: je jeden súbor TAPI, ktorú musíte premenovať v režime MS-DOS.
-
Kliknite na tlačidlo Štart, kliknite na tlačidlo vypnúť, kliknite na tlačidlo reštartovať v režime MS-DOSa kliknite na tlačidlo OK.
-
C:\Windows príkazového riadka zadajte nasledovné riadky:
CD systemren súborom tapi32.dll tapi32.oldexit
-
Kliknite na tlačidlo Štart, kliknite na tlačidlo Spustiť, typu sfc.exe do poľa Otvoriť a kliknite na tlačidlo OK.
-
Nástroj Kontrola systémových súborov, kliknite na možnosť Extrahovať jeden súbor z inštalačných diskiet .
-
Do poľa Zadajte systémový súbor, ktorý chcete obnoviť zadajte súborom tapi32.dlla kliknite na tlačidlo Štart.
-
V dialógovom okne obnoviť z kliknite na jednotku, kde je nainštalovaný systém Windows.
-
V dialógovom okne Uložiť súbor zadajte c:\windows\systema kliknite na tlačidlo OK. Zopakujte kroky 6 až 9 pre jednotlivé súbory. Poznámka: súbor Tapi.inf je len jeden z týchto súborov, ktoré sa nenachádzajú v priečinku C:\Windows\System. Extrahovať súbor, zmeniť poľa Uložiť súbor v priečinkuc:\windows\inf.
Tapi.inf Tapiini.exe Tapi.dll Tapiui.dll Tapisrv.exe Tapiupr.exe Tapi16.exe Remotesp.tsp Tsp3216l.tsp Tsp3216s.dll Tlocmgr.exe Telephon.cpl Tcmsetup.exe
-
Reštartujte počítač.
Poznámka: poškodeného ovládača alebo ovládač modemu môžete vytvoriť aj tento problém. Ak problém pretrváva, skúste odstrániť a preinštalovať modem v Správcovi zariadení. Uistite sa, že máte aktuálne k dispozícii preinštalovať ovládače modemu.
Odkazy
SRX000914602787