KB3168740 – porušenie prístupu sa vyskytuje pri spúšťaní dvoch nadradených balíkov, ktoré používajú rovnaký podradený balík paralelne v SQL serveri 2014 alebo 2016

Príznaky

Zoberme si nasledujúcu situáciu:

  • Používate SQL Server Integration Services (SSIS) s SQL Server 2014 alebo 2016.

  • Môžete vytvoriť dva balíky SSIS, ktoré oba používajú rovnaký podradený balík.

  • Podradený balík obsahuje reťazec pripojenia, ktorý je určený výrazom.

  • Tieto dva nadradené balíky môžete spustiť paralelne.

V tomto scenári sa môže vyskytnúť súbeh, ktorá spôsobuje porušenie prístupu.

Riešenie

Tento problém bol vyriešený v nasledujúcich kumulatívnych aktualizáciách pre SQL Server:

Kumulatívna aktualizácia balíka 8 pre SQL server 2014 Service Pack 1 Kumulatívna aktualizácia 2 pre SQL Server 2014 SP2 Kumulatívna aktualizácia 2 pre SQL Server 2016

Každá nová Kumulatívna aktualizácia pre SQL Server obsahuje všetky rýchlych opráv a všetky opravy zabezpečenia, ktoré boli súčasťou predchádzajúcej kumulatívnej aktualizácie. Pozrite si najnovšie kumulatívne aktualizácie pre SQL Server:

Kumulatívna aktualizácia pre SQL server 2014 Posledná Kumulatívna aktualizácia pre SQL Server 2016

Stav

Spoločnosť Microsoft potvrdzuje, že ide o problém v produktoch spoločnosti Microsoft, ktoré sú uvedené v tomto článku v časti Informácie v tomto článku sa týkajú nasledujúcich produktov.

Odkazy

Oboznámte sa s terminológiou , ktorú spoločnosť Microsoft používa na popis aktualizácií softvéru.

Potrebujete ďalšiu pomoc?

Rozšírte svoje zručnosti
Preskúmať školenie
Buďte medzi prvými, ktorí získajú nové funkcie
Pripojiť k Microsoft insiderov chcú

Považujete poskytnuté informácie za užitočné?

Ďakujem za vaše pripomienky!

Ďakujeme vám za pripomienky. Pravdepodobne vám pomôže, ak vás spojíme s pracovníkom podpory pre Office.

×