Príznaky
Predpokladajme, že používate jeden alebo viaceré aplikácie Lync SDK – založené na počítači a pripájate sa k schôdzi s viacerými účastníkmi. V tejto situácii klient Lyncu alebo Skypu for Business prestane reagovať na obdobie.
Príčina
Pripojenie k schôdzi s mnohými účastníkmi generuje tisíce interných udalostí, ktoré sú potom zaradené do frontu a spracované.
Prítomnosť aplikácie založených na Lyncu SDK spôsobuje klientovi Lyncu alebo Skypu for Business odoslanie týchto interných udalostí do ďalších frontov. Tieto fronty používajú Inter-Apartment COM hovory, ktoré trvať oveľa dlhšie, aby dokončili. Počas spracovania tohto frontu klientske používateľské rozhranie prestane reagovať, kým sa neodstráni front.
Alternatívne riešenie
Ak chcete tento problém obísť, ukončite všetky aplikácie Lync SDK – založené pred pripojením k schôdzi.
Riešenie
Dôležité upozornenie
Postupujte presne podľa krokov uvedených v tejto časti. Ak databázu Registry upravíte nesprávne, môžu nastať vážne problémy. Skôr než ho upravíte, zálohujte databázu Registry na obnovenie v prípade výskytu problémov.
Ak chcete tento problém vyriešiť, nainštalujte si najnovšie aktualizácie pre Skype for Business 2016 a Skype for Business 2015. Potom vytvorte objekt GPO, ak chcete pridať nasledujúci nový kľúč databázy Registry DWORD a nastaviť hodnotu v rámci cesty:
HKEY_CURRENT_USER\Software\Microsoft\Office\xx.0\Lync
Hodnota DWORD EnableLargeMeetingProcessing = 1 Hodnota DWORD LargeMeetingMinimumRosterCount = 20 (predvolená možnosť) Hodnota DWORD LargeMeetingRosterLoadingDelayInSec = 30 (predvolená možnosť)
Poznámka
XX.0 v tejto ceste databázy Registry zodpovedá verzii skypu for Business (16,0 = Skype for Business 2016, 15,0 = Skype for Business 2015).
Môžete tiež povoliť túto opravu vytvorením vlastnej položky politiky a jej pridaním do politiky klienta, a to takto:
$x = New-CsClientPolicyEntry -Name "EnableLargeMeetingProcessing" -Value "true"
Set-CsClientPolicy -Identity "<ClientPolicyName>" -PolicyEntry @{Add=$x}
Získanie najnovších aktualizácií
Poznámka
Kliknutím semzobrazíte celý zoznam klientov. Pomocou technológie Klikni a spusti je odporúčaný spôsob inštalácie klienta Skype for Business. Klienta technológie Klikni a spusti si môžete stiahnuť z portálu Office365.
Vydanie programu Microsoft Installer (. msi)
Vydanie technológie Klikni a spusti
Otvorte program balíka Office, napríklad Word, a potom vyberte položku súbor> konto> Možnosti aktualizácie> aktualizovať.
Poznámka
Ak v klientovi neexistuje "Možnosti aktualizácie", ide o inštaláciu. msi.