Prihláste sa s kontom Microsoft
Prihláste sa alebo si vytvorte konto.
Dobrý deň,
Vyberte iné konto.
Máte viacero kont
Vyberte konto, s ktorým sa chcete prihlásiť.

Príznaky

Predstavte si nasledujúcu situáciu:

  • V počítači so systémom Windows Vista alebo Windows Server 2008-založené nakonfigurujete servera proxy v programe Windows Internet Explorer.

  • Používate Web Distributed Authoring and Versioning (WebDav) protokol na prístup k lokalite Microsoft Office SharePoint Server.

V tomto prípade sa neočakávane výzva na zadanie poverení trikrát. Však očakávate, že priamy prístup stránky.

Napríklad sa zobrazí výzva na zadanie poverení trikrát, ak sú splnené nasledujúce podmienky:

  • Otvoríte súbor Microsoft Office z lokality SharePoint Server.

  • Na otvorenie súboru, používate program systému Microsoft Office 2007 v počítači klienta so systémom Windows Vista, ktorý má server proxy nakonfigurovaný.

Poznámky

  • Tento problém sa nevyskytuje v počítači so systémom Windows XP.

  • Je podobný problém, ktorý sa vyskytuje v systéme Windows 7 alebo Windows Server 2008 R2, nájdete podrobné informácie.

Príčina

V systéme Windows Vista, program Internet Explorer používa službu webového klienta pri použití programu Internet Explorer na prístup k prostriedku služby. Služba webového klienta používa Windows HTTP Services (WinHTTP) vykonávať sieťové vstupno-výstupných operácií pomocou vzdialeného hostiteľa. Však WinHTTP odoslať poverenia používateľa na lokalitu SharePoint Server, keď klient pristupuje na lokalite SharePoint Server prostredníctvom servera proxy. Preto na lokalite SharePoint Server zobrazí výzvu na zadanie poverení používateľa.

Riešenie

Rýchla oprava rieši tento problém. Po použití tejto rýchlej opravy, musíte vytvoriť položku databázy registry s názvom "AuthForwardServerList." Ďalšie informácie nájdete v časti "Informácie databázy Registry".

Informácie o rýchlej oprave

Od spoločnosti Microsoft je k dispozícii podporovaná rýchla oprava. Táto rýchla oprava je však určená iba opravu problému, ktorý je popísaný v tomto článku. Rýchlu opravu použite len v počítačoch s týmto konkrétnym problémom. Táto rýchla oprava môže byť ďalej testovaná. Ak nie ste výrazne ovplyvnení týmto problémom, odporúčame vám počkať na ďalšiu aktualizáciu softvéru, ktorá bude obsahovať túto rýchlu opravu.

Ak je rýchla oprava k dispozícii na stiahnutie, na začiatku tohto článku databázy Knowledge Base sa nachádza časť „K díspozícii je rýchla oprava na stiahnutie“. Ak sa táto časť nezobrazuje, obráťte sa na oddelenie služieb zákazníkom a technickej podpory spoločnosti Microsoft a požiadajte o poskytnutie tejto rýchlej opravy.

Poznámka: Ak sa vyskytnú ďalšie problémy alebo ak je potrebné riešiť problémy, je možné, že budete musieť vytvoriť samostatnú servisnú požiadavku. Na ďalšie žiadosti o podporu a problémy, ktoré sa netýkajú tejto konkrétnej rýchlej opravy, sa vzťahujú zvyčajné poplatky za poskytnutie technickej podpory. Úplný zoznam telefónnych čísel služieb zákazníkom spoločnosti Microsoft a podpora alebo vytvoriť samostatnú servisnú požiadavku, nájdete na webovej lokalite spoločnosti Microsoft:

Poznámka: Formulár "Prevzatie dostupnej rýchlej opravy" sa zobrazuje pre jazyky, pre ktoré je rýchla oprava k dispozícii. Ak nemôžete nájsť požadovaný jazyk, znamená to, že rýchla oprava nie je pre tento jazyk k dispozícii.

Dôležité rýchlych opráv systému Windows Vista a Windows Server 2008 sa nachádzajú v rovnakých balíkoch. Však iba jeden z týchto produktov môže uvedené na stránke "Rýchla oprava žiadosť". Ak chcete požiadať o opravu hotfix, ktorá je určená pre systém Windows Vista a Windows Server 2008, stačí vybrať produkt, ktorý je uvedený na stránke.

Požiadavky

Použiť túto rýchlu opravu, počítač spustiť jeden z nasledujúcich:

  • Windows Vista

  • Windows Vista Service Pack 1

  • Windows Server 2008

Požiadavka na reštartovanie

Musíte reštartovať počítač po použití tejto rýchlej opravy.

Informácie o nahradení rýchlej opravy

Táto rýchla oprava nenahrádza žiadne iné vydané rýchle opravy.

Informácie o databáze Registry

Dôležité upozornenie: Táto časť, postup alebo úloha obsahuje kroky, ktoré informujú o úpravách databázy Registry. Ak databázu Registry upravíte nesprávne, môžu nastať vážne problémy. Postupujte preto presne podľa týchto krokov. Na dosiahnutie lepšej ochrany zálohujte databázu Registry pred úpravou. Potom môžete obnoviť databázu Registry, ak sa vyskytne problém. Ďalšie informácie o zálohovaní a obnovení databázy Registry získate po kliknutí na nasledujúce číslo článku publikovaného v databáze Microsoft Knowledge Base:

Ak chcete povoliť túto rýchlu opravu, postupujte nasledovne:

  1. Kliknite na Štart, typ
    regedit do poľa Hľadať a stlačte kláves ENTER.

  2. Vyhľadajte a kliknite na nasledujúci podkľúč databázy registry:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

  3. V ponuke úpravy ukážte na položku
    Novéa kliknite na tlačidlo Hodnota viacnásobného reťazca.

  4. Zadajte AuthForwardServerLista stlačte kláves ENTER.

  5. Upraviť v ponuke
    Upraviť.

  6. Do poľa údaj hodnoty zadajte adresu URL lokality SharePoint Server a kliknite na tlačidlo OK.
    Poznámka: Môžete tiež zadať zoznam adries URL v poli údaj hodnoty . Ďalšie informácie nájdete v časti "Vzorky URL zoznam" v tomto článku.

  7. Ukončite Editor databázy Registry.

Po vytvorení tejto položky databázy registry služby Webový klient načíta hodnotu položky. Ak klientsky počítač sa pokúsi získať prístup k URL, ktorý zodpovedá ktoréhokoľvek z výrazov v zozname, na overenie používateľa sa odosielajú poverenia používateľa, a nie výzva na zadanie poverení.

Poznámky

  • Po úprave databázy registry, musíte reštartovať službu webového klienta.

  • Zmena databázy registry môžete použiť na ľubovoľný novší operačný systém Windows aj (bez konkrétnej rýchlej opravy je potrebné, len na úpravu databázy registry).

Zoznam adries URL vzorky

Nasleduje zoznam adries URL vzorky:

https://*.Contoso.comhttp://*.dns.live.com
*.microsoft.com
https://172.169.4.6

Tento zoznam adries URL umožňuje služba webového klienta poslať poverenia týmito spôsobmi:

  • Akékoľvek šifrovaný kanál podradená doména, domény s názvom Contoso.com

  • Akékoľvek nezabezpečenú kanál podradená doména, domény, ktorého názov je dns.live.com

  • Každý kanál na server, ktorých názov končí reťazcom ". microsoft.com"

  • Akékoľvek šifrovaný kanál hostiteľovi ktorých IP adresa je 172.169.4.6

Poznámka: Po nakonfigurovaní tento zoznam adries URL, poverenia sa automaticky overenie na servery WebDAV aj v prípade, že tieto servery sú na internete.

Čomu sa vyhnúť v zozname URL

  • Pridať znak hviezdičky (*) na konci URL. Pri použití tohto postupu môže predstavovať bezpečnostné riziko. Napríklad, nepoužívajte nasledujúce URL:

    http://*.dns.live.*

  • Pred alebo po reťazec pridať znak hviezdičky (*). Po vykonaní tohto kroku webového klienta služby môžete poslať používateľské poverenia viac serverov. Zobraziť napríklad nasledujúce príklady:

    • Pridajte nasledujúce URL do zoznamu:

      http://*Contoso.com
      V tomto príklade Služba odošle používateľské poverenia na http://any_extra_charactersContoso.com

    • Pridajte nasledujúce URL do zoznamu:

      http://Contoso*.comV tomto príklade Služba odošle používateľské poverenia na http://Contosoany_extra_characters.com

  • V zozname URL Nepoužívajte UNC názov hostiteľa. Nepoužívajte napríklad nasledujúci názov:

    *.contoso.com@SSL

  • V zozname URL neobsahuje názov alebo číslo portu. Napríklad, nepoužívajte nasledujúce:

    • http://*.dns.live.com/DavShare

    • http://*dns.live.com:80

  • V zozname URL Nepoužívajte IPv6.

Dôležité upozornenie: Tento zoznam adries URL nemá vplyv na nastavenie zóny zabezpečenia. Tento zoznam adries URL sa používa len na osobitné účely zasielania poverenia na servery WebDAV. Zoznam by mal vytvoriť ako reštriktívne ako možné zabrániť problémy so zabezpečením. Tiež neexistuje žiadne špeciálne odmietnuť zoznam sú poverenia postúpené všetky servery, ktoré zodpovedajú tohto zoznamu.

Anglická verzia tejto rýchlej opravy má atribúty súborov (alebo novšie atribúty) uvedené v nasledujúcej tabuľke. Dátumy a čas jednotlivých súborov sú uvedené vo formáte koordinovaného svetového času (UTC). Pri zobrazení informácií o súbore sa dátumy a čas prevedú na miestny čas. Ak chcete vyhľadať rozdiely medzi časom UTC a miestnym časom, použite kartu Časové pásmo v položke Dátum a čas v ovládacom paneli.

Windows Vista a Windows Server 2008 súbor informácií poznámky

  • Súbory vzťahujúce sa na konkrétny produkt, medzník (RTM, SPn) je možné identifikovať na základe kontroly čísel verzií súborov tak, ako je uvedené v nasledujúcej tabuľke.

  • Service Pack 1 je súčasťou systému Windows Server 2008. Medzníky RTM sa preto vzťahujú iba na systém Windows Vista. Medzníky RTM majú číslo verzie 6.0.0000.xxxxxx.

  • Súbory typu MANIFEST (.manifest) a súbory MUM (.mum), ktoré sú nainštalované pre každý prostredie sú uvedené samostatne . Súbory MUM a súbory MANIFEST a priradené súbory katalógu zabezpečenia (.cat), sú kľúčové pre zachovanie stavu aktualizovaných súčastí. Súbory katalógov zabezpečenia (atribúty nie uvedené) sú podpísané digitálnym podpisom spoločnosti Microsoft.

Potrebujete ďalšiu pomoc?

Chcete ďalšie možnosti?

Môžete preskúmať výhody predplatného, prehľadávať školiace kurzy, naučiť sa zabezpečiť svoje zariadenie a ešte oveľa viac.

Komunity pomôžu s kladením otázok a odpovedaním na ne, s poskytovaním pripomienok a so získavaním informácií od odborníkov s bohatými znalosťami.

Boli tieto informácie užitočné?

Aká je podľa vás jazyková kvalita textu?
Čo sa vám páčilo, prípadne čo nie?
Stlačením tlačidla Odoslať sa vaše pripomienky použijú na zlepšenie produktov a služieb spoločnosti Microsoft. Váš správca IT bude môcť tieto údaje zhromažďovať. Vyhlásenie o ochrane osobných údajov.

Ďakujeme za vaše pripomienky!

×