Prihláste sa s kontom Microsoft
Prihláste sa alebo si vytvorte konto.
Dobrý deň,
Vyberte iné konto.
Máte viacero kont
Vyberte konto, s ktorým sa chcete prihlásiť.

Príznaky

Predstavte si nasledujúcu situáciu:

  • Nainštalujete rolu servera Windows Deployment Services (WDS) v počítači so systémom Windows Server 2008 R2, Windows Server 2008 alebo Windows Server 2003.

  • V lokálnej sieti (LAN), použijete obrázka spustenia systému Windows 7 alebo Windows Server 2008 R2 spustenia obrazu nasadenie obrazov jedného alebo viacerých operačných systémov Windows Deployment Services.

  • Pokúšate sa nasadiť obrázok, ktorý je založený na ACPI Uniprocessor (ACPI APIC UP) vrstvy HAL (Hardware Abstraction) klienta, ktorý používa ACPI APIC UP HAL alebo ACPI Multiprocessor (ACPI APIC MP) HAL.

V tomto prípade obrázok nie je zobrazená v ponuke obrázky dostupného operačného systému počas procesu nasadenia. Preto nie je možné nasadiť obraz klienta.

Poznámka: Tento problém sa vyskytuje aj v zavádzacie obrazy systém Windows Vista a Windows Server 2008 zavádzacie obrazy. Ďalšie informácie získate po kliknutí na nasledovné číslo článku publikovaného v databáze Microsoft Knowledge Base:

935772 ACPI APIC UP HAL obraz operačného systému nie je možné nasadiť Ak obrázka spustenia systému Windows Vista alebo Windows Server 2008 spustenia obrazu sa používa v procese nasadenia

Príčina

Problém sa vyskytuje, pretože Wdsclient.dll modul odmieta nesprávne obrázky, ktoré sú založené na ACPI APIC UP HAL pri Wdsclient.dll module zobrazenie obrázkov dostupného operačného systému.

Riešenie

Informácie o rýchlej oprave

Od spoločnosti Microsoft je k dispozícii podporovaná rýchla oprava. Táto rýchla oprava je však určená iba opravu problému, ktorý je popísaný v tomto článku. Rýchlu opravu použite len v systémoch, v ktorých sa vyskytuje problém popísaný v tomto článku. Táto rýchla oprava môže byť ďalej testovaná. Ak nie ste výrazne ovplyvnení týmto problémom, odporúčame vám počkať na ďalšiu aktualizáciu softvéru, ktorá bude obsahovať túto rýchlu opravu.

Ak je rýchla oprava k dispozícii na stiahnutie, na začiatku tohto článku databázy Knowledge Base sa nachádza časť „K díspozícii je rýchla oprava na stiahnutie“. Ak sa táto časť nezobrazuje, obráťte sa na oddelenie služieb zákazníkom a technickej podpory spoločnosti Microsoft a požiadajte o poskytnutie tejto rýchlej opravy.

Poznámka: Ak sa vyskytnú ďalšie problémy alebo ak je potrebné riešiť problémy, je možné, že budete musieť vytvoriť samostatnú servisnú požiadavku. Na ďalšie žiadosti o podporu a problémy, ktoré sa netýkajú tejto konkrétnej rýchlej opravy, sa vzťahujú zvyčajné poplatky za poskytnutie technickej podpory. Úplný zoznam telefónnych čísel služieb zákazníkom spoločnosti Microsoft a podpora alebo vytvoriť samostatnú servisnú požiadavku, nájdete na webovej lokalite spoločnosti Microsoft:

http://support.microsoft.com/contactus/?ws=supportPoznámka: Formulár "Prevzatie dostupnej rýchlej opravy" sa zobrazuje pre jazyky, pre ktoré je rýchla oprava k dispozícii. Ak nemôžete nájsť požadovaný jazyk, znamená to, že rýchla oprava nie je pre tento jazyk k dispozícii.

Požiadavky

Použiť túto rýchlu opravu, musíte používať jeden z nasledujúcich operačných systémov:

  • Windows Server 2003 Service Pack 2 (SP2)

  • Windows Server 2008

  • Windows Server 2008 Service Pack 2 (SP2)

  • Windows Server 2008 R2

  • Windows 7

  • Windows Vista Service Pack 1 (SP1)

Poznámka: Ide o operačných systémoch, v ktorom môžete nainštalovať Windows Automated Installation Kit (Windows AIK) pre systém Windows 7. Používate Windows AIK pre Windows 7 rýchlej boot image Windows 7 alebo Windows Server 2008 R2 boot image.

Informácie o databáze Registry

Ak chcete použiť rýchlu opravu v tomto balíku, nemáte robiť žiadne zmeny v databáze registry.

Požiadavka na reštartovanie

Po použití tejto rýchlej opravy nie je potrebné reštartovať počítač.

Informácie o nahradení rýchlej opravy

Táto rýchla oprava nenahrádza predchádzajúcu rýchlu opravu.

Informácie o súboroch

Globálna verzia tejto rýchlej opravy inštaluje súbory, ktorých atribúty sú uvedené v nasledujúcich tabuľkách. Dátumy a časy jednotlivých súborov sú uvedené vo formáte UTC (Coordinated Universal Time). Dátumy a časy pre tieto súbory v lokálnom počítači sú zobrazené v miestnom čase a podľa aktuálneho nastavenia funkcie prechodu na letný čas. Dátumy a časy sa okrem toho môžu zmeniť aj pri vykonávaní určitých operácií so súbormi.

Poznámky k informáciám o súboroch systémov Windows 7 a Windows Server 2008 R2

Dôležité upozornenie: Rýchle opravy systémov Windows 7 a Windows Server 2008 R2 sú súčasťou rovnakých balíkov. Rýchle opravy na stránke žiadosti o rýchlu opravu sú však uvedené pre obidva operačné systémy. Ak chcete požiadať o opravu hotfix, ktorá je určená pre jeden alebo oba operačné systémy, vyberte rýchlu opravu, ktorá je uvedená v časti "Windows 7 alebo Windows Server 2008 R2" na stránke. Vždy si pozrite časti "Vzťahuje sa na" v článkoch, aby ste zistili skutočný operačný systém, pre ktorý je daná rýchla oprava určená.

Zavádzací obraz x86 so systémom Windows 7

Názov súboru

Verzia súboru

Veľkosť súboru

Dátum

Čas

Platforma

Wdsclient.dll

6.1.7600.20650

532,480

21-Feb-2010

15:55

x86

X64 so systémom Windows 7 boot image a x64 so systémom Windows Server 2008 R2 spustiť obraz

Názov súboru

Verzia súboru

Veľkosť súboru

Dátum

Čas

Platforma

Wdsclient.dll

6.1.7600.20650

624,128

21-Feb-2010

16:09

x64

Zavádzací obraz IA-64-bitových Windows Server 2008 R2

Názov súboru

Verzia súboru

Veľkosť súboru

Dátum

Čas

Platforma

Wdsclient.dll

6.1.7600.20650

1,351,680

21-Feb-2010

15:03

IA-64

Stav

Spoločnosť Microsoft potvrdila, že ide o problém v produktoch spoločnosti Microsoft, ktoré sú uvedené v časti Vzťahuje sa na.

Ďalšie informácie

Musíte použiť túto rýchlu opravu na druhý obrázok súboru obrázka spustenia systému Windows 7 alebo Windows Server 2008 R2. Chcete urobiť, postupujte nasledovne.

Poznámka: Druhý obrázok je obraz Windows Preinstallation Environment (Windows PE).

  1. Na serveri Windows Deployment Services nainštalovať Windows automatizovaný inštalácia Kit (AIK) pre systém Windows 7.
    Ak chcete získať Windows AIK pre Windows 7, nájdete na nasledujúcej webovej lokalite spoločnosti Microsoft:http://www.microsoft.com/downloads/details.aspx?familyid=696DD665-9F76-4177-A811-39C26D3B3B34&displaylang=en
    Poznámka: Môžete tiež nainštalovať Windows AIK pre Windows 7 na samostatnom počítači, ktorý je spustený operačný systém, ktorý je podporovaný Windows AIK pre Windows 7.

  2. Kliknite na tlačidlo Štart , kliknite na položku Všetky programy, kliknite na položku Microsoft Windows AIK, kliknite pravým tlačidlom na nasadenie nástroje príkazového riadkaa vyberte Spustiť ako správca.

    UAC Ak sa zobrazí výzva na zadanie hesla správcu alebo na potvrdenie, zadajte heslo alebo poskytnite potvrdenie.

  3. Extrahujte súbor Windows6.1-KB980711platformusúbor .cab z opravy hotfix do dočasného priečinka. Ak to chcete urobiť, postupujte nasledovne:

    1. Kliknite na tlačidlo Štart , kliknite na položku Spustiť, zadajte reťazec cmda kliknite na tlačidlo OK.

    2. Do príkazového riadka zadajte nasledovný príkaz a stlačte kláves ENTER:

      Expand.exe CabFilePath -R-F: * TempFolderPathPoznámky

      • CabFilePath predstavuje cestu k súboru CAB.

      • TempFolderPath predstavuje cestu dočasný priečinok.

  4. Vypnúť problematické boot image, aby bol k dispozícii na prevzatie v procese aktualizácie. Chcete urobiť, otvorte modul Windows Deployment Services Microsoft Management Console (MMC), kliknite pravým tlačidlom na boot image, ktorý chcete aktualizovať a vyberte vypnúť.

  5. Exportovať problematické boot image zo servera Windows Deployment Services BootWimPath. Chcete urobiť, kliknite pravým tlačidlom na boot image a potom vyberte Export. Exportovať boot image BootWimPath.

    Poznámky

    • BootWimPath predstavuje lokálne adresár, kde je exportovaný súbor Boot.wim.

    • Nainštalujete systém Windows AIK na samostatnom počítači musí skopírujte súbor Boot.wim do adresára v počítači. Potom vykonajte kroky 6 až 8 v počítači.

  6. Pripojiť zavádzací obraz na čítanie a zapisovanie. Chcete urobiť, zadajte nasledujúci príkaz do príkazového riadka a stlačte kláves ENTER:

    DISM /mount-wim /wimfile:BootWimPath /index:2 /mountdir:MountLocationPoznámka:

    • MountLocation predstavuje miesto obraz.

    • Uistite sa, že pripojiť obrazu, ktorého Zavádzacia indexové číslo je 2.

  7. Skopírujte súbor Wdsclient.dll z priečinka TempFolderPath nasledovné priečinky:

    • MountLocation\Windows\Winsxs\Platform_microsoft-windows-imagebasedsetup-media_ID

    • MountLocation\sources

    Poznámka: Napríklad zástupný symbol ID hodnotu 31bf3856ad364e35_6.1.7600.16385_none_6fe42cf3e82ff497

  8. Odpojenie Boot.wim súboru, a potom potvrdiť všetky zmeny. Chcete urobiť, zadajte nasledujúci príkaz do príkazového riadka a stlačte kláves ENTER:

    Dism.exe /unmount-wim /mountdir:MountLocation /commit

  9. Pridať aktualizovaný Boot.wim súbor späť na server Windows Deployment Services. Chcete urobiť, otvorte modul Windows Deployment Services MMC kliknite pravým tlačidlom myši na Zavádzacie obrazy, vyberte položku Pridaťa potom zadajte cestu aktualizovaný súbor Boot.wim

  10. Windows Deployment Services MMC modulu, kliknite pravým tlačidlom myši boot image, ktoré ste pridali do uistite sa, že je zapnutá.

    Poznámka: Musíte vypnúť alebo odstrániť problematické boot image.

Ďalšie informácie o službe Windows Deployment Services nájdete na nasledujúcich webových lokalitách Microsoft Tech:

Všeobecné informácie o službe Windows Deployment Services

Všeobecné informácie o Windows Deployment Services for Windows Server 2008 R2Ďalšie informácie získate po kliknutí na nasledujúce číslo článku publikovaného v databáze Microsoft Knowledge Base:

935772 po inovácii na program WDS, ACPI Multiprocessor obraz nezobrazí v ponuke obrazov operačného systému pri spustení PXE klient počítače ACPI Uniprocessor HAL

Ďalšie informácie o terminológii z oblasti aktualizácií softvéru získate po kliknutí na nasledujúce číslo článku publikovaného v databáze Microsoft Knowledge Base:

824684 Popis štandardnej terminológie použitej na popis aktualizácií softvéru od spoločnosti Microsoft

Potrebujete ďalšiu pomoc?

Chcete ďalšie možnosti?

Môžete preskúmať výhody predplatného, prehľadávať školiace kurzy, naučiť sa zabezpečiť svoje zariadenie a ešte oveľa viac.

Komunity pomôžu s kladením otázok a odpovedaním na ne, s poskytovaním pripomienok a so získavaním informácií od odborníkov s bohatými znalosťami.

Boli tieto informácie užitočné?

Aká je podľa vás jazyková kvalita textu?
Čo sa vám páčilo, prípadne čo nie?
Stlačením tlačidla Odoslať sa vaše pripomienky použijú na zlepšenie produktov a služieb spoločnosti Microsoft. Váš správca IT bude môcť tieto údaje zhromažďovať. Vyhlásenie o ochrane osobných údajov.

Ďakujeme za vaše pripomienky!

×