Applies ToWindows 7 Home Premium Windows 7 Enterprise Windows 7 Enterprise N Windows 7 Home Basic Windows 7 Professional Windows 7 Professional N Windows 7 Starter Windows 7 Starter N Windows 7 Ultimate Windows 7 Ultimate N Microsoft Windows XP Service Pack 3

Podpora pre Windows Vista Service Pack 1 (SP1) končí 12. júla 2011. Ak chcete pokračovať v prijímaní aktualizácií zabezpečenia pre Windows, skontrolujte, či používate Windows Vista s balíkom Service Pack 2 (SP2). Ďalšie informácie nájdete v téme Táto webová stránka spoločnosti Microsoft: končí sa podpora pre niektoré verzie Windowsu.

Príznaky

Zvážte nasledujúci scenár.

  • Používate Windows XP Service Pack 3 (SP3), Windows Vista Service Pack 1 (SP1) alebo počítač so systémom Windows 7

  • Používate meno používateľa, ktoré obsahuje znak dvojbajtového znaku set (DBCS).

Pri pokuse o inštaláciu aplikácie, ktorá používa Redistribuovateľný balík Microsoft Visual C++ 2005, sa zobrazí nasledujúce chybové hlásenie:

Syntaktická chyba možnosti príkazového riadkovania. Zadajte príkaz/? O pomoc.

Príčina

Tento problém sa vyskytuje, pretože nástroj kabinetu Win32 Self-Extractor nedokáže spracovať znaky DBCS v názve používateľa.

Riešenie

Ak chcete, aby sme tento problém vyriešili za vás, prejdite na časťOpravte to za mňa. Ak chcete tento problém vyriešiť sami, prejdite na časťja to vyriešim.

Opravte to za mňa

Ak chcete tento problém vyriešiť automaticky, kliknite na tlačidlo opraviť alebo prepojenie. V dialógovom okne sťahovanie súboru kliknite na položku Spustiť a postupujte podľa krokov v sprievodcovi riešenie Fix it.

Poznámok

  • Riešenie Fix it nebude fungovať, ak vaše konto nie je kontom správcu.

  • Tento sprievodca môže byť dostupný iba v angličtine. Automatická oprava však funguje aj pre ostatné jazykové verzie systému Windows.

  • Ak nie ste v počítači, v ktorom sa vyskytol problém, môžete riešenie Fix it uložiť na USB kľúč alebo na CD disk a potom ho spustiť v počítači, v ktorom sa vyskytol problém.

Potom prejdite na časť vyriešil saproblém?

Ja to vyriešim

Ak chcete tento problém vyriešiť, postupujte podľa týchto krokov:

  1. Kliknite na položku spustiť Tlačidlo Štart , kliknite pravým tlačidlom myši na položku počítača potom kliknite na položku Vlastnosti.

  2. V oblasti Nastavenie názvu počítača, domény a pracovnej skupiny kliknite na položku zmeniť nastavenie. Povolenie kontroly používateľských kont  Ak sa zobrazí výzva na zadanie hesla správcu alebo na potvrdenie, zadajte svoje heslo alebo kliknite na položku Continue (pokračovať).

  3. Kliknite na položku zmeniť nastavenie a potom selct na kartu Spresnenie. Kliknite na tlačidlo premenné prostredia

  4. V oblasti premenných používateľa kliknite na položku temp a potom kliknite na položku Upraviť.

  5. Do poľa hodnota premennej zadajte C:\Temp a potom dvakrát kliknite na tlačidlo OK .

  6. Kliknite na tlačidlo použiťa potom na tlačidlo OK.

  7. Postupujte podľa krokov 4 až 6 pre premennú prostredia TMP.

  8. Potvrďte, že priečinok C:\Temp existuje, ak ho nevytvoríte.

  9. Reštartujte počítač.

  10. Skúste aplikáciu nainštalovať znova.

Vyriešil sa problém?

  • Skontrolujte, či sa problém vyriešil. Ak sa problém vyriešil, dokončili ste sa v tejto časti. Ak sa problém nevyriešil, môžete sa obrátiť na oddelenie technickej podpory.

  • Ocenili by sme vaše pripomienky. Ak chcete poskytnúť pripomienky alebo nahlásiť akékoľvek problémy s týmto riešením, zanechajte komentár k bloguOpravte to za mňaalebo nám pošlite e-mail.

Potrebujete ďalšiu pomoc?

Chcete ďalšie možnosti?

Môžete preskúmať výhody predplatného, prehľadávať školiace kurzy, naučiť sa zabezpečiť svoje zariadenie a ešte oveľa viac.

Komunity pomôžu s kladením otázok a odpovedaním na ne, s poskytovaním pripomienok a so získavaním informácií od odborníkov s bohatými znalosťami.