Prihláste sa s kontom Microsoft
Prihláste sa alebo si vytvorte konto.
Dobrý deň,
Vyberte iné konto.
Máte viacero kont
Vyberte konto, s ktorým sa chcete prihlásiť.

Podpora pre Windows Vista Service Pack 1 (SP1) sa skončila 12. júla 2011. Ak chcete pokračovať v prijímaní aktualizácií zabezpečenia pre Windows, skontrolujte, či používate Windows Vista s balíkom Service Pack 2 (SP2). Ďalšie informácie nájdete v téme Táto webová stránka spoločnosti Microsoft: končí sa podpora pre niektoré verzie Windowsu.

Príznaky

Pokúšate sa stiahnuť súbor, ktorý je väčší ako 50000000 bajtov z webového priečinka v systéme Windows XP Service Pack 2 (SP2) alebo novšiu verziu Windowsu. Môže sa zobraziť chybové hlásenie podobné nasledujúcemu:

Názov súborusa nedá skopírovať: zo zdrojového súboru alebo disku sa nedá čítať

Poznámka v tomto chybovom hlásení je názov súboru zástupným symbolom názvu súboru.

Tento problém sa vyskytuje aj v počítači so systémom Windows Vista alebo v počítači so systémom Windows XP Service Pack 1 (SP1), v ktorom je nainštalovaná aktualizácia zabezpečenia 896426 (MS05-028).

V tomto scenári v systéme Windows 7, 8 alebo 8,1 sa môže zobraziť nasledujúce chybové hlásenie:

Kopírovanie priečinka

Pri kopírovaní priečinka sa neočakávaná chyba udržiava. Ak sa táto chyba zobrazuje aj naďalej, môžete pomocou kódu chyby vyhľadať pomoc s týmto problémom.

Chyba 0x800700DF: veľkosť súboru prekračuje povolený limit a nie je možné ho uložiť.

<názov súboru>

Skúste to znova zrušiť

Príčina

Tento problém sa vyskytuje, pretože zmeny zabezpečenia, ktoré boli zavedené v systéme Windows XP SP2, majú vplyv na Presmerovač Web Distributed Authoring and Versioning (WebDAV). Táto zmena zabezpečenia zaisťuje, že neoprávnený server nemôže vynútiť klientsky počítač na útok na odmietnutie služby. Ak sa pokúsite Stiahnuť súbor, ktorý je väčší ako 50000000 bajtov, klientsky počítač interpretuje tento súbor na stiahnutie ako útok na odmietnutie služby. Z tohto dôvodu sa proces sťahovania zastaví.

Riešenie

Dôležité Táto časť, metóda alebo úloha obsahuje kroky, ktoré vám informujú o tom, ako upraviť databázu Registry. Ak však databázu Registry upravíte nesprávne, môžu nastať vážne problémy. Preto dávajte pozor a postupujte presne podľa týchto krokov. Na dosiahnutie lepšej ochrany je vhodné pred úpravou databázu Registry zálohovať. To vám umožní obnoviť databázu Registry, ak sa vyskytnú problémy. Ďalšie informácie o zálohovaní a obnovení databázy Registry sa nachádzajú v nasledujúcom článku databázy Microsoft Knowledge Base:

322756 Ako zálohovať a obnovovať databázu Registry vo Windowse,
Ak máte Windows XP SP2, Vista alebo 7, prejdite do častiOpravte to za mňaa spustite opravu. Ak chcete tento problém vyriešiť sami alebo používate Windows 8 alebo 8,1, prejdite na časťja to vyriešim.

Windows XP SP2, Vista alebo 7: Opravte to za mňa



Ak chcete tento problém vyriešiť automaticky, kliknite na tlačidlo opraviť alebo prepojenie. V dialógovom okne sťahovanie súboru kliknite na položku Spustiť a postupujte podľa krokov v sprievodcovi riešenie Fix it.

Poznámka: Táto oprava nefunguje s Windowsom 8 ani novším.




Poznámok

  • Keď budete postupovať podľa sprievodcu riešenie Fix it, musíte zadať hodnotu FileSizeLimitInBytes, ktorá je väčšia než veľkosť súboru, ktorý chcete stiahnuť.

  • Tento sprievodca môže byť dostupný iba v angličtine. Automatická oprava však funguje aj pre ostatné jazykové verzie systému Windows.

  • Ak nie ste v počítači, v ktorom sa vyskytol problém, môžete riešenie Fix it uložiť na USB kľúč alebo na CD disk a potom ho spustiť v počítači, v ktorom sa vyskytol problém.


Potom prejdite na časť vyriešil saproblém?



Ja to vyriešim


Ak chcete tento problém vyriešiť, postupujte podľa týchto krokov:

  1. Windows XP SP2, Vista alebo 7: kliknite na tlačidlo Štart, kliknite na položku Spustiť, zadajte príkaz regedit a potom kliknite na tlačidlo OK.

    Windows 8 alebo novšia: potiahnutím prstom z pravej časti zobrazte kľúčové tlačidlá a potom vyberte položku Hľadať a zadajte príkaz regedit (alebo zadajte príkaz regedit z domovskej obrazovky). Vyberte položku regedit z výsledkov vyhľadávania a spustite ju.

  2. Vyhľadajte nasledujúci podkľúč databázy Registry a kliknite naň:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

  3. Na pravej table kliknite pravým tlačidlom myši na
    FileSizeLimitInBytes hodnotu a potom kliknite na položku
    Upraviť.

    Ak sa nezobrazuje
    hodnotaFileSizeLimitInBytes , kliknite pravým tlačidlom myši na prázdne miesto na pravej table, kliknite na položku nový, kliknite na položku hodnota DWORD, zadajte FileSizeLimitInBytes a potom kliknite na
    tlačidlo OK.

  4. V poli Upraviť hodnotu DWORD kliknutím vyberte možnosť desatinné číslo . Do poľa v časti údaje hodnotyzadajte hodnotu, ktorá je väčšia ako veľkosť súboru, ktorý chcete stiahnuť. Kliknite na tlačidlo OK.

    Poznámka Predvolená hodnota pre limit veľkosti súboru je 50000000 bajtov.

  5. Ukončite Editor databázy Registry. Reštartujte počítač.


Vyriešil sa problém?

  • Skontrolujte, či sa problém vyriešil. Ak sa problém vyriešil, dokončili ste sa v tejto časti. Ak sa problém nevyriešil, môžete sa obrátiť na oddelenie technickej podpory.

  • Ocenili by sme vaše pripomienky. Ak chcete poskytnúť pripomienky alebo nahlásiť akékoľvek problémy s týmto riešením, zanechajte komentár k bloguOpravte to za mňaalebo nám pošlite e-mail.

Potrebujete ďalšiu pomoc?

Chcete ďalšie možnosti?

Môžete preskúmať výhody predplatného, prehľadávať školiace kurzy, naučiť sa zabezpečiť svoje zariadenie a ešte oveľa viac.

Komunity pomôžu s kladením otázok a odpovedaním na ne, s poskytovaním pripomienok a so získavaním informácií od odborníkov s bohatými znalosťami.

Boli tieto informácie užitočné?

Aká je podľa vás jazyková kvalita textu?
Čo sa vám páčilo, prípadne čo nie?
Stlačením tlačidla Odoslať sa vaše pripomienky použijú na zlepšenie produktov a služieb spoločnosti Microsoft. Váš správca IT bude môcť tieto údaje zhromažďovať. Vyhlásenie o ochrane osobných údajov.

Ďakujeme za vaše pripomienky!

×