Prihláste sa s kontom Microsoft
Prihláste sa alebo si vytvorte konto.
Dobrý deň,
Vyberte iné konto.
Máte viacero kont
Vyberte konto, s ktorým sa chcete prihlásiť.

Príznaky

Pri spustení portálu Business Portal sa môže zobraziť výzva na zadanie mena používateľa a hesla. Tento problém sa vyskytuje v týchto produktoch:

  • Business Portal in Microsoft Dynamics GP

  • Business Portal in Microsoft Business Solutions - Great Plains

  • Business Portal in Microsoft Dynamics SL

  • Business Portal in Microsoft Business Solutions - Solomon

Príčina

Príčina 1

Tento problém môže byť spôsobený nastavením konfigurácie v službe Microsoft Internetové informačné služby (IIS). Pozrite si časť Rozlíšenie 1 v časti Rozlíšenie.

Príčina 2

Tento problém môže byť spôsobený nastavením konfigurácie v Microsoft Internet Exploreri. Pozrite si časť Rozlíšenie 2 v časti Rozlíšenie.

Príčina 3

Tento problém sa môže vyskytnúť, pretože Windows SharePoint roly a roly portálu Business Portal nie sú správne synchronizované. Pozrite si časť Rozlíšenie 3 v časti Rozlíšenie.

Príčina 4

Tento problém sa môže vyskytnúť, ak boli používatelia odstránení a znova pridaní do adresárovej služby Active Directory pomocou rovnakého mena používateľa, IDENTIFIKÁCIA zabezpečenia (SID) používateľa sa môže líšiť v službe Active Directory od toho, čo je uvedené v Windows SharePoint Services (WSS). Pozrite si časť Rozlíšenie 4 v časti Rozlíšenie.

Príčina 5

Tento problém sa môže vyskytnúť, pretože u konkrétneho používateľa, ktorý sa vyskytol problém, je poškodený súbor Ntuser.dat. Pozrite si časť Rozlíšenie 5 v časti Rozlíšenie.

Príčina 6

Tento problém sa môže vyskytnúť, pretože na stránky portálu Business Portal bolo pridané logo spoločnosti a používateľ pravdepodobne nemá povolenia systému súborov NTFS pre súbor, ktorý obsahuje logo. Pozrite si časť Rozlíšenie 6 v časti Rozlíšenie.

Príčina 7

Tento problém sa môže vyskytnúť, ak používateľ nemá správne práva na fyzické súbory ASP.NET *.aspx. Pozrite si časť Rozlíšenie 7 v časti Rozlíšenie.

Príčina 8

Tento problém sa môže vyskytnúť, ak SharePoint webová aplikácia používa overovanie Kerberos. Pozrite si časť Rozlíšenie 8 v časti Rozlíšenie.

Riešenie

Rozlíšenie 1

Ak chcete overiť nastavenie konfigurácie v službe IIS, postupujte takto:

  1. Prihláste sa na server so službou IIS ako používateľ s lokálnymi povoleniami správcu.

  2. Kliknite na tlačidloŠtart , kliknite napoložku Spustiť , zadajte text inetmgr a potom kliknite na tlačidlo OK.

  3. Kliknite pravým tlačidlom myši na webovú lokalitu, na ktorej je nainštalovaný portál Business Portal, a potom kliknite na položku Vlastnosti.

  4. Kliknite na kartu Zabezpečenie adresára.

  5. V okne Overovanie a riadenie prístupu kliknite na položku Upraviť.

  6. Kliknutím začiarknite políčko Integrované Windows a potom kliknite na tlačidlo OK.

    Poznámka Začiarkavacie políčko integrované Windows overovanie by malo byť jediným začiarknuť políčkom v tomto okne. Ak je v službe IIS zapnuté základné overovanie, pri každom prístupe na webovú lokalitu v relácii Internet Explorera sa zobrazí výzva na prihlásenie. Ak je povolené overovanie digestu, pri každom prístupe na webovú lokalitu sa zobrazí aj výzva na prihlásenie. Overenie s prehľadom však vyžaduje Active Directory a meno používateľa a heslo sú šifrované.

  7. Rozbaľte webovú lokalitu, na ktorej je nainštalovaný podnikový portál, kliknite pravým tlačidlom myši na virtuálny adresár BusinessPortal, kliknite na položku Vlastnosti a zopakujte kroky 5 až 7 uvedené vyššie v tejto časti.

Rozlíšenie 2

Ak chcete overiť nastavenie konfigurácie v Internet Exploreri, postupujte takto:

  1. V Internet Exploreri určite, či podnikový portál používa zónu Lokálny intranet alebo Dôveryhodné lokality. Ak to chcete urobiť, spustite portál Business Portal a poznačte si, ktorá zóna je uvedená v pravom dolnom rohu okna Internet Explorera lokality Business Portal.

  2. Kliknite na položkyNástroje , Možnosti siete interneta potom kliknite na kartu Zabezpečenie.

  3. V závislosti od toho, ktorú zónu podnikový portál používa, kliknite buď na položkuLokálny intranet, alebo Dôveryhodné lokality, a potom kliknite na položku Vlastná úroveň.

    Poznámka Ak chcete určiť, ktorú zónu podnikový portál používa, pozrite si vyššie krok 1 v tejto časti.

  4. Skontrolujte, či sú technológia ActiveX všetky možnosti nastavené na možnosť Povolené.

  5. V časti Overenie používateľa skontrolujte, či je začiarknuté políčko Automatické prihlásenie s aktuálnym menom používateľa a heslom.

  6. Ak chcete vymazať nesprávne heslá z vyrovnávacej pamäte, použite príslušný krok:

    • Ak používate Internet Explorer Windows 7, kliknite na kartu Všeobecné, potom na položku Odstrániťa na položku Odstrániť heslá.

    • Ak používate Internet Explorer 6 Windows, kliknite na kartu Obsah, potom na položku Automatické dokončovaniea na položku Vymazať heslá.

  7. Overte, či možnosť Prediskutovať nie je zapnutá v Internet Exploreri. Ak to chcete urobiť, kliknite na položkyZobraziť , Panel prieskumníkaa potom kliknutím odstráňte znak začiarknutia vedľa položky Prediskutovať.

Poznámka Nastavenia Internet Explorera musia byť nakonfigurované v každej pracovnej stanice pre každého používateľa, u ktorých sa vyskytol problém.

Rozlíšenie 3

Tento problém vyriešite spustením synchronizácie rolí na portáli Business Portal. Postupujte podľa nasledujúcich krokov:

  1. Spustiť podnikový portál ako používateľ, ktorý má priradenú rolu správcu na podnikovom portáli pre všetky spoločnosti.

  2. Kliknite na Nastavenia lokality, kliknite na položku Používatelia a povolenia, kliknite na položku Spravovaťroly a potom na položku Skontrolovať synchronizáciu rolí.

  3. Kliknite na položkuVšetko a potom na položku Skontrolovať.

  4. Ak sú chyby nahlásené, kliknite na položku Aktualizovať.

Poznámka Táto funkcia neexistuje na portáli Business Portal v systéme Microsoft Dynamics GP 10.0 alebo na portáli Business Portal v systéme Microsoft Dynamics SL 7.0.

Rozlíšenie 4

Ak chcete vyriešiť tento problém, spustite nástroj ValidateBPUser a vyhľadajte používateľa alebo používateľov, ktorí majú neplatné identifikátory SIDs. Postupujte podľa nasledujúcich krokov:

  1. Stiahnite si ValidateBPUser.exe pomoc. Ak si chcete ValidateBPUser.exe pomocné služby, navštívte túto webovú lokalitu spoločnosti Microsoft:

    https://mbs.microsoft.com/fileexchange/?fileID=8069b581-a52b-4705-90c7-0ed728fe0b9ePoznámka Stiahnite si nástroj do počítača so spusteným portálom Business Portal.

  2. Upravte nasledujúce dva parametre v ValidateBPusers.exe.config súbore na základe konkrétneho prostredia:

    1. WebServerRootUrl
      Toto je URL adresa, ktorá je hostiteľom podnikového portálu. Ak ste napríklad nainštalovali Podnikový portál na predvolenú webovú lokalitu, URL adresa sa http://IISComputerName.

    2. BusinessPortalBPSharePointRootSiteUrl
      Toto je business portal SharePoint KOREŇOVÁ URL adresa lokality. Zodpovedá parametru wssObjectModelSiteURL v súbore BusinessFramework.config.

  3. Spustite nástroj ValidateBPUser.exe program. Ak to chcete urobiť, postupujte podľa týchto krokov Poznámka Nezabudnite spustiť nástroj ako používateľ portálu Business Portal, ktorý má priradenú rolu správcu

    BP (všetky spoločnosti). Ak používateľovi nie je priradená rola správcu BP, zobrazí sa výzva na zadanie mena používateľa a hesla.

    1. V okne systému MS-DOS prejdite do adresára, v ktorom ste uložili nástroj, a potom do príkazového riadka zadajte nasledujúci príkaz:

      validateBPUsers.exe verbose

    2. Ak chcete okno zavrieť, zadajte text exit (skončiť).

  4. Tento nástroj aktualizuje BusinessPortalSharepointSIDMismatches.xml súbor. Súbor obsahuje všetkých používateľov, ktorých SID v službe Active Directory nezodpovedá sidu vo WSS. Predvolene sa tento súbor nachádza v tomto priečinku:

    C:\Program Files\Common Files\Microsoft Shared\web server extensions\60\BIN

  5. Ak súbor obsahuje používateľov, ktorí majú nerovnakujúce sids, obráťte sa na oddelenie technickej podpory pre Microsoft Dynamics.

Rozlíšenie 5

Ak chcete vyriešiť poškodený súbor Ntuser.dat, znova vytvorte používateľský profil. Ďalšie informácie o tom, ako znova vytvoriť používateľský profil, získate po kliknutí na nasledujúce číslo článku, ktorý sa zobrazí vedomostnej databázy Microsoft Knowledge Base:

811151 Kopírovanie údajov z poškodeného používateľského profilu do nového profilu

Rozlíšenie 6

Tento problém vyriešite tak, že používateľovi poskytnete povolenia na úplný prístup NTSF k súboru, ktorý obsahuje logo. Postupujte podľa nasledujúcich krokov:

  1. Vyhľadajte súbor, ktorý obsahuje logo. Ak to chcete urobiť, kliknite na položku Nastavenia, kliknite na položku Nastaveniaa potom kliknite na položku Zmeniť logo portálu.

  2. Kliknite pravým tlačidlom myši na súbor a potom kliknite na položku Vlastnosti.

  3. Na karte Zabezpečenie kliknite na položku Pridať.

  4. Do oblasti Zadajte názvy objektov, ktoré sa majú vybrať zadajte meno používateľa, ktorý sa má zobraziť, kliknite na položku Skontrolovať mená a potom kliknite na tlačidlo OK.

  5. V oblasti Povolenia kliknite na položku Povoliť pre možnosť Úplný prístup a potom kliknite na tlačidlo OK.

Rozlíšenie 7

Tento problém vyriešite tak, že poskytnete expplikátne práva všetkým fyzickým súborom, ktoré používa webová lokalita. Alebo ako test na zobrazenie, či sa chyba stále vyskytuje, nasní s lokálnym správcom počítača s portálom Business Portal.

Rozlíšenie 8

Tento problém vyriešite zapnutím overovania NTLM pre webovú aplikáciu Business Portal. V prípade príslušnej verzie nižšie postupujte podľa týchto krokov:


SharePoint 3.0

  1. Na serveri Business Portal kliknite na tlačidlo Štart, kliknite na položku Ovládací panel, kliknite na položku Nástroje na správu a potom kliknite na položku SharePoint centrálnej správy systému 3.0.

  2. Kliknite na kartu Správa aplikácií.

  3. V časti Zabezpečenie aplikácie kliknite na položku Poskytovatelia overovania.

  4. Skontrolujte, či je v pravom hornom rohu vybratá webová aplikácia Business Portal.

  5. Kliknite na položku Predvolené.

  6. V časti Nastavenia iis Nastavenia skontrolujte, či je začiarknuté Windows integrované overenie služby IIS. Skontrolujte tiež, či je vybratá možnosť NTLM.

  7. Kliknite na tlačidlo Uložiť.

  8. Reštartujte služby IIS.

  9. Spustite Business Portal a skontrolujte, či sa problém vyskytol aj naďalej.

SharePoint 2010

  1. Na serveri Business Portal kliknite na tlačidlo Štart ,kliknite na položku Všetky programy ,kliknite na položku SharePoint 2010 Productsa potom kliknite na položku SharePoint Centrálna správa servera 2010.

  2. Kliknite na položku Spravovať webové aplikácie.

  3. Kliknutím zvýraznite lokalitu, na ktorú je nainštalovaná webová aplikácia Business Portal.

  4. V časti Zabezpečenie kliknite na položku Poskytovatelia overovaniaa potom kliknite na položku Predvolené.

  5. V časti Overenie služieb IIS Nastavenia skontrolujte, či je začiarknuté políčko Integrované Windows overovania. Skontrolujte tiež, či je vybratá možnosť NTLM.

  6. Kliknite na položku Uložiť.

  7. Reštartujte služby IIS.

  8. Spustite Business Portal a skontrolujte, či sa problém vyskytol aj naďalej.

Potrebujete ďalšiu pomoc?

Chcete ďalšie možnosti?

Môžete preskúmať výhody predplatného, prehľadávať školiace kurzy, naučiť sa zabezpečiť svoje zariadenie a ešte oveľa viac.

Komunity pomôžu s kladením otázok a odpovedaním na ne, s poskytovaním pripomienok a so získavaním informácií od odborníkov s bohatými znalosťami.

Boli tieto informácie užitočné?

Aká je podľa vás jazyková kvalita textu?
Čo sa vám páčilo, prípadne čo nie?
Stlačením tlačidla Odoslať sa vaše pripomienky použijú na zlepšenie produktov a služieb spoločnosti Microsoft. Váš správca IT bude môcť tieto údaje zhromažďovať. Vyhlásenie o ochrane osobných údajov.

Ďakujeme za vaše pripomienky!

×