Príznaky
Po dokončení alebo zrušení odosielateľa sa hodnota v poli stav neaktualizuje na možnosť zatvorené v správe objednávok v Microsoft Dynamics SL.
Poznámka: Pole stav sa zobrazí na karte Ďalšie informácie na obrazovke odosielateľov (40.110.00) . Okrem toho obrazovka zobrazovača denníka aktualizácie denníkov (40.460.00) nezahŕňa položku identifikácie odosielateľa.
Príčina
Príčina 1
Nastavenie aktualizácie oneskoreného odosielateľa je nesprávne. Pozrite si tému Riešenie 1.
Príčina 2
Nastavenie času v režime spánku pre správcov procesov je príliš malé. Pozrite si tému Riešenie 2
Príčina 3
Krok odosielateľa aktualizácie na karte kroky v okne Typy objednávok (40.200.00) je nastavený nesprávne. Pozrite si tému Riešenie 3.
Príčina 4
Typ objednávky sa zmenil na karte kroky na obrazovke Typy objednávok (40.200.00) pred zatvorením existujúcich odosielateľov. Pozrite si tému Riešenie 4.
Príčina 5
Prispôsobenia sa pridali na obrazovku odosielateľov (40.110.00) , ktorá prerušila spracovanie záznamov odosielateľa. Pozrite si tému riešenie 5.
Príčina 6
Ľubovoľná príčina okrem príčiny 1 až príčina 5. V tomto prípade sa tento problém vyskytuje bez ohľadu na typ objednávky. Pozrite si tému riešenie 6 alebo rezolúcia 7.
Riešenie
Riešenie 1
Overte, či nastavenie oneskorenia aktualizácie odosielateľa nie je príliš veľké. Postupujte podľa nasledujúcich krokov:
-
V ponuke modul kliknite na položku správa objednávok.
-
Na table správa objednávok kliknite v časti Nastaveniena položku Nastavenie správy objednávok .
-
Na karte iné Skontrolujte, či je hodnota v poli Aktualizácia oneskoreného odosielateľa (minúty) príliš veľká. Poznámka: Ak je hodnota oneskorenej aktualizácie (minút) zasielateľa nastavená na hodnotu 30, odosielateľ sa nezavrie až 30 minút po dokončení záznamu odosielateľa.
Riešenie 2
Zvýšte dobu spánku procesu manažéra procesov. Postupujte podľa nasledujúcich krokov:
-
V ponuke modul kliknite na položku správa objednávok.
-
Na table správa objednávok kliknite v časti Nastaveniena položku Nastavenie správy objednávok .
-
Ak je hodnota v poli menšia než 15, na karte Ďalšie zadajte do poľa časový úsek spánku správcu procesov (v sekundách) hodnotu 15 .
Riešenie 3
Opravte stav kroku v type objednávky. Postupujte podľa nasledujúcich krokov:
-
V zozname modulov kliknite na položku správa objednávok.
-
Na table správa objednávok kliknite na položku Typy objednávok v časti Údržba.
-
Do poľa typ objednávky zadajte identifikáciu typu objednávky, ktorú chcete zmeniť.
-
Na karte kroky kliknite na položku vyžadované v stave pre krok odosielateľa aktualizácie.
-
Kliknite na tlačidlo Uložiť. Potom zatvorenie obrazovky Typy objednávok (40.200.00) .
Riešenie 4
Zrušenie odosielateľov a súvisiacich predajných objednávok. Postupujte podľa nasledujúcich krokov:
-
V zozname modulov kliknite na položku správa objednávok.
-
Na table správa objednávok kliknite v časti vstup na položku potvrdenie zásielky.
-
Do poľa Identifikácia odosielateľa zadajte identifikáciu odosielateľa, ktorého chcete zrušiť.
-
Kliknutím začiarknite nasledujúce políčka:
-
Zrušiť odosielateľa
-
Zrušiť objednávku
-
-
Kliknite na tlačidlo Dokončiť. Potom zatvorenie Obrazovka s potvrdením odoslania (40.117.00) .
Riešenie 5
Odstránenie prispôsobení pre obrazovku odosielateľov (40.110.00) . Postupujte podľa nasledujúcich krokov:
-
Zatvorenie všetkých obrazoviek okrem obrazovky odosielateľov (40.110.00) .
-
V ponuke prispôsobiť kliknite na položku prispôsobiť režim.
-
V ponuke prispôsobiť kliknite na položku odstrániť zmeny na obrazovke.
-
Kliknite na tlačidlo Ánoa potom na tlačidlo OK.
-
Zatvorenie obrazovky odosielateľov (40.110.00) . Potom otvorte obrazovku.
Riešenie 6
Zmeňte poradie odosielateľov na objednávku, ktorú rozpoznal Správca procesov. Postupujte podľa nasledujúcich krokov. Poznámka: Skôr než začnete postupovať podľa pokynov v tomto postupe, skontrolujte, či máte úplnú záložnú kópiu databázy, ktorú môžete obnoviť, ak sa vyskytne problém.
-
Na obrazovke Process Manager (40.400.00) kliknite na položku zastaviť.
-
Pomocou analyzátora Microsoft SQL Query alebo Microsoft SQL Server Management Studio spustite príslušný príkaz v databáze aplikácie.
-
-
Microsoft SQL Server 7,0
SELECT "execADG_Release_For_Update" "+ rtrim (CpnyID) +" '; ' '; ' "+ rtrim (ShipperID) +" ' "from SOSHIPHEADER, kde NextFunctionID =" 4043000 "and NextFunctionClass =" 0200 "
-
Microsoft SQL Server 2000 alebo Microsoft SQL Server 2005 alebo Microsoft SQL Server 2008
NASTAVIŤ QUOTED_IDENTIFIEROFF vyberte položku "exec ADG_Release_For_Update" "+ rtrim (CpnyID) +" '; ' '; ' "+ rtrim (ShipperID) +" ' "from SOSHIPHEADER whereNextFunctionID =" 4043000 "and NextFunctionClass =" 0200 "
-
-
Skopírujte výsledky výpisu do nového okna. Vylúčiť všetky záhlavia stĺpcov alebo riadky počtu riadkov. Potom spustite nový príkaz na opätovné zaradenie odosielateľov, ktorí sú uvedení v zozname.Poznámka: Nasledujúci príkaz je príkladom výsledkov, ktoré by ste skopírovali.
exec ADG_Release_For_Update ' 0060 ', ' ', ' s 0009868 '
-
Na obrazovke Process Manager (40.400.00) kliknite na položku Spustiť.
Riešenie 7
Zrušenie odosielateľa. Postupujte podľa nasledujúcich krokov:
-
V zozname modulov kliknite na položku správa objednávok.
-
Na table správa objednávok kliknite na položku odosielatelia v časti vstup.
-
Na karte Ďalšie informácie kliknutím začiarknite políčko zrušené a potom kliknite na tlačidlo Dokončiť.