Vzťahuje sa naWindows 7 Enterprise Windows 7 Home Basic Windows 7 Home Premium Windows 7 Professional Windows 7 Starter Windows 7 Ultimate Windows Server 2008 R2 Datacenter Windows Server 2008 R2 Enterprise Windows Server 2008 R2 Standard Windows Vista Enterprise 64-bit Edition Windows Vista Home Basic 64-bit Edition Windows Vista Home Premium 64-bit Edition Windows Vista Ultimate 64-bit Edition Windows Vista Business Windows Vista Business 64-bit Edition Windows Vista Business N Windows Vista Business N 64-bit Edition Windows Vista Enterprise Windows Vista Home Basic Windows Vista Home Basic N Windows Vista Home Basic N 64-bit Edition Windows Vista Home Premium Windows Vista Starter Windows Vista Ultimate Windows Server 2008 Datacenter without Hyper-V Windows Server 2008 Enterprise without Hyper-V Windows Server 2008 for Itanium-Based Systems Windows Server 2008 Standard without Hyper-V Windows Server 2008 Datacenter Windows Server 2008 Enterprise Windows Server 2008 Standard

Príznaky

V počítači so systémom Windows Vista, Windows 7, Windows Server 2008 alebo Windows Server 2008 R2, zobrazí nasledujúce chybové hlásenie:

STOP 0x00000050 (parameter1, parameter2, parameter3, parameter4) PAGE_FAULT_IN_NONPAGED_AREA

Poznámky

  • Parametre v tomto chybovom hlásení sa líšia v závislosti od konfigurácie počítača.

  • Nie všetky chyby "Stop 0x00000050" spôsobujú tento problém. Tento problém sa vyskytuje, keď službu Server spracováva niektoré SMB žiadosti z niektorých vzdialených počítačov.

Príčina

Príčinou tohto problému s časovaním v ovládača služby Server. Tento problém časovania zahŕňa operácia, ktorá pridáva nové relácie SMB globálnej relácie tabuľky a operácia zatvorí relácie SMB. V tomto časovaním ovládač služba Server synchronizuje Tieto operácie správne. Keď sa prejaví toto správanie, relácie SMB sa pridá do tabuľky globálnej relácie po odstránení relácie. Preto zápis globálnej relácie medzi tabuľkami uvoľniť pamäť. Keď je prístupný uvoľnené pamäte, zobrazí sa chybové hlásenie Stop, ktoré je spomenuté v časti "Príznaky".

Riešenie

Informácie o rýchlej oprave

Od spoločnosti Microsoft je k dispozícii podporovaná rýchla oprava. Táto rýchla oprava je však určená iba opravu problému, ktorý je popísaný v tomto článku. Rýchlu opravu použite len v systémoch, v ktorých sa vyskytuje problém popísaný v tomto článku. Táto rýchla oprava môže byť ďalej testovaná. Ak nie ste výrazne ovplyvnení týmto problémom, odporúčame vám počkať na ďalšiu aktualizáciu softvéru, ktorá bude obsahovať túto rýchlu opravu.Ak je rýchla oprava k dispozícii na stiahnutie, na začiatku tohto článku databázy Knowledge Base sa nachádza časť „K díspozícii je rýchla oprava na stiahnutie“. Ak sa táto časť nezobrazuje, obráťte sa na oddelenie služieb zákazníkom a technickej podpory spoločnosti Microsoft a požiadajte o poskytnutie tejto rýchlej opravy.Poznámka: Ak sa vyskytnú ďalšie problémy alebo ak je potrebné riešiť problémy, je možné, že budete musieť vytvoriť samostatnú servisnú požiadavku. Na ďalšie žiadosti o podporu a problémy, ktoré sa netýkajú tejto konkrétnej rýchlej opravy, sa vzťahujú zvyčajné poplatky za poskytnutie technickej podpory. Úplný zoznam telefónnych čísel služieb zákazníkom spoločnosti Microsoft a podpora alebo vytvoriť samostatnú servisnú požiadavku, nájdete na webovej lokalite spoločnosti Microsoft:

Poznámka: Formulár "Prevzatie dostupnej rýchlej opravy" sa zobrazuje pre jazyky, pre ktoré je rýchla oprava k dispozícii. Ak nemôžete nájsť požadovaný jazyk, znamená to, že rýchla oprava nie je pre tento jazyk k dispozícii.

Požiadavky

Ak chcete použiť túto rýchlu opravu, používate jeden z nasledujúcich operačných systémov v počítači:

  • Windows Vista

  • Windows 7

  • Windows Server 2008

  • Windows Server 2008 R2

Informácie o databáze Registry

Ak chcete použiť rýchlu opravu v tomto balíku, nemáte robiť žiadne zmeny v databáze registry.

Požiadavka na reštartovanie

Musíte reštartovať počítač po použití tejto rýchlej opravy.

Informácie o nahradení rýchlej opravy

Táto rýchla oprava nenahrádza predchádzajúcu rýchlu opravu.

Informácie o súboroch

Globálna verzia tejto rýchlej opravy inštaluje súbory, ktorých atribúty sú uvedené v nasledujúcich tabuľkách. Dátumy a časy jednotlivých súborov sú uvedené vo formáte UTC (Coordinated Universal Time). Dátumy a časy pre tieto súbory v lokálnom počítači sú zobrazené v miestnom čase a podľa aktuálneho nastavenia funkcie prechodu na letný čas. Dátumy a časy sa okrem toho môžu zmeniť aj pri vykonávaní určitých operácií so súbormi.

Windows Vista a Windows Server 2008 súbor informácií poznámky

Dôležité upozornenie: Rýchle opravy systémov Windows Vista a Windows Server 2008 sa nachádzajú v rovnakých balíkoch. Avšak iba "Windows Vista" je uvedené na stránke žiadosti o rýchlu opravu. Ak chcete požiadať o opravu hotfix, ktorá je určená pre jeden alebo oba operačné systémy, vyberte rýchlu opravu, ktorá je uvedená v časti "Windows Vista" na stránke. Vždy si pozrite časti "Vzťahuje sa na" v článkoch zistiť skutočný operačný systém, daná rýchla oprava určená.

  • Súbory vzťahujúce sa na konkrétny produkt, SR_Level (RTM, SPn), a priečinok služby (LDR, GDR) je identifikovať na základe kontroly čísel verzií súborov tak, ako je uvedené v nasledujúcej tabuľke.

  • Service Pack 1 je integrovaný do verziou Windows Server 2008. Medzníky RTM sa preto vzťahujú iba na systém Windows Vista. Medzníky RTM sa 6.0.0000. xxxxx číslo verzie.

  • Súbory typu MANIFEST (.manifest) a súbory MUM (.mum) ktoré sa inštalujú pre jednotlivé prostredia, sú uvedené samostatne v sekcii "Ďalší súbor informácie pre systém Windows Server 2008 a Windows Vista". Súbory MUM a súbory MANIFEST a priradené súbory katalógu zabezpečenia (.cat), sú mimoriadne dôležité na zachovanie stavu aktualizovaných súčastí. Súbory katalógov zabezpečenia, pre ktoré nie sú uvedené atribúty, sú podpísané digitálnym podpisom spoločnosti Microsoft.

Potrebujete ďalšiu pomoc?

Chcete ďalšie možnosti?

Môžete preskúmať výhody predplatného, prehľadávať školiace kurzy, naučiť sa zabezpečiť svoje zariadenie a ešte oveľa viac.