Vzťahuje sa na
Exchange Server 2019 Exchange Server 2016

Príznaky

Microsoft Exchange Server 2019 alebo 2016 servera Exchange, Predpokladajme, že nastavíte web proxy server, ktorý používa Exchange Server pripojiť na Internet pomocou parametra InternetWebProxy a nie je priamy prístup na internet. Zistíte, že pripojenie OAuth vždy zlyhá, ak môžete vyskúšať pomocou rutiny cmdlet Test-OAuthConnectivity aj v prípade, že pripojenie je v poriadku.

Príčina

Tento problém sa vyskytuje, pretože cmdlet Test-OAuthConnectivity nerešpektuje InternetWebProxy nastavenia na serveri Exchange. Preto ak Exchange Server blokuje pripojenie na internet priamo, sa nebude správne otestovanie OAuth.

Stav

Spoločnosť Microsoft potvrdzuje, že ide o problém v produktoch spoločnosti Microsoft, ktoré sú uvedené v tomto článku v časti Informácie v tomto článku sa týkajú nasledujúcich produktov.

Riešenie

Tento problém vyriešiť, nainštalujte nasledujúce aktualizácie:Exchange Server 2019 nainštalovať kumulatívnej aktualizácii 1 pre Exchange Server 2019 alebo neskôr Kumulatívna aktualizáciapre Exchange Server 2019.

Exchange Server 2016, nainštalujte Kumulatívna aktualizácia 12 pre Exchange Server 2016 alebo neskôr Kumulatívna aktualizácia pre 2016 servera Exchange.

Odkazy

Informácie o terminológii, ktorú spoločnosť Microsoft používa na popis aktualizácií softvéru.

Potrebujete ďalšiu pomoc?

Chcete ďalšie možnosti?

Môžete preskúmať výhody predplatného, prehľadávať školiace kurzy, naučiť sa zabezpečiť svoje zariadenie a ešte oveľa viac.