Podpora pre Windows 7 sa skončila 14. januára 2020
Odporúčame vám prejsť na počítač s Windowsom 11, aby ste naďalej dostávali aktualizácie zabezpečenia od spoločnosti Microsoft.
Microsoft Security Essentials v automatickej súčinnosti so službou Microsoft Update zabezpečuje udržiavanie definícií vírusov a spyware v aktualizovanom stave.
Príznaky
Tu sú niektoré bežné problémy s automatickými aktualizáciami:
-
Zobrazujú sa chybové hlásenia s informáciou o zlyhaní aktualizácií.
-
Pri hľadaní aktualizácií sa zobrazí chybové hlásenie s informáciou, že aktualizácie definícií vírusov a spyware nemožno nájsť, stiahnuť alebo nainštalovať.
-
Aktualizácie zlyhajú napriek tomu, že ste pripojení na internet.
-
Aktualizácie sa neinštalujú automaticky podľa plánu.
Príčina
Najčastejšími príčinami problémov s aktualizáciami sú problémy s pripojením na internet. Ak ste online, problém môže byť spôsobený konfliktmi v nastavení Windows Internet Explorera.
Riešenie
Poznámka: Na vykonanie týchto krokov musíte ukončiť Internet Explorer. Preto si ich vytlačte, zapíšte alebo skopírujte do iného súboru a potom si túto tému pridajte do záložiek na budúce použitie.
Krok 1: Obnovte pôvodné nastavenie Internet Explorera
-
Ukončite všetky otvorené programy vrátane Internet Explorera.
Poznámka: Obnovením tohto nastavenia v Internet Exploreri sa odstránia dočasné súbory, súbory cookie, história prehľadávania a online heslá. Neodstránia sa však obľúbené položky.
-
Kliknite na tlačidlo Štart, do poľa Spustiť vyhľadávanie zadajte reťazec inetcpl.cpl a potom stlačte kláves Enter.
-
V dialógovom okne Možnosti internetu kliknite na kartu Rozšírené.
-
V časti Obnoviť pôvodné nastavenia programu Internet Explorer kliknite na tlačidlo Obnoviť a potom znova na tlačidlo Obnoviť.
-
Počkajte, kým Internet Explorer dokončí obnovenie pôvodného nastavenia, a potom kliknite na tlačidlo OK.
-
Otvorte Internet Explorer.
-
Otvorte aplikáciu Microsoft Security Essentials, kliknite na kartu Aktualizácia a potom na položku Aktualizovať. Ak problém pretrváva, prejdite na ďalší krok.
Krok 2: Nastavte Internet Explorer ako predvolený prehliadač
-
Ukončite všetky otvorené programy vrátane Internet Explorera.
-
Kliknite na tlačidlo Štart, do poľa Spustiť vyhľadávanie zadajte reťazec inetcpl.cpl a potom stlačte kláves Enter.
-
V dialógovom okne Možnosti internetu kliknite na kartu Programy.
-
V časti Predvolený webový prehľadávač kliknite na položku Predvoliť. Kliknite na tlačidlo OK.
-
Otvorte Microsoft Security Essentials. Kliknite na kartu Aktualizácia a potom na položku Aktualizovať. Ak problém pretrváva, prejdite na ďalší krok.
Krok 3: Skontrolujte, či máte v PC nastavený správny dátum a čas
-
Otvorte Microsoft Security Essentials.
-
Ak prijaté chybové hlásenie obsahuje kód 0x80072f8f, problém je pravdepodobne spôsobený nesprávnym nastavením dátumu alebo času v PC.
-
Ak chcete obnoviť nastavenie dátumu alebo času v počítači, postupujte podľa krokov v téme Oprava rozbitých odkazov na pracovnej ploche a bežných úloh údržby systému.
Krok 4: Premenujte priečinok Software Distribution (Distribúcia softvéru) v počítači
-
Zastavenie služby automatických aktualizácií
-
Kliknite na tlačidlo Štart, kliknite na položku Spustiť, zadajte reťazec services.msc a kliknite na tlačidlo OK.
-
Kliknite pravým tlačidlom myši na službu Automatické aktualizácie a potom kliknite na položku Zastaviť.
-
Minimalizujte modul Služby.
-
-
Ak prijaté chybové hlásenie obsahuje kód 0x80072f8f, problém je pravdepodobne spôsobený nesprávnym nastavením dátumu alebo času v PC.
-
Premenujte adresár SoftwareDistribution takto:
-
Kliknite na tlačidlo Štart, kliknite na položku Spustiť, zadajte reťazec cmd a kliknite na tlačidlo OK.
-
Zadajte reťazec cd %windir% a stlačte kláves Enter.
-
Zadajte reťazec ren SoftwareDistribution SDTemp a stlačte kláves Enter.
-
Zadajte výraz Exit a potom stlačte kláves Enter.
-
-
Spustite službu automatických aktualizácií takto:
-
Maximalizujte modul Služby.
-
Kliknite pravým tlačidlom myši na službu Automatické aktualizácie a potom kliknite na položku Spustiť.
-
Zavrite okno modulu Služby.
-
Krok 5: Obnovte pôvodné nastavenie nástroja na aktualizáciu antivírusového programu Microsoft v PC
-
Kliknite na tlačidlo Štart, položku Všetky programy, položku Príslušenstvo, potom kliknite pravým tlačidlom myši na položku Príkazový riadok a potom vyberte položku Spustiť ako správca.
-
V okne Príkazový riadok zadajte tieto príkazy a po každom príkaze stlačte kláves Enter:
-
Cd\
-
Cd program files\microsoft security essentials
-
Mpcmdrun –removedefinitions –all
-
Ukončiť
-
-
Reštartujte PC.
-
Otvorte aplikáciu Microsoft Security Essentials, kliknite na kartu Aktualizácia a potom na položku Aktualizovať. Ak problém pretrváva, prejdite na ďalší krok.
Krok 6: Manuálne nainštalujte aktualizácie definícií vírusov a spyware
-
Ak používate 32-bitovú verziu operačného systému Windows, Stiahnite si najnovšie aktualizácie manuálne na lokalite http://go.Microsoft.com/fwlink/?LinkID=87342.
-
Ak používate 64-bitovú verziu operačného systému Windows, Stiahnite si najnovšie aktualizácie manuálne na lokalite http://go.Microsoft.com/fwlink/?LinkId=87341.
Kliknite na položku Spustiť. Najnovšie aktualizácie sa manuálne nainštalujú do PC.
Krok 7: Kontaktujte technickú podporu
Ak vám uvedené kroky nepomohli vyriešiť problém, obráťte sa na technickú podporu. Ďalšie informácie nájdete v téme oddelenie podpory pre zákazníkov.