Du kan använda funktionen OMFEL för att hitta och hantera fel i en formel. OMFEL returnerar ett värde som du anger om en formel utvärderas till ett fel. annars returneras resultatet av formeln.

Syntax

OMFEL(värde; värde_om_fel)

Syntaxen för funktionen OMFEL har följande argument:

  • värde    Obligatoriskt. Detta är det argument som genomsöks efter fel.

  • value_if_error    Obligatoriskt. Det värde som returneras om formeln utvärderas till ett fel. Följande feltyper utvärderas: #SAKNAS!, #VÄRDEFEL!, #REFERENS!, #DIVISION/0!, #OGILTIGT!, #NAMN? eller #NULL!.

Kommentarer

  • Om värde eller value_if_error cell är en tom cell behandlar OMFEL det som ett tomt strängvärde ("").

  • Om värde är en matrisformel returnerar OMFEL en matris med resultat för varje cell i det område som anges i värde. Se det andra exemplet nedan.

Exempel

Kopiera exempeldata i följande tabell och klistra in dem i cell A1 i ett nytt Excel-kalkylblad. Om du vill att formlerna ska visa resultat markerar du dem, trycker på F2 och sedan på Retur.

Kvot

Antal sålda enheter

210

35

55

0

23

Formel

Beskrivning

Resultat

=OMFEL(A2/B2; "Fel i beräkningen")

Söker efter fel i formeln i det första argumentet (dividera 210 med 35), hittar inga fel och returnerar formelresultatet.

6

=OMFEL(A3/B3; "Fel i beräkningen")

Söker efter fel i formeln i det första argumentet (dividera 55 med 0), hittar en division med 0-fel och returnerar värde_om_fel.

Fel i beräkningen

=OMFEL(A4/B4; "Fel i beräkningen")

Söker efter fel i formeln i det första argumentet (dividera "" med 23), hittar inga fel och returnerar formelresultatet.

0

Exempel 2

Kvot

Antal sålda enheter

Proportioner

210

35

6

55

0

Fel i beräkningen

23

0

Formel

Beskrivning

Resultat

=C2

Söker efter fel i formeln i det första argumentet i det första elementet av matrisen (A2/B2 eller dividera 210 med 35), hittar inga fel och returnerar formelresultatet.

6

=C3

Söker efter fel i formeln i det första argumentet i det andra elementet i matrisen (A3/B3 eller dividera 55 med 0), hittar en division med 0-fel och returnerar värde_om_fel.

Fel i beräkningen

=C4

Söker efter fel i formeln i det första argumentet i det tredje elementet av matrisen (A4/B4 eller dividera "" med 23), hittar inga fel och returnerar formelresultatet.

0

Obs! Om du har en aktuell version av Microsoft 365kan du ange formeln i den övre vänstra cellen i utdataområdet och sedan trycka på RETUR för att bekräfta formeln som en dynamisk matrisformel. Annars måste formeln anges som en äldre matrisformel genom att först välja utdataområdet, ange formeln i den övre vänstra cellen i utdataområdet och sedan trycka på CTRL+SKIFT+RETUR för att bekräfta. I Excel infogas klammerparenteser i början och slutet av formeln åt dig. Mer information om matrisformler finns i Riktlinjer för och exempel på matrisformler.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community eller få support i Answers-communityn.

Behöver du mer hjälp?

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Gå med i Microsoft Office Insiders

Hade du nytta av den här informationen?

Hur nöjd är du med översättningskvaliteten?
Vad påverkade din upplevelse?

Tack för din feedback!

×