Logga in med Microsoft
Logga in eller skapa ett konto.
Hej,
Välj ett annat konto.
Du har flera konton
Välj det konto som du vill logga in med.
Spara en Excel-arbetsbok för kompatibilitet med tidigare versioner av Excel

Du har uppgraderat till en ny version av Excel och inser att du ska dela arbetsböcker med andra som ännu inte har uppgraderat. Genom att köra Kompatibilitetskontroll kan du identifiera funktioner eller information som kanske inte är tillgängliga i en tidigare version, och du kan sedan lösa några av problemen innan du delar arbetsboken med andra.

Spara en fil i .xls-format och granska problem som rapporteras av kompatibilitetskontrollen

Följ anvisningarna nedan:

  1. Klicka > exportera > ändra filtyp.

    Ändra filtyp på fliken Exportera

  2. Dubbelklicka på Excel 97-2003-arbetsbok (*.xls) under Filtyper för arbetsböcker.

    Formatet Excel 97-2003-arbetsbok

  3. I popup-fönstret Spara som väljer du en mapp för arbetsboken.

  4. Skriv ett nytt filnamn i rutan Filnamn (eller använd det som redan finns där).

  5. Klicka på Spara.

  6. Om kompatibilitetskontrollen visas granskar du eventuella kompatibilitetsproblem som hittades.

    Kompatibilitetskontroll som visa problem med mindre återgivningsnedsättning

    Med länken Sök kommer du till den platsen i kalkylbladet, och med länken Hjälp kommer du till information om problemet och möjliga lösningar.
     

Meddelanden: 

  • I den nya versionen Excel öppnas den arbetsbok som du just .xls i kompatibilitetsläge. Fortsätt att arbeta i det läget om du planerar att skicka arbetsboken fram och tillbaka till andra som ska öppna den i den tidigare versionen av Excel.

  • När du inte längre behöver bakåtkompatibilitet klickar du på Arkiv > Info> Konvertera för att konvertera arbetsboken till det senaste filformatet så att du kan dra nytta av nyheter i Excel.

Kör kompatibilitetskontrollen för Excel 2007 och senare

Om du vill kontrollera om en arbetsbok är kompatibel med Excel 2007 eller 2010 kör du Kompatibilitetskontroll manuellt första gången du sparar arbetsboken. Ange sedan att Kompatibilitetskontroll ska köras varje gång du sparar arbetsboken.

Följ anvisningarna nedan:

  1. Klicka på Arkiv > Info > Felsök.

    Kontrollera kompatibilitet

  2. Välj Kontrollera kompatibilitet.

  3. Om du hädanefter vill kontrollera kompatibiliteten automatiskt markerar du rutan Kontrollera kompatibilitet när arbetsboken sparas.
     

    Tips: Du kan också ange vilka versioner Excel du vill inkludera när du kontrollerar kompatibilitet. Alla versioner är markerade som standard, så avmarkera bara kryssrutan för de versioner du inte vill ha med.

    Kompatibilitetskontroll som visar versioner som ska kontrolleras

    Om några problem hittas kommer du till den platsen i kalkylbladet med länken Sök, och med länken Hjälp kommer du till information om problemet och möjliga lösningar.

Använda Access för att kombinera datakällor för datafunktioner som använder flera tabeller

Obs!: Du kan också använda funktionen LETARAD i Excel för att åtgärda problemet, men processen är lite komplicerad och blir mer komplicerad allt eftersom antalet datakällor att kombinera ökar.

Excel 2010 och tidigare versioner har inte stöd för datafunktioner som analyserar flera tabeller, eftersom de Excel-versionerna inte har en datamodell. Om arbetsboken innehåller sådana funktioner kan du förbereda dem för användning i tidigare versioner genom att kombinera funktionens datakällor till en enda tabell och sedan använda den nya tabellen som datakälla.

Ett sätt är att kombinera datakällorna och återskapa dem som en fråga i Access, som du sedan importerar till arbetsboken. Så här går det till:

  1. Importera varje ursprunglig datakälla i Access som en ny tabell.

  2. I Excel öppnar du dialogrutan Relationer genom att klicka på Data > Dataverktyg > relationer och anteckna relationerna mellan de ursprungliga datakällorna.

  3. Återskapa alla relationer i Access.

  4. Skapa en fråga i Access som innehåller alla fält som Excel behöver.

  5. I Excel du frågan till ett nytt kalkylblad som en tabell.

När dina data finns i en tabell i Excel kan du välja den tabellen som datakälla för de datafunktioner som har använt flera tabeller, eller återskapa datafunktionerna och välja den nya tabellen som datakälla.

Behöver du mer hjälp?

Du kan alltid fråga en expert i Excel Tech Community eller få support i Answers-communityn.

Se även

Excel formatering och funktioner som inte överförs till andra filformat

Kompatibilitetsproblem med kalkylblad

Behöver du mer hjälp?

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Gå med i Microsoft Office Insiders

Hade du nytta av den här informationen?

Hur nöjd är du med språkkvaliteten?
Vad påverkade din upplevelse?

Tack för din feedback!

×