Utgivningsdatum:
12 oktober 2021

Version:
.NET Framework 3.5 och 4.8

I uppdateringen från den 12 oktober 2021 för Windows 10 version 1809 och Windows Server innehåller version 2019 kumulativa förbättringar av tillförlitligheten i .NET Framework 3.5 och 4.8. Vi rekommenderar att du använder den här uppdateringen som en del av dina regelbundet underhållsarbete. Innan du installerar den här uppdateringen finns mer information i avsnitten Krav förkrav för omstart.

Förbättringar av kvalitet och tillförlitlighet

CLR

- Den befintliga minnestryckets algoritm som används i GC. AddMemoryPressure API utlöser indikering av GC för aggressivt. Den här uppdateringen innehåller en alternativ algoritm som är mindre aggressiva. Ett program kan registrera sig för den nya algoritmen genom att ange:

COMPlus_GCNewMemoryPressure miljövariabel till 1

Det här gäller för alla program som använder GC. AddMemoryPressure API.

Common Language Runtime (CLR)

Mer information om den här uppdateringen

Följande artiklar innehåller ytterligare information om den här uppdateringen i samband med enskilda produktversioner.

  • 5006765 Beskrivning av den kumulativa uppdateringen för .NET Framework 3.5, 4.7.2 och 4.8 för Windows 10 version 1809 (KB5006765)

Hämta den här uppdateringen

Installera den här uppdateringen

Utgivningskanal

Tillgänglig

Nästa steg

Windows Uppdatering och Microsoft Update

Ja

Om du vill ladda ned och installera den här uppdateringen går du Inställningar > uppdatering & säkerhets- > Windows uppdateringoch väljer sedan Sök efter uppdateringar.

Microsoft Update Catalog

Ja

Om du vill hämta det fristående paketet för den här uppdateringen går du till webbplatsen för Microsoft Update-katalogen.

Windows Server Update Services (WSUS)

Ja

Den här uppdateringen synkroniseras automatiskt med WSUS om du konfigurerar produkter och klassificeringar enligt följande:

Produkt:Windows 10 version 1809 och Windows Server, version 2019

Klassificering: Uppdateringar

Filinformation

En lista över de filer som tillhandahålls i den här uppdateringen finns i filinformation för kumulativ uppdatering.

Krav

Du måste ha installerat .NET Framework 3.5 eller 4.8 för att kunna använda den här uppdateringen.

Krav för omstart

Du måste starta om datorn när du har tillämpat den här uppdateringen om några berörda filer används. Vi rekommenderar att du avslutar .NET Framework program innan du använder den här uppdateringen.

Så här får du hjälp och support för den här uppdateringen

Kända problem i den här uppdateringen

Microsoft känner för närvarande inte till några problem i den här uppdateringen.

Behöver du mer hjälp?

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Microsoft Insiders

Hade du nytta av den här informationen?

Hur nöjd är du med språkkvaliteten?
Vad påverkade din upplevelse?

Tack för din feedback!

×