KB3173666-.NET Framework 3,5 krävs när du konfigurerar SQL Server 2016 som sekundärt för leverans av transaktions logg

Symptom

Tänk dig följande situation:

  • Du installerar SQL Server 2016 på datorn.

  • Du använder överföring av transaktions logg och konfigurerar SQL Server 2016 som sekundär.

I det här scenariot när du startar ett LSCopy -jobb på den sekundära kan du stöta på fel utan att loggat fel. Om du redigerar LSCopy -jobbet under SQL Server Agent på sekundärt, kopierar och klistrar du in det fullständiga sqllogship. exe -kommandot i kommando raden och trycker sedan på RETUR, så visas .NET Framework 3,5.Obs! När du har installerat .NET Framework 3,5 och startat om servern i det här scenariot fungerar LSCopy -och LSRestore -jobben som de ska.

Lösning

Korrigeringen för det här problemet ingår i följande kumulativa uppdatering för SQL Server:

Kumulativ uppdatering 1 för SQL Server 2016

Varje ny kumulativ uppdatering för SQL Server innehåller alla snabb korrigeringar och alla säkerhets korrigeringar som ingick i den föregående kumulativa uppdateringen. Kolla in de senaste kumulativa uppdateringarna för SQL Server:

Senaste kumulativa uppdateringen för SQL Server 2016

Status

Microsoft har bekräftat att det här är ett problem i Microsoft-produkterna som nämns i "gäller".

Referenser

Lär dig mer om terminologin som används av Microsoft för att beskriva program varu uppdateringar.

Behöver du mer hjälp?

Utöka dina kunskaper
Utforska utbildning
Få nya funktioner först
Anslut till Microsoft Insiders

Hade du nytta av den här informationen?

Tack för din feedback!

Tack för din feedback! Det låter som att det kan vara bra att koppla dig till en av våra Office-supportrepresentanter.

×