We couldn’t sign you in
Select the account you want to use.

#REF! hatası, formülün geçerli olmayan bir hücreye başvurduğunu gösterir. Bu çoğunlukla formülün başvurduğu hücrelerin silinmesi veya üzerlerine başka bir şey yapıştırılması durumunda olur.

Aşağıdaki örnek, E sütununda =TOPLA(B2,C2,D2) formülünü kullanır.

=TOPLA(B2,C2,D2) gibi açık hücre başvuruları kullanan formüller, bir sütunun silinmesi durumunda #BAŞV! hatası verebilir.

B, C veya D sütununu silmeniz #BAŞV! hatasına neden olur. Bu örnekte C sütununu (2007 Satışları) siliyoruz ve şimdi formül =TOPLA(B2,#BAŞV!,C2) oluyor. Bunun gibi açık hücre başvuruları kullanır (birbirinden virgülle ayrılmış olarak her hücreye tek tek başvurarak) ve başvurulan bir satır veya sütunu silerseniz, Excel bunu çözemez ve dolayısıyla #BAŞV! hatası döndürür. İşlevlerde açık hücre başvuruları kullanımının önerilmemesinin birincil nedeni budur.

Bir sütunun silinmesi nedeniyle oluşan #BAŞV! hatası örneği.

Çözüm

  • Satır veya sütunları yanlışlıkla sildiyseniz, hemen Hızlı Erişim Araç Çubuğu'nda Geri Al düğmesine tıklayarak (veya CTRL+Z tuşlarına basarak) bunları geri yükleyebilirsiniz.

  • Formülü, tek tek hücreler yerine bir aralık başvurusu (=TOPLA(B2:D2) gibi) kullanacak şekilde ayarlayın. Şimdi toplama aralığının içindeki herhangi bir sütunu silebilirsiniz ve Excel formülü otomatik olarak ayarlar. Ayrıca, satırların toplamı için =TOPLA(B2:B5) formülünü de kullanabilirsiniz.

Aşağıdaki örnekte , =DÜŞEYARA(A8,A2:D5,5,YANLIŞ) bir #REF! hatasını verir çünkü 5. sütundan döndürülecek bir değer arar, ancak başvuru aralığı A:D'dir ve bu da yalnızca 4 sütundur.

Yanlış aralığa sahip DÜŞEYARA formülü örneği.  Formül: =VLOOKU(A8,A2:D5,5,YANLIŞ).  DÜŞEYARA aralığında beşinci sütun olmadığından, 5 bir #REF neden olur! hatası oluşur.

Çözüm

Aralığı daha büyük olacak şekilde ayarlayın veya sütun arama değerini başvuru aralığıyla eşleşecek şekilde küçültün. =DÜŞEYARA(A8,A2:E5,5,YANLIŞ) ve =DÜŞEYARA(A8,A2:D5,4,YANLIŞ) geçerli başvuru aralıkları olabilir.

Bu örnekte =İnDİS(B2:E5,5,5) formülü bir #REF! hatasını verir çünkü İnDİS aralığı 4 satır 4 sütundur, ancak formül 5. satır ve 5. sütundaki değerleri döndürmek ister.

Geçersiz aralık başvurusu içeren bir İNDİS formülü örneği.  Formül =İNDİS(B2:E5,5,5) ancak aralık yalnızca 4 satıra 4 sütundur.

Çözüm

Satır ve sütun başvurularını İNDİS arama aralığı içinde kalacak şekilde ayarlayın. =İNDİS(B2:E5,4,4) formülü geçerli bir sonuç döndürebilir.

Aşağıdaki örnekte, DOLAYLI işlevi kapalı olan bir çalışma kitabına başvurmayı denediğinden #BAŞV! hatasına neden olur.

Kapalı bir çalışma kitabına yapılan DOLAYLI başvuru nedeniyle oluşan #BAŞV! hatası örneği.

Çözüm

Başvuruda bulunan çalışma kitabını açın. Dinamik dizi işlevine sahip kapalı bir çalışma kitabına başvurursanız aynı hatayla karşılaşırsınız.

Bağlı çalışma kitaplarındaki tablo ve sütun adlarına yönelik yapılandırılmış başvurular desteklenmez.

Bağlantılı çalışma kitaplarına yönelik hesaplanan başvurular desteklenmez.

Hücrelerin taşınması veya silinmesi geçersiz bir hücre başvurusuna neden oldu veya işlev başvuru hatası döndüriyor.

#BAŞV! hatası döndüren bir Nesne Bağlama ve Ekleme (OLE) bağlantısı kullandıysanız, bağlantının çağırdığı programı başlatın.

Not: OLE, programlar arasında bilgi paylaşmak için kullanabileceğiniz bir teknolojidir.

#BAŞV! hatasıyla karşılaşırsanız, önce doğru konuya başvurarak emin olun. Hala bir #REF alıyorsanız! hatasıyla karşılaşırsanız, Microsoft 365 belgelerinde dış içeriği engelleme veya engellemeyi kaldırma bölümünde açıklandığı gibi Dış içerik için Güven Merkezi Ayarlarınızı denetleyin.

Not: Dinamik Veri Değişimi (DDE),Microsoft Windows tabanlı programlar arasında veri alışverişi için oluşturulmuş bir protokoldür.

Makro Sorunları

Çalışma sayfasında bir makro işlevin üzerindeki hücreye başvuran bir işlev girerse ve işlevi içeren hücre 1. satırdaysa, işlev #REF! çünkü 1. satırın üzerinde hiç hücre yok. Bağımsız değişkenin geçerli olmayan bir hücreye mi yoksa hücre aralığına mı başvurduğunu görmek için işlevi denetleyin. Bu durum hesaba katmak için Visual Basic Düzenleyicisi'ndeki (VBE) makronun düzenlenmesi gerekebilir.

Daha fazla yardım mı gerekiyor?

Excel'de canlı ve ücretsiz yanıtlar alın

Sorularınızı Excel Teknoloji Topluluğuuzmanlarına sorabilir veya Yanıt topluluğu içinden destek alabilirsiniz.

Ayrıca Bkz:

Excel’deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerde hataları algılama

Excel işlevleri (alfabetik)

Excel işlevleri (kategoriye göre)

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Insider'Microsoft Office katılın

Bu bilgi yararlı oldu mu?

Dil kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?

Geri bildiriminiz için teşekkürler!

×