Önemli: Daha Excel 2016, Excel Mobile ve Web için Excel araLIKLIK işlevinin yerine ARALIKLIK.ARALIKÇIT işlevinin yerine başka bir işlevi kullanın. Geriye dönük uyumluluk için BİRLEŞTİR hala kullanılabilse de, çok daha güçlü bir işlev olan ARALIKBİRLEŞTİR işlevini kullanmayı dikkate almalısınız.

Bu sorunla karşılaştığınız en yaygın senaryolardan #VALUE! hatası olan BIRE BIRLEM! gibi hata içeren bir hücre başvurusu içeren bir dize #VALUE.

Aşağıdaki örnekte, D2, E2 ve F2'yi birleştirmek istiyoruz ve E2'de #DEĞER! hatası var.

BİRLEŞTİR işlevinde #DEĞER! hatası

E2'deki hata, işlevin #DEĞER! hatası görüntülenmesine neden olur. Başarılı bir şekilde çalışması için, bu hatayı hata dışında bir değerle değiştirmeniz gerekir. Hücre başvurusunda hata olup olmadığını denetleyen ve hata varsa, hatanın yerine 0 değerinin gösterildiği bir metin dizesi görüntüleyen bir formül oluşturabilirseniz (veya 0 yerine kendi metninizi koyabilirsiniz, ancak bu durumda metninizi tırnak içine almanız gerekir: "Metniniz").

Şöyle bir formül çalışır:

=EĞER(EHATALIYSA(E2),BİRLEŞTİR(D2," ",0," ",F2))

#DEĞER! hatasını düzeltme

Bu nasıl çalışır? EĞER işlevi EĞERHATA işlevini kullanarak E2'de hata olup olmadığını denetler; hata varsa, BİRLEŞTİR işlevi D2, E2 ve F2 değerlerini birleştirir (işlev hatayı 0 ile değiştirir) ve sonuçta elde edilen metin dizesini görüntüler. Formülde değerleri ayırmaya yardımcı olmak için boşlukların (“ “) kullanıldığına da dikkat edin.

Excel 2003 ve daha eski sürümlerde #DEĞER! hatası olan BİRLEŞTİR işlevini düzeltme

TE000130376 veya daha eski sürümlerde #DEĞER! hatasını Office Excel 2003 eski sürümlerde Geçiş Formülü Değerlendirme (TFE) seçeneğinin işaretini Excel. Bir hücreyi başka bir #VALUE! hatası konusunda altı çizilen adımları izleyin.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğuuzmanlarına sorabilir veya Yanıt topluluğu içinden destek alabilirsiniz.

Ayrıca Bkz:

#DEĞER! hatasını düzeltme

BİRLEŞTİR işlevi

ARALIKBİRLEŞTİR işlevi

Excel’deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerde hataları algılama

Tüm Excel işlevleri (alfabetik)

Tüm Excel işlevleri (kategoriye göre)

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Microsoft Insider 'a katılın

Bu bilgi yardımcı oldu mu?

Çeviri kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?

Geri bildiriminiz için teşekkür ederiz!

×