Microsoft hesabıyla oturum açın
Oturum açın veya hesap oluşturun.
Merhaba,
Farklı bir hesap seçin.
Birden çok hesabınız var
Oturum açmak istediğiniz hesabı seçin.

Bu konu başlığı altında, EĞERSAY ve ÇOKEĞERSAY işlevlerindeki #DEĞER! hatasının yaygın nedenleri listelenir.

Sorun: Formül kapalı bir çalışma kitabındaki hücrelere başvuruyor

Kapalı bir çalışma kitabındaki hücreye veya aralığa başvuran EĞERSAY/ÇOKEĞERSAY işlevleri #DEĞER! hatasıyla sonuçlanır.

Not: Bu, EDEBİ, ÇOKE EXCEL gibi diğer birçok işlevde bilinen bir sorundur. Bkz. E TOPLA, EĞER EĞER COUNT VE EĞERBLANK işlevleri #VALUE! hatası 'ne bakın.

Çözüm: Formülde belirtilen bağlantılı çalışma kitabını açın ve F9'a basarak formülü yenileyin.

Ayrıca, bir dizi formülünde TOPLA ve EĞER işlevlerini birlikte kullanarak bu sorunu giderebilirsiniz. Bkz. E TOPLA, EĞER EĞER COUNT VE EĞERBLANK işlevleri #VALUE! hatası 'ne bakın.

Sorun: Dize 255 karakteri aşıyor

Çözüm: Mümkünse dizeyi kısaltın. Dizeyi kısaltamıyorsanız, değeri birden çok dizeye bölmek için BİRLEŞTİR işlevini veya Ve (&) işlecini kullanın. Örneğin,

  • =EĞERSAY(B2:B12,"uzun dize"&"başka bir uzun dize")

İşlevlerle ilgili bir sorunuz mu var?

Excel topluluk forumuna soru gönderin

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğuuzmanlarına sorabilir veya Yanıt topluluğu içinden destek alabilirsiniz.

Ayrıca Bkz:

#DEĞER! hatasını düzeltme

EĞERSAY işlevi

ÇOKEĞERSAY işlevi

EĞER işlevi: İç içe formüller ve hatalardan kaçınma

Gelişmiş EĞER işlevleri ile ilgili bir video izleyin

Excel’deki formüllere genel bakış

Bozuk formülleri önleme

Formüllerde hataları algılama

Tüm Excel işlevleri (alfabetik)

Tüm Excel işlevleri (kategoriye göre)

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Insider'Microsoft Office katılın

Bu bilgi yararlı oldu mu?

Dil kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?

Geri bildiriminiz için teşekkürler!

×