İşleçler formülde öğeler üzerinde gerçekleştirmek istediğiniz hesaplama türünü belirtir; örneğin toplama, çıkarma, çarpma veya bölme. Bu makalede, işleçlerin bir hesaplamada öğeler üzerinde nasıl davranacaklarını varsayılan sırada öğrenirsiniz. Bu sırayı ayraç kullanarak nasıl değiştirycenizi de öğrenirsiniz.

İşleç türleri

Dört tür hesaplama işleci vardır: Aritmetik, karşılaştırma, metin birleştirme ve başvuru.

Toplama, çıkarma veya çarpma gibi temel matematik işlemlerini gerçekleştirmek veya sayıları birleştirmek ve sayısal sonuçlar üretmek için, bu tablodaki aritmetik işleçleri kullanın.

Aritmetik işleç

Anlamı

Örnek

+ (artı işareti)

Toplama

=3+3

– (eksi işareti)


Çıkarma Olumsuzlama

=3–1
=–1

* (yıldız işareti)

Çarpma

=3*3

/ (ileri eğri çizgi)

Bölme

=3/3

% (yüzde işareti)

Yüzde

=%20

^ (şapka işareti)

Üs

=

Aşağıdaki tabloda yer alan işleçlerle iki değeri karşılaştırabilirsiniz. İki değer, bu işleçler kullanılarak karşılaştırıldığında, sonuç DOĞRU veya YANLIŞ mantıksal bir değerdir.

Karşılaştırma işleci

Anlamı

Örnek

= (eşit işareti)

Eşittir

=A1=B1

> (büyüktür işareti)

Büyüktür

=A1>B1

< (küçüktür işareti)

Küçüktür

=A1<B1

>= (büyüktür veya eşittir işareti)

Büyüktür veya eşittir

=A1>=B1

<= (küçüktür veya eşittir işareti)

Küçüktür veya eşittir

=A1<=B1

<> (eşit değildir işareti)

Eşit değildir

=A1<>B1

Tek bir metin parçası & için ve (veya) dizesini kullanarak bir veya birden çok metin dizesini bir veya daha fazla metin dizesini bir hale yazın.

Metin işleci

Anlamı

Örnek

& (ve işareti)

Bir sürekli metin değeri üretmek için, iki değeri bağlar veya arttır.

="North"&"wind"

Hesaplamalar için hücre aralıklarını bu işleçlerle birleştirin.

Başvuru işleci

Anlamı

Örnek

: (iki nokta üst üste)

İki başvuru arasındaki bütün hücrelere, bu iki başvuruyu da içermek üzere, bir başvuru veren aralık operatörü

=TOPLA(B5:B15)

, (virgül)

Birden çok başvuruyı tek bir başvuruda birleştiren union işleci.

=TOPLA(B5:B15,D5:D15)

(boşluk)

Kesişim işleci, iki başvuruda ortak olan hücrelere başvuru üretendir.

=TOPLA(B7:D7 C6:C8)

# (pound)

# simgesi çeşitli bağlamlarda kullanılır:

  • Hata adının parçası olarak kullanılır.

  • İşle ilgili yetersiz alanı göstermek için kullanılır. Çoğu durumda, içerikler düzgün görünene kadar sütunu genişletebilirsiniz.

  • Dinamik dizi formülünde tüm bir aralığın başvurusu için kullanılan taşmış aralık işleci.

  • Sayı yerine metinlere başvurulduğunda oluşan #DEĞER!

  • #####

  • =TOPLA(A2#)

@ (at)

Formülde örtülü kesişimi göstermek için kullanılan başvuru işleci. 

=@A1:A10

=TOPLA(Tablo1[@[Ocak]:[Aralık]])

Excel'in formüllerdeki işlemleri yapma sırası

Bazı durumlarda hesaplamanın gerçekleştir çalışma sırası formülün hesaplanması değerini etkileyebilir; dolayısıyla sırayı anlamak ve görmeyi beklediğiniz sonuçları elde etmek için sırayı nasıl değiştirebilirsiniz? önemlidir.

Formüller verileri özel bir sırada hesaplar. Excel'de bir formül her zaman eşittir işaretiyle (=) başlar. Eşittir işareti, Excel karakterlerin bir formül oluşturduğunu söyler. Bu eşittir işaretinden sonra, hesaplama işleçleri tarafından ayrılmış bir dizi hesaplanacak öğe (işlenen) olabilir. Excel, formülleri formüldeki her işlecin özel sırasına göre soldan sağa doğru hesaplar.

Birden fazla işleci tek bir formülde birleştirirseniz, Excel, işlemleri aşağıdaki tabloda gösterilen sırayla yapar. Bir formül, aynı önceliğe sahip olan işleçler içeriyorsa, (örneğin, bir formül, hem bir çarpma işleci, hem de bir bölme işleci içeriyorsa), Excel, işleçleri soldan sağa doğru değerlendirir.

İşleç

Açıklama

: (iki nokta üst üste)

(tek boşluk)

, (virgül)

Başvuru işleçleri

Olumsuzlama (-1'deki gibi)

%

Yüzde

^

Üs

* ve /

Çarpma ve bölme

+ ve –

Toplama ve çıkarma

ve

İki metin dizesini köprüler (art arda bağlama)

=
< >
<=
>=
<>

Karşılaştırma

Değerlendirme sırasını değiştirmek için, formülün ilk olarak hesaplanacak olan parçasını ayraç içine alın. Örneğin, aşağıdaki formülde sonuç 11'tir, çünkü Excel toplamadan önce çarpmayı hesaplar. Formül önce 2 ile 3'ü çarpar ve sonra sonucu 5 ile çarpar.

=5+2*3

Buna karşılık, söz dizimsini değiştirmek için ayraç kullanırsanız, Excel 5 ile 2'ye 5'i ekler ve sonra 21 elde etmek için sonucu 3 ile çarpar.

=(5+2)*3

Aşağıdaki örnekte, formülün ilk bölümünü içine alan parantezler, Excel'yi önce B4+25'i hesaplamaya ve sonra da sonucu D5, E5 ve F5 hücrelerinde değerlerin toplamına bölmeye zorlar.

=(B4+25)/TOPLA(D5:F5)

Daha fazla bilgi edinmek için İşleç sırası ile ilgili Excel bu videoyu izleyin.

Formüller Excel formüllerin değerlerini nasıl dönüştürür?

Bir formül girerken, Excel işleç için belirli türde değerler bekler. Beklenenden farklı bir değer girersiniz, Excel değeri dönüştür olabilir.

Formül

Üretir

Açıklama

= "1"+"2"

3

Artı işareti (+) kullanırsanız, Excel sayıların olmasını bekler. Tırnak işaretleri "1" ve "2" ifadelerini metin değerleri olsa Excel metin değerlerini otomatik olarak sayılara dönüştürür.

= 1+"$4,00"

5

Formül sayı beklerken, Excel sayı için kabul edilen bir biçimde ise metni dönüştürür.

= "1/6/2001"-"5/1/2001"

31

Excel aa/d/yyyy biçimindeki metni tarih olarak yorumlar, tarihleri seri numaralara dönüştürür ve sonra aralarındaki farkı hesaplar.

=SQRT ("8+1")

Sayı yerine metinlere başvurulduğunda oluşan #DEĞER!

Excel "8+1" metni sayıya dönüştürüle Excel sayıya dönüştürülemesi nedeniyle sayıya dönüştürülemesi. Metni sayıya dönüştürmek ve 3 sonucu elde etmek için "8+1" yerine "9" veya "8"+"1" kullanabilirsiniz.

= "A"&TRUE

ATRUE

Metin beklendiği zaman, Excel ve YANLIŞ gibi mantıksal değerleri metne dönüştürür.

Daha fazla yardım mı gerekiyor?

Sorularınızı Excel Teknoloji Topluluğuuzmanlarına sorabilir veya Yanıt topluluğu içinden destek alabilirsiniz.

Ayrıca Bkz.

Daha fazla yardıma mı ihtiyacınız var?

Yeteneklerinizi geliştirin
Eğitimleri keşfedin
Yeni özellikleri ilk olarak siz edinin
Microsoft Insider 'a katılın

Bu bilgi yardımcı oldu mu?

Çeviri kalitesinden ne kadar memnunsunuz?
Deneyiminizi ne etkiledi?

Geri bildiriminiz için teşekkür ederiz!

×