开始使用 Excel 中的“获取和转换”功能

注意: 本文已完成其工作,随后将不再使用。 为防止出现“找不到页面”问题,我们将删除已知无效的链接。 如果创建了指向此页面的链接,请删除这些链接,以便与我们一起为用户提供通畅的 Web 连接。

可将 Excel 中的“获取和转换”用于搜索数据源,创建连接,然后按照可满足需要的方式调整数据(如删除列、更改数据类型或合并表格)。 调整数据之后,可以共享发现或使用查询创建报表。

通过 4 个步骤Excel连接和转换数据:1 - 连接、2 - 转换、3 - 合并和 4 - 管理。

如果按照顺序看这些步骤,将发现其通常按照下面的方式进行:

  • 连接 - 建立与云中、服务内或本地的数据之间的连接

  • 转换 - 调整数据以满足你的需求;原始源保持不变

  • 组合 – 基于多个数据源创建数据模型,获得数据的独特见解

  • 管理- 查询完成后,可以保存、复制或将其用于报表

无论何时连接或转换数据或者将数据与其他数据源组合,“获取和转换”功能均会在每一步调用“查询编辑器“记录,并按照需求进行调整。 通过“查询编辑器”还可以撤销、恢复、更改顺序或修改任何步骤… 这样你就可以按照需要的方式调整所连接数据的视图。

可以根据你的需要,使用“获取和转换”功能创建简单或复杂的查询。 添加查询步骤时,“查询编辑器”在后台工作,以创建单独的指令来执行你的命令。 这些指令将以 M 语言创建。 喜欢数据脚本所具有的强大功能和灵活性的用户可以使用“高级编辑器”手动创建或更改 M 语言查询。 本文后续内容将会更详细地介绍查询编辑器高级编辑器

可从“数据”选项卡 >“获取数据”>“选择数据源”开始新的查询。 如果未看到“获取数据”按钮,请从“数据”选项卡中选择“新建查询”按钮。 以下是从数据库源中进行选择的示例。

获取和转换“从数据库”选项

注意:  Power Query还可用于早期版本的 Excel 加载项,以及Power BI。 若要在先前版本的 Excel 中查看实际的“Power Query”,请查看 Power Query 快速入门

连接

可以使用查询连接至单一数据源,例如 Access 数据库,或者也可以连接至多个文件、数据库、OData 源或网站。 随后可以使用自己唯一的组合将所有这些数据源聚集在一起,挖掘出你未曾发现的见解。

从"数据"选项卡上的"获取&转换"部分选择"获取数据 (如果没有看到"获取数据"按钮,则选择"新建查询) "你将看到许多可供选择的数据源,包括文件,如Excel工作簿或文本/CSV文件、数据库(如Access、SQL Server、OracleMySQL、Azure服务(如HDInsightBlob 存储)以及各种其他源,例如Web、SharePoint列表、Hadoop 文件、Facebook、Salesforce等。

注意: 可以在此处了解各个 Excel 版本中可用的数据源:“获取和转换”功能 (Power Query) 位于何处.

连接到数据源时,"获取&"会显示"导航器"窗格,用于编辑数据源的数据。 从导航器窗口中选择"编辑"时,"获取&转换"将启动查询编辑器,这是一个专用窗口,用于简化并显示数据连接以及所应用转换。 下一部分“转换”提供了与“查询编辑器”相关的更多信息。

转换

获取和转换”允许你按照有助于分析来自你的数据源的数据的方式,转换这些数据。 转换数据指的是按照可以满足你的需要的方式修改数据,例如,你可以删除列,更改数据类型或合并表格,这些操作全部都属于数据转换。 转换数据时,将集中处理你需要的形状,以便改善你的分析。 对一组或多组数据应用转换的过程称为调整数据。

Excel 使用专用的“查询编辑器”来帮助显示数据转换。 选择“数据”>“获取数据”,然后选择数据源,如工作簿或数据库,此时将会显示“导航器”窗口,可以通过此窗口选择要在查询中使用的表格。 选择表格时,“导航器”窗口的右侧窗格中将显示其数据预览。

获取和转换 > Power Query“导航”窗格

如果选择“加载”,则数据源将按原样导入 Excel 中。 如果选择"转换数据"选项,将启动"查询编辑器"。

Power Query 编辑器窗格

查询编辑器”将持续跟踪你对数据执行的所有操作。 “查询编辑器”记录并标记你对数据应用的每次转换或步骤。 无论转换是连接到数据源、删除列、合并还是 数据类型 更改,查询编辑器都跟踪"查询"窗格的"应用步骤"部分中设置操作。

对数据连接应用的转换共同构成查询

请务必知悉,在“查询编辑器”中定义的操作不会更改原始源数据。 相反,Excel 将记录连接或转换数据时你执行的每个步骤;一旦你调整完数据,它将拍摄优化后的数据集的快照,并将其放入工作簿中。

有许多转换可以应用于数据。 还可使用 M 语言和查询编辑器的高级编辑器 编写 自己的转换。 可以从查询编辑器的“主页”或“视图”选项卡打开“高级编辑器”,而你可以在其中修改与现有查询关联的 M 语言步骤。

Power Query“高级编辑器”窗格(使用 M 语言编辑)

创建查询完成之后,可从“主页”选项卡中选择“关闭并加载”,此时查询结果将加载到 Excel 中并且可用于新的工作簿选项卡。

了解有关转换的详细信息:

管理

保存包含查询的 Excel 工作簿时,也将自动保存该查询。 可以通过在“数据”选项卡上选择“查询和连接”来查看 Excel 工作簿中的所有查询。

Power Query“查询和连接”窗格

如果在"查询和连接"窗格中右键单击&名称,将看到多个选项。 例如,可以 复制 查询,这样无需更改原始查询即可更改查询的一些或所有元素;这就像创建查询模板,然后可以修改该模板以创建自定义数据集 - 例如,一个数据集用于零售,另一个数据集用于批发,另一个用于库存,所有这些数据集都基于相同的数据连接。

还可以“合并”或“追加”查询,从而将查询转化为可重复使用的构建块。

查询&连接右键单击菜单选项

还可以将工作簿发布到 Power BI,并创建可与组共享、自动刷新以及可以调整的联机报表。 若要将工作簿发布到 Power BI,请选择“文件”>“发布”>“发布到 Power BI”

注意: 工作簿必须保存到 OneDrive for Business才能将其发布到 Power BI。

详细了解如何 管理 查询:

需要更多帮助吗?

可随时在 Excel 技术社区中咨询专家,在解答社区获得支持,或在 Excel User Voice 上建议新功能或功能改进。

Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Office Insiders

Was this information helpful?

How satisfied are you with the translation quality?
What affected your experience?

Thank you for your feedback!

×