KB3170082 - 修复:升级到 SQL Server 2016 Master Data Services 时出现权限问题或失败

应用对象
SQL Server 2016 Enterprise - duplicate (do not use) SQL Server 2016 Enterprise Core - duplicate (do not use)

症状

此更新修复了以下问题:

  • 如果 Master Data Services (MDS) 数据库包含以“_Code”、“_Name”或“_ID”结尾的属性,则 MDS 数据库升级可能会失败。
  • 如果你在早期版本的 MDS 中使用成员权限,则成员权限可能无法正确升级,并且升级后可能会破坏成员权限。

解决方法

此问题已首先在 SQL Server 的以下累积更新中修复:

建议:安装 SQL Server 的最新累积更新

SQL Server 的每个新累积更新都包含上一个累积更新中包含的所有修补程序和所有安全修补程序。 建议下载并安装 SQL Server 的最新累积更新:

      

状态

Microsoft 已确认在 "适用于" 部分中所列的 Microsoft 产品中存在问题。

参考资料

了解 Microsoft 用于描述软件更新的术语。