症状
假设您使用 SQL Server 2016 或 2017。 当您使用 Hadoop 查询加密区域中的数据时,一切正常。 但是,大约 10 小时后,查询失败并在Dms_polybase.log生成以下错误消息。 虽然如果重启 PolyBase 服务可以解决此问题,但查询可能会在 10 小时后再次失败。
org.apache.hadoop.security.authentication.client.AuthenticationException: GSSException: 未提供有效凭据 (机制级别: 找不到任何 Kerberos tgt) 。
原因
出现此问题的原因是 PolyBase 不会自动续订 Kerberos 票证授予票证 (tgt) 。 票证将在创建后 10 小时过期。
状态
Microsoft 已确认在 "适用于" 部分中所列的 Microsoft 产品中存在问题。
解决方法
此问题已在 SQL Server 的以下累积更新中修复:
关于 SQL Server 的累积更新:
SQL Server 的每个新累积更新都包含上一个累积更新中包含的所有修补程序和所有安全修补程序。 查看 SQL Server 的最新累积更新:
参考资料
了解 Microsoft 用于描述软件更新的术语。