症状
假设你在 Microsoft SQL Server 2016 或 2017 中在分区表上创建了 XML 索引或extended_indexes ((如空间索引) )。 当您尝试使用 TRUNCATE TABLE WITH PARTITIONS 命令截断分区表的分区时,例如,“Truncate Table PartitionedTable by using (PARTITIONS (PartitionNumber) ) ”,操作可能会失败。
解决方法
此问题已在 SQL Server 的以下累积更新中修复:
关于 SQL Server 的累积更新:
SQL Server 的每个新累积更新都包含上一个累积更新中包含的所有修补程序和所有安全修补程序。 查看 SQL Server 的最新累积更新:
状态
Microsoft 已确认在 "适用于" 部分中所列的 Microsoft 产品中存在问题。
参考资料
了解 Microsoft 用于描述软件更新的术语。