插入图表

应用对象
Visio Professional 2024 Visio Standard 2024 Visio Professional 2021 Visio Standard 2021 Visio Professional 2019 Visio Standard 2019 Visio 专业版 2016 Visio 标准版 2016

Visio 使用 Microsoft Excel 提供高级图表功能。 如果未安装 Excel,Visio 将会使用 Microsoft Graph 替代。

警告

目前,适用于 Visio 计划 2、Visio 2021 和 Visio 2019 的 Visio 桌面应用中出现了与图表相关的问题。 插入某些增强型元文件或图表可能会导致 Visio 突然停止运行。 打开包含某些增强型元文件或图表的 Visio 文件也可能导致 Visio 突然停止运行。 此问题在 2022 年 2 月更新后开始。 预计修复将在 2022 年 3 月更新中到位。 同时,作为解决方法,您可以转到“高级文件>选项”>并打开“禁用增强型元文件优化”。

可以通过以下两种方法之一向图表添加数据图表或图形:

  • 在图中创建新的图表或图形。 在 Visio 中创建新图表时,你将在 Excel 中编辑该图表的数据,但数据将与 Visio 文件一起保存。

    • 在“插入”选项卡上的“插图”组中,单击“图表”。
      嵌入的 Excel 工作簿随即添加到图表中,Visio 功能区将更改为包含 Excel 选项卡,这样你就可以使用图表了。 单击图表外部以编辑 Visio 绘图。 双击图表以再次使用图表进行 word。
      嵌入的 Excel 工作簿有两个选项卡:图表选项卡和数据选项卡。要添加数据,请单击标记为 Sheet1 的选项卡。 若要设置图表格式,请单击标记为 Chart1 的选项卡。 功能区上出现两个“ 图表工具 ”选项卡。 使用这些选项卡上的命令和库设置图表的格式。
  • 将 Excel 图表或图形粘贴到图表中,并链接到 Excel 文件中的数据。 从已保存的 Excel 文件复制图表并将其粘贴到图表中时,图表中的数据将链接到 Excel 文件。 若要更改图表中的数据,必须在 Excel 中对链接的工作表进行更改,然后刷新 Visio 图表中的数据。 Excel 工作表是一个单独的文件,不与 Visio 文件一起保存。

另请参阅

在 Visio 中创建饼图

在 Visio 中创建折线图

创建二维条形图

创建三维条形图